Subject: RE: Protocol Action: Agent Extensibility (AgentX) Protocol to Dra ft Standard

From: "Natale, Robert C (Bob)" <[email-masked]>
Date: Tue, 4 Dec 2001 15:28:56 -0500

Dave,

Of the 13 implementation reports submitted,
10 were public and 3 were private.  The full
text of the 10 public reports was posted to
the AgentX list at the time of submission.
I have not checked lately, but I believe that
info is still in the archives.

None of the 3 private reports raised any
significant issues with implementation or
interoperability.  (The requests for privacy
-- while not requiring any explanation --
were made for what can generally be summed
up as "business reasons" of varying (but
extremely benign) nature in each case.)

Cordially,

BobN
AgentX Chair

> -----Original Message-----
> From: David T. Perkins [mailto:[email-masked]]
> Sent: Tuesday, December 04, 2001 2:53 PM
> To: The IESG
> Cc: RFC Editor; Internet Architecture Board; [email-masked]
> Subject: Re: Protocol Action: Agent Extensibility (AgentX) Protocol to
> Draft Standard
> 
> 
> HI,
> 
> While I do not want to derail the agent-X work, I certainly find
> troubling the implementation report specified in the URL below.
> It (by itself) does not provide to me the sufficient detail
> to determine if the IETF requirements for advancement to draft
> were achieved. I do know the WG chair and many of the WG members
> and trust their good judgement. However, a page or two of additional
> documentation would go a long way in helping the historians
> determine that interoperability of all aspects was truely achieved
> and that the technology was deployed and found to be useful.
> 
> Regards,
> /david t. perkins
> 
> At 12:19 PM 12/4/2001 -0500, The IESG wrote:
> 
> 
> >The IESG has elevated the Agent Extensibility (AgentX) Protocol
> >(RFC2741) and Definitions of Managed Objects for Extensible 
> SNMP Agents
> >(RFC 2742) to Draft Standard.  These documents were the 
> product of the
> >SNMP Agent Extensibility Working Group.
> >
> >The contact persons are Bert Wijnen and Randy Bush.
> >
> >Technical Summary
> > 
> >  RFC2741 defines a standardized framework for extensible 
> SNMP agents.
> >  It defines processing entities called master agents and subagents,
> >  a protocol (AgentX) used to communicate between them, and the
> >  elements of procedure by which the extensible agent processes SNMP
> >  protocol messages.
> >
> >  RFC2742 defines a portion of the Management Information Base (MIB)
> >  for use with network management protocols in the Internet 
> community.
> >  In particular, it describes objects managing SNMP agents that use
> >  the Agent Extensibility (AgentX) Protocol.
> >
> >Working Group Summary
> >
> >  The working group collected 13 implementation and interoperability
> >  reports. The WG implementation report from the WG chair is at:
> >
> >     http://www.ietf.org/IESG/Implementations/AGENTX-IMPLEMENTATION
> >
> >  These reports demonstrated that all AgentX features have been
> >  implemented by two or more independent implementations and that
> >  sub-agents from one implementation are able to interoperate
> >  with master agents from an independent implementation.  A number
> >  of the implementations are found in well-known commercial SNMP
> >  products; several are found in widely distributed academic and/or
> >  "open source" projects; implementations beyond those with filed
> >  reports are known to exist.
> >
> >  Neither the referenced implementation reports nor the WG Last Call
> >  identified any changes to the these RFCs that are required for
> >  implementation or interoperability.
> >
> >  The working group consensus is that these documents are ready for
> >  advancement to Draft Standard.
> >
> >Protocol Quality
> >
> >  The documents have been reviewed for the IESG by Randy Bush and
> >  Bert Wijnen 
>

---

From: "David T. Perkins" <[email-masked]>
Date: Tue, 04 Dec 2001 13:14:22 -0800

HI,

Thanks Bob! It looks like I was overreacting to seeing just the
summary without hearing that there were documentation in the WG
email archives.

Sorry,
/david t. perkins