Subject: [Agentx] problem when connection will break between master and sub agent by master agent.

From: jigar contractor <[email-masked]>
Date: Thu, 16 Mar 2006 14:04:01 -0800 (PST)

Hi,
   
       I am writing application which uses AgentX protocol to register agentx subagent to master agent. I am stuck at following position:
   
     I am able to connect with master agent using (JAX). Now suddenly master agent went down. But I am not able to get from AgentXSubagent that this connection  is down. Is there any way in protocol to know whether this connection is down. I request you to focus on this problem. 
   
     Thanks,
   
  Jigar.

---------------------------------
 Yahoo! Mail
 Use Photomail to share photos without annoying attachments.

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 16 Mar 2006 14:55:03 -0800

Hi -

> From: "jigar contractor" <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, March 16, 2006 2:04 PM
> Subject: [Agentx] problem when connection will break between master and subagent by master agent.
...
>      I am able to connect with master agent using (JAX).
> Now suddenly master agent went down.
> But I am not able to get from AgentXSubagent that this connection  is down.
> Is there any way in protocol to know whether this connection is down.
...

I don't know whether the specific API you are using supports this,
but at a protocol level, this is a case where TCP keepalives actually
make sense.  Since master/sub-agent communications are normally
system-internal, and only rarely over a local network, and, except in
interoperability testing, almost never over wide area network, the
usual reasons for avoiding keepalives or minimizing their frequency
do not apply.

Randy

---

From: Frank Fock <[email-masked]>
Date: Fri, 17 Mar 2006 00:14:58 +0100

Hi Jigar,

You can use the AgentX Ping PDU to detect connection loss
with the master agent.

Best regards,
Frank

jigar contractor wrote:
> Hi,
>  
>      I am writing application which uses AgentX protocol to register 
> agentx subagent to master agent. I am stuck at following position:
>  
>    I am able to connect with master agent using (JAX). Now suddenly 
> master agent went down. But I am not able to get from AgentXSubagent 
> that this connection  is down. Is there any way in protocol to know 
> whether this connection is down. I request you to focus on this problem.
>  
>    Thanks,
>  
> Jigar.
> 
> ------------------------------------------------------------------------
> Yahoo! Mail
> Use Photomail 
> <http://pa.yahoo.com/*http://us.rd.yahoo.com/evt=38867/*http://photomail.mail.yahoo.com> 
> to share photos without annoying attachments.

-- 
AGENT++
http://www.agentpp.com
http://www.mibexplorer.com
http://www.mibdesigner.com

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 16 Mar 2006 15:37:02 -0800

Hi -

> From: "Frank Fock" <[email-masked]>
> To: "jigar contractor" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, March 16, 2006 3:14 PM
> Subject: Re: [Agentx] problem when connection will break between master andsub agent by master agent.
...
...

A better solution than TCP keepalives, particularly if you want to cover the case
where the TCP connection is still there but the application is out to lunch.

Randy