Subject: [Agentx] java subaget

From: "Vernekar, Ramakrishna Kashinath" <[email-masked]>
Date: Sat, 9 Sep 2006 15:00:18 +0530

Hi all

My subagent is in JAX and is able to connect to net-snmp. But when i try

to retrieve any values, i do not get anything. walk just finishes 

without ouputting any values for my mib 

did any body used jax subagent with net-snmp-5.3.0.1 with ipv6 address

please help me if ypu have any ideas.

Thanks in advance

---

From: Frank Fock <[email-masked]>
Date: Sat, 09 Sep 2006 20:01:40 +0200

Hi,

I would switch to SNMP4J-AgentX which is available
from http://www.snmp4j.org it is has a complete
AgentX implementation. AFAIK JAX only implements
a subset. The NET-SNMP AgentX implementation has
some bugs regarding handling search ranges correctly.
May be such a bug causes your problem? In
SNMP4J-AgentX I have implemented a work-around
for some of those bugs.

Regards,
Frank Fock

---

From: Frank Fock <[email-masked]>
Date: Sun, 10 Sep 2006 09:45:17 +0200

Hi Ram,

Since your question is not AgentX related, you
should address it to the NET-SNMP group/mailing list.
Probably the agent needs to be configured to listen
to the IPv6 address.

Regards,
Frank Fock

Vernekar, Ramakrishna Kashinath wrote:
> Hi 
> 
> Thanks for your quick response.
> 
> I am using net-snmp-5.3.0.1  for example
> 
> If I give snmpwalk -v2c -c public localhost oid (private mib implemented
> using jax tool kit)
> 
> It works fine
> 
> But same is not working if I give ipv6 address
>  snmpwalk -v2c -c public [ipv6 address] oid (private mib)
> 
> Regards
> Ram
> 
> 
> 
> -----Original Message-----
> From: Frank Fock [mailto:[email-masked]] 
> Sent: Saturday, September 09, 2006 11:32 PM
> To: Vernekar, Ramakrishna Kashinath
> Cc: [email-masked]
> Subject: Re: [Agentx] java subaget
> 
> Hi,
> 

-- 
AGENT++
http://www.agentpp.com
http://www.mibexplorer.com
http://www.mibdesigner.com

---

From: Frank Fock <[email-masked]>
Date: Sun, 10 Sep 2006 09:45:17 +0200

Hi Ram,

Regards,
Frank Fock

---

From: "Vernekar, Ramakrishna Kashinath" <[email-masked]>
Date: Sun, 10 Sep 2006 13:12:15 +0530

Hi 

It works fine

Regards
Ram

-----Original Message-----
From: Frank Fock [mailto:[email-masked]] 
Sent: Saturday, September 09, 2006 11:32 PM
To: Vernekar, Ramakrishna Kashinath
Cc: [email-masked]
Subject: Re: [Agentx] java subaget

Hi,

Regards,
Frank Fock

> please help me if ypu have any ideas.

atron.ietf.org with esmtp (Exim 4.43) id 1GMK69-0002Cb-9v
	for [email-masked]; Sun, 10 Sep 2006 03:51:25 -0400
Content-class: urn:content-classes:message
Subject: RE: [Agentx] java subaget
Date: Sun, 10 Sep 2006 13:12:15 +0530
From: "Vernekar, Ramakrishna Kashinath" <[email-masked]>
To: "Frank Fock" <[email-masked]>
Cc: [email-masked]

Hi 

It works fine

Regards
Ram

-----Original Message-----
From: Frank Fock [mailto:[email-masked]] 
Sent: Saturday, September 09, 2006 11:32 PM
To: Vernekar, Ramakrishna Kashinath
Cc: [email-masked]
Subject: Re: [Agentx] java subaget

Hi,

Regards,
Frank Fock