Subject: Re: "Web Addresses in HTML 5", URIs, URLs, IRIs

From: Mark Nottingham <[email-masked]>
Date: Mon, 23 Mar 2009 09:32:32 -0700

Hi Dan,

What's the intended venue and status for this work (if known)?

Cheers,

On 23/03/2009, at 9:13 AM, Dan Connolly wrote:

> This was, until recently, part of the HTML 5 spec. It's
> been suggested that it applies beyond HTML 5, e.g. XMLHTTPRequest,
> and perhaps Jabber etc.
>
>
> Web addresses in HTML 5
> Editor's Draft 20 March 2009
>
> Editors:
>    Dan Connolly, Midwest Web Sense LLC and W3C
>    C. M. Sperberg-McQueen, Black Mesa Technologies LLC
>
> Abstract
>
> This specification defines the handling of Web addresses for  
> Hypertext Markup Language (HTML) 5, the fifth major revision of the  
> core language of the World Wide Web. In this version, special  
> attention has been given to defining clear conformance criteria for  
> user agents in an effort to improve interoperability.
>
> Publication mechanics are a little goofy at this point; the 20 March
> draft is available at:
> http://homer.w3.org/~connolly/projects/urlp/raw-file/008373680cae/wah5/draft.html
>
> The 17 March draft is available attached to...
>
> "Web addresses in HTML 5" for review (ISSUE-56 urls-webarch) Dan  
> Connolly (Wednesday, 18 March)
> http://lists.w3.org/Archives/Public/public-html/2009Mar/0444.html
>
> -- 
> Dan Connolly, W3C http://www.w3.org/People/Connolly/
>
>

--
Mark Nottingham     http://www.mnot.net/

---

From: Dan Connolly <[email-masked]>
Date: Mon, 23 Mar 2009 09:13:00 -0700

Web addresses in HTML 5

Editors:

Abstract

This specification defines the handling of Web addresses for Hypertext 
Markup Language (HTML) 5, the fifth major revision of the core language 
of the World Wide Web. In this version, special attention has been given 
to defining clear conformance criteria for user agents in an effort to 
improve interoperability.

---

From: "Anne van Kesteren" <[email-masked]>
Date: Mon, 23 Mar 2009 17:57:31 +0100

> been suggested that it applies beyond HTML 5, e.g. XMLHTTPRequest,

I think this can address the longstanding issue for url() in CSS as well.  
I have a feeling the algorithm is also used for HTTP (though with a more  
limited input of course) as browsers handle spaces and other incorrect  
characters "fine" in e.g. the Location header.

-- 
Anne van Kesteren
http://annevankesteren.nl/

---

From: Dan Connolly <[email-masked]>
Date: Mon, 23 Mar 2009 10:30:21 -0700

> What's the intended venue and status for this work (if known)?

Not known. I suppose the purpose of my message is to research
the optimal venue and status.

It was published Feb 2009 in the W3C Recommendation track
as part of HTML 5
http://www.w3.org/TR/2009/WD-html5-20090212/infrastructure.html#urls

but it's not at all clear that people with expertise in URIs
are likely to discover it under the title "HTML 5".

So I'm here at the IETF (in person and on apps-discuss) trying
figure out who is interested to participate and what venue(s)
would work well/best.