Subject: Fwd: I-D Action:draft-nottingham-site-meta-05.txt

From: Lisa Dusseault <[email-masked]>
Date: Thu, 31 Dec 2009 08:55:29 -0800

FYI,

This document is currently in IESG Evaluation with a few DISCUSS
issues to be cleared.  One of the ADs asked whether this draft had
been widely reviewed and I wasn't sure it had been posted here though
it has definitely been discussed on HTTPBIS and in W3C lists.  This
draft proposes a namespace for a mechanism that can be useful for
HTTP-based applications, e.g. if it were available and accepted 5-10
years ago, it would have been an alternative for some of the
bootstrapping problems of WebDAV and CalDAV.

See also http://tools.ietf.org/html/draft-hammer-hostmeta-05 for an
example of use of this namespace.

Lisa

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Tue, Dec 29, 2009 at 2:45 PM
Subject: I-D Action:draft-nottingham-site-meta-05.txt
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

       Title           : Defining Well-Known URIs
       Author(s)       : M. Nottingham, E. Hammer-Lahav
       Filename        : draft-nottingham-site-meta-05.txt
       Pages           : 8
       Date            : 2009-12-29

This memo defines a path prefix for "well-known locations", "/.well-
known/" in selected URI schemes.

Status of this Memo

This Internet-Draft is submitted to IETF in full conformance with the
provisions of BCP 78 and BCP 79.

Internet-Drafts are working documents of the Internet Engineering
Task Force (IETF), its areas, and its working groups.  Note that
other groups may also distribute working documents as Internet-
Drafts.

Internet-Drafts are draft documents valid for a maximum of six months
and may be updated, replaced, or obsoleted by other documents at any
time.  It is inappropriate to use Internet-Drafts as reference
material or to cite them other than as "work in progress."

The list of current Internet-Drafts can be accessed at
http://www.ietf.org/ietf/1id-abstracts.txt.

The list of Internet-Draft Shadow Directories can be accessed at
http://www.ietf.org/shadow.html.

This Internet-Draft will expire on July 3, 2010.

Copyright Notice

Copyright (c) 2009 IETF Trust and the persons identified as the
document authors.  All rights reserved.

This document is subject to BCP 78 and the IETF Trust's Legal
Provisions Relating to IETF Documents
(http://trustee.ietf.org/license-info) in effect on the date of
publication of this document.  Please review these documents
carefully, as they describe your rights and restrictions with respect
to this document.  Code Components extracted from this document must
include Simplified BSD License text as described in Section 4.e of
the Trust Legal Provisions and are provided without warranty as
described in the BSD License.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-nottingham-site-meta-05.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Larry Masinter <[email-masked]>
Date: Thu, 31 Dec 2009 11:17:42 -0800

There's a lot of confusion about the use of the term
"metadata". In this case, the term is being used for
something that might more appropriately be seen as
"default metadata for resources at a site" rather
than "site metadata". I know it's not really the
job of this document to clear up all of the
confusion around metadata, but I think it would be
better if this document were to include at least a
sentence or two explaining how its use of "metadata"
is not a close match, for example, to the 
the primary definition in:
http://en.wikipedia.org/wiki/Metadata

or even 
http://www.w3.org/DesignIssues/Metadata.html
or 
http://www.w3.org/2001/tag/group/track/issues/63

Larry
--
http://larry.masinter.net

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lisa Dusseault
Sent: Thursday, December 31, 2009 8:55 AM
To: Apps Discuss
Subject: Fwd: I-D Action:draft-nottingham-site-meta-05.txt

FYI,

Lisa

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Tue, Dec 29, 2009 at 2:45 PM
Subject: I-D Action:draft-nottingham-site-meta-05.txt
To: [email-masked]

Status of this Memo

Copyright Notice

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
_______________________________________________
Apps-Discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 31 Dec 2009 14:15:14 -0700

Thanks Larry.

Metadata is a word or phrase, not a technical term. In the context of this draft, it generally means "information about".

One use case for these well-known locations may very well be "default metadata for resources at a site", which is close (but not exactly) what host-meta [1] is proposing. If someone defines a well-known location for "site metadata", that would be an acceptable use case as well, assuming it is better defined than just that. Both are valid and it would be wrong for the draft to allow one but not the other.

I don't see the need for the document to say anything more than it currently does. It would be a waste of everyone's time if the process of reviewing and approving registrations will involve a discussion of the metadata-ness of the proposed document.

EHL

[1] http://tools.ietf.org/html/draft-hammer-hostmeta

> From: [email-masked] [mailto:apps-discuss-
> [email-masked]] On Behalf Of Larry Masinter
> Sent: Thursday, December 31, 2009 11:18 AM
> To: Lisa Dusseault; Apps Discuss
> Subject: RE: I-D Action:draft-nottingham-site-meta-05.txt
> 
> There's a lot of confusion about the use of the term "metadata". In this case,
> the term is being used for something that might more appropriately be seen
> as "default metadata for resources at a site" rather than "site metadata". I
> know it's not really the job of this document to clear up all of the confusion
> around metadata, but I think it would be better if this document were to
> include at least a sentence or two explaining how its use of "metadata"
> is not a close match, for example, to the the primary definition in:
> From: [email-masked] [mailto:apps-discuss-
> [email-masked]] On Behalf Of Lisa Dusseault
> This document is currently in IESG Evaluation with a few DISCUSS issues to be
> cleared.  One of the ADs asked whether this draft had been widely reviewed
> and I wasn't sure it had been posted here though it has definitely been
> discussed on HTTPBIS and in W3C lists.  This draft proposes a namespace for a
> mechanism that can be useful for HTTP-based applications, e.g. if it were
> available and accepted 5-10 years ago, it would have been an alternative for
> some of the bootstrapping problems of WebDAV and CalDAV.
> 
> Internet-Drafts are working documents of the Internet Engineering Task
> Force (IETF), its areas, and its working groups.  Note that other groups may
> also distribute working documents as Internet- Drafts.
> 
> Internet-Drafts are draft documents valid for a maximum of six months and
> may be updated, replaced, or obsoleted by other documents at any time.  It
> is inappropriate to use Internet-Drafts as reference material or to cite them
> other than as "work in progress."
> 
> Copyright (c) 2009 IETF Trust and the persons identified as the document
> authors.  All rights reserved.
> 
> This document is subject to BCP 78 and the IETF Trust's Legal Provisions
> Relating to IETF Documents
> (http://trustee.ietf.org/license-info) in effect on the date of publication of
> this document.  Please review these documents carefully, as they describe
> your rights and restrictions with respect to this document.  Code
> Components extracted from this document must include Simplified BSD
> License text as described in Section 4.e of the Trust Legal Provisions and are
> provided without warranty as described in the BSD License.
> 
> implementation to automatically retrieve the ASCII version of the Internet-
> Draft.
> 
> 
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt