Subject: [apps-discuss] multipart/form-data

From: Larry Masinter <[email-masked]>
Date: Sun, 15 Sep 2013 01:22:50 -0700

I made an initial pass over updating multipart/form-data, see:
http://tools.ietf.org/html/draft-masinter-multipart-form-data-00 

initial diff from rfc 2388
http://tools.ietf.org/rfcdiff?url1=rfc2388&url2=draft-masinter-multipart-form-data-00.txt

and a repo
https://github.com/masinter/multipart-form-data

with issue tracker
https://github.com/masinter/multipart-form-data/issues

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 15 Sep 2013 10:57:14 +0200

Made a quick scan.

Nits:
s/proscriptive/prescriptive/
You have two references to HTML4.0 (one called html4).

I would kill Appendix B; RFC 2388 is not going away.

      --AaB03x
      content-disposition: form-data; name="field1"
      content-type: text/plain;charset=windows-1250
      content-transfer-encoding: quoted-printable
      Joe owes =80100.
      --AaB03x

You need an empty line before the "Joe owes" (unfortunately, this was turned into a page break in RFC 2388).

I think some clarification of the "can" in 3.2 is required.  Maybe say something like "the handling of file input fields that allow multiple files to be specified varies between browsers.  Some send these as sets of files (wrapping all the parts for the files in one multipart/mixed), some just send multiple form-data parts with the same "name" attribute.  HTML5 specifies the latter behavior."

(See:) http://www.whatwg.org/specs/web-apps/current-work/multipage/association-of-controls-and-forms.html#multipart-form-data

> In particular, this means that multiple files submitted as part of a single <input type=file multiple> element will result in each file having its own field; the "sets of files" feature ("multipart/mixed") of RFC 2388 is not used.

My view is that this use of multipart/mixed now qualifies for a NOT RECOMMENDED.

Thanks for doing this work!

Grüße, Carsten