Subject: [apps-discuss] The case of dotless domains - draft-moonesamy-dotless-domains-00

From: S Moonesamy <[email-masked]>
Date: Fri, 20 Sep 2013 07:50:28 -0700

Hi Sal, Murray,

I would like to request adoption of 
draft-moonesamy-dotless-domains-00 as an Appsawg draft.

Regards,
S. Moonesamy

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 20 Sep 2013 08:39:06 -0700

On Sep 20, 2013, at 7:50 AM, S Moonesamy <[email-masked]> wrote:

> I would like to request adoption of draft-moonesamy-dotless-domains-00 as an Appsawg draft.

This seems like a really bad idea. The IAB report already does a much better job of discussing the technical issues. Further, this document is about an event (the Charleston Road application) that may be resolved well before the RFC is published. Further still, it is not clear what practices are being proposed as "best".

If there is a desire for an RFC (as compared to a report), people should ask the IAB to publish theirs on the IAB track.

--Paul Hoffman

---

From: S Moonesamy <[email-masked]>
Date: Fri, 20 Sep 2013 23:28:24 -0700

Hi Paul,
At 08:39 20-09-2013, Paul Hoffman wrote:
>This seems like a really bad idea. The IAB report already does a 
>much better job of discussing the technical issues. Further, this 
>document is about an event (the Charleston Road application) that 
>may be resolved well before the RFC is published. Further still, it 
>is not clear what practices are being proposed as "best".
>
>If there is a desire for an RFC (as compared to a report), people 
>should ask the IAB to publish theirs on the IAB track.

Thanks for the comments.  As background information I performed an 
APPSDIR review about a week ago and I noticed that it mentioned 
"dotless domains".  I raised it as a minor issue ( 
http://www.ietf.org/mail-archive/web/apps-discuss/current/msg10404.html 
).  I followed up on the review.  An Area Director raised a question 
about a reference in his review and I commented about that.  I asked 
the APPSAWG Chairs whether they would consider adoption of the draft 
(see my message to the mailing list).

I don't understand the comment about the desire for a RFC.  I have 
been working on two other drafts where the next step was Last 
Call.  I put that effort on hold because of other IETF activities.

Section 1 is to provide some context.  I don't feel strongly about it.

I don't feel strongly about "best".  I can discuss about the intended 
status if the WG Chairs believe that it is necessary to do that at this stage.

Please note that I am okay if anyone says that "this is a bad 
idea".  I prefer not to comment about the IAB statement.  If the WG 
Chairs believe that it would be constructive to have that discussion 
I can comment.

I am not deriving any material benefit, directly or indirectly, 
through the draft.  Please note that if there are any question about 
conflict of interest I am willing to disclosure any information which 
anyone would like to know about.

Regards,
S. Moonesamy

---

From: "Jiankang Yao" <[email-masked]>
Date: Sun, 22 Sep 2013 17:52:43 +0800

I support SM's suggestion. With the explosive growth of new TLD names in ICANN or in DNS zone, it is reasonable to push this draft or simlar idea.
It is better that SM's draft can combine my draft http://tools.ietf.org/html/draft-yao-dnsop-tld-names-00.

Jiankang Yao

From: S Moonesamy
Date: 2013-09-20 22:50
To: Murray Kucherawy; Salvatore Loreto
CC: apps-discuss
Subject: [apps-discuss] The case of dotless domains - draft-moonesamy-dotless-domains-00
Hi Sal, Murray,

Regards,
S. Moonesamy

_______________________________________________
apps-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 23 Sep 2013 08:02:01 -0700

On Sep 20, 2013, at 11:28 PM, S Moonesamy <[email-masked]> wrote:

> Thanks for the comments.  As background information I performed an APPSDIR review about a week ago and I noticed that it mentioned "dotless domains".  I raised it as a minor issue ( http://www.ietf.org/mail-archive/web/apps-discuss/current/msg10404.html ).  I followed up on the review.  An Area Director raised a question about a reference in his review and I commented about that.  I asked the APPSAWG Chairs whether they would consider adoption of the draft (see my message to the mailing list).

It seems useful to have an RFC that defines "dotless domains" and lists the technical (and possibly political) problems with them. I believe that the IAB's report is a much better starting point than draft-moonesamy-dotless-domains.

> I don't understand the comment about the desire for a RFC.  I have been working on two other drafts where the next step was Last Call.  I put that effort on hold because of other IETF activities.

And I don't understand what that has to do with your proposal to advance this as a WG work item. The purpose of having a WG work item is to eventually publish one or more RFCs. I am proposing that effort be focused on the IAB, not draft-moonesamy-dotless-domains.

> Section 1 is to provide some context.  I don't feel strongly about it.

The same "context" is in the abstract. Maybe produce a draft that has what you really want in it?

> I don't feel strongly about "best".  I can discuss about the intended status if the WG Chairs believe that it is necessary to do that at this stage.

It is vastly different for a WG work item to be informational than standards track, particularly when discussing something with which a WG has little experience.

> Please note that I am okay if anyone says that "this is a bad idea".  I prefer not to comment about the IAB statement.  If the WG Chairs believe that it would be constructive to have that discussion I can comment.

It is a bad idea for this WG to produce a document that somewhat overlaps with the IAB report and somewhat does not, but is not clear where it does and does not. It is a bad idea to write a Best Current Practices document when we have no idea what the best current practices are.

> I am not deriving any material benefit, directly or indirectly, through the draft.  Please note that if there are any question about conflict of interest I am willing to disclosure any information which anyone would like to know about.

No one suggested any such benefit to you or the IAB.

--Paul Hoffman

---

From: S Moonesamy <[email-masked]>
Date: Mon, 23 Sep 2013 09:55:29 -0700

Hi Paul,
At 08:02 23-09-2013, Paul Hoffman wrote:
>It seems useful to have an RFC that defines "dotless domains" and 
>lists the technical (and possibly political) problems with them. I 
>believe that the IAB's report is a much better starting point than 
>draft-moonesamy-dotless-domains.

The reason I did not rely only on the RFCs mentioned in the IAB 
statement was because of a comment from John Klensin:

   "My personal bias is that, if the IAB starts making Statements about
    the implications of a technological choice, they should be comprehensive
    about the relevant subject."

I went through the specifications which are listed as Informational 
references in the draft.  I am aware of cases such as:

; QUESTION SECTION:
;io.                            IN      MX

;; ANSWER SECTION:
io.                     1       IN      MX      10 mailer2.io.

as they have been discussed previously within the Applications 
Area.  I preferred not to assume that there aren't any technical 
problems because of that.

>has what you really want in it?

[snip]

>It is vastly different for a WG work item to be informational than 
>standards track, particularly when discussing something with which a 
>WG has little experience.

The Abstract and Section 1 mentions that:

   "This memo discusses about the case of the dotless domains in terms of
    the technical standards published by the IETF."

Section 4 is about "Domain names in Application Protocols".  The 
protocols mentioned are:

   1. FTP
   2. HTTP
   3. IMAP
   4. SMTP
   5. XMPP

In my opinion the above-mentioned protocols are usually discussed 
within the Applications Area.

There was a thread on the SMTP mailing list where Dave Crocker commented that:

  'From ICANN SSAC SAC 053
   (www.icann.org/en/groups/ssac/documents/sac-053-en.pdf):

   "3.4  Electronic Mail One serious and prevalent concern is that
   dotless domains would not work with protocols that specify additional
   rules of what constitutes a legal domain. The most prominent example
   is the Simple Mail Transfer Protocol (SMTP) to deliver electronic
   mail. It requires at least two labels in the FQDN of a mail address.
   Thus standard-compliant mail servers would reject emails to addresses
   such as user at brand."

   I'm not seeing this requirement/limitation in RFC 5321. It merely 
requires an FQDN.

   Does anyone have an explanation for the assessment in the ICANN 
report that at
   least two levels are required?'

John Levine commented that "they goofed".  Tony Finch commented that 
ICANN may have looked at RFC 2821.

John Levine posted a comment to the IETF discussion mailing list:

   "The only reason this has come up is that one (1) of the 1900 new TLD
    applications has asked for a waiver to do a dotless domain, and that
    applicant happens to be Google applying for .SEARCH.  ICANN can just
    say no.  Or they might not even have to, since Google's is only one of
    four competing applicants for .SEARCH, and there is no reason to
    assume that they would necessarily be the winner at the end of the
    negotiations."

The context in the Abstract is similar to what John Levine 
wrote.  It's in the -00 version as that was, according to John 
Levine, the reason why the discussion started.

Jiankang Yao commented that:

   "With the explosive growth of new TLD names in ICANN or in DNS zone, it is
    reasonable to push this draft or similar idea."

and made a suggestion to combine his draft and mine.

In my opinion Jiankang understood that the my draft was about 
application protocols.

Regards,
S. Moonesamy