Subject: [apps-discuss] I-D Action: draft-masinter-multipart-form-data-01.txt

From: [email-masked]
Date: Fri, 20 Sep 2013 05:20:04 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Applications Area Working Group Working Group of the IETF.

	Title           : Returning Values from Forms: multipart/form-data
	Author(s)       : Larry Masinter
	Filename        : draft-masinter-multipart-form-data-01.txt
	Pages           : 9
	Date            : 2013-09-20

Abstract:
   This specification defines an Internet Media Type, multipart/form-
   data, which can be used by a wide variety of applications and
   transported by a wide variety of protocols as a way of returning a
   set of values as the result of a user filling out a form.  It
   replaces RFC 2388.

NOTE

   The Currently, XML source for this Internet Draft may be found in
   [1], as well as an issue tracker.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-masinter-multipart-form-data

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-masinter-multipart-form-data-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-masinter-multipart-form-data-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Julian Reschke <[email-masked]>
Date: Fri, 20 Sep 2013 14:40:32 +0200

Hi there,

<http://tools.ietf.org/html/draft-masinter-multipart-form-data-01#section-2.6> 
claims:

2.6. The _charset_ field

    Forms have the convention that the value of a form entry with entry
    name "_charset_" and type "hidden" is automatically set to the name
    of the form-charset.  In this case, the value of the default charset
    of each text/plain part without a charset parameter is the supplied
    value.

I wasn't aware if the auto-filling feature but it appears to be true. I 
supposed we should a reference to a spec where that is defined (HTML5 I 
guess?)

Best regards, Julian

---

From: Larry Masinter <[email-masked]>
Date: Fri, 20 Sep 2013 08:56:33 -0700

The goal is to describe it in this document, as a convention for anyone using multipart/form-data. 
Parsers of multipart/form-data need to be aware of both content-type;charset=.... as well as _charset_ values.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Julian Reschke
> Sent: Friday, September 20, 2013 5:41 AM
> To: [email-masked]
> Subject: [apps-discuss] _charset_ parameter, was I-D Action: draft-masinter-
> multipart-form-data-01.txt
> 
> Hi there,
> 
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Julian Reschke <[email-masked]>
Date: Fri, 20 Sep 2013 18:05:48 +0200

On 2013-09-20 17:56, Larry Masinter wrote:
> ...

Right. Right?

Is this a difference from application/x-www-form-urlencoded where the 
charset parameter isn't defined at all?

Best regards, Julian