Subject: Re: [arch-d] 2. thinking about an implementation

From: Peter Tomsu <[email-masked]>
Date: Mon, 26 Feb 2007 14:34:46 +0100

So you actually think this is the better solution? Just distributing  
the task?

Not sure

Peter

On 23.01.2007, at 14:28, Brian E Carpenter wrote:

> On 2007-01-22 18:50, Simon Leinen wrote:
>> Brian E Carpenter writes:
>>> Please note, though, that one of the more interesting criticisms of
>>> shim6 is that it asks end systems (e.g. server farms) to hold extra
>>> state per session. Moving state around does move heat dissipation
>>> around.
>> What amount of additional state are we talking about?
>
> I like Jari's answer, but I would suggest another way to look
> at it: instead of the site NAT (or PAT) having to hold state
> per active flow, each host will have to hold state per active
> flow. So the border box will get noticeably less hot and (in a
> server farm) the offload NICs will each get a little hotter.
>
>    Brian
>
> _______________________________________________
> Architecture-discuss mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/architecture-discuss

_______________________________________________
Architecture-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/architecture-discuss

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 26 Feb 2007 17:19:44 +0100

Peter,

If people are worried about bottleneck effects and
(literally) hot spots, distribution is surely something
to consider. That's an engineering question.

 From an architectural viewpoint, it seems quite important
to think carefully about what the end to end principle
actually says:

   "The function in question can completely and
    correctly be implemented only with the knowledge and help of the
    application standing at the endpoints of the communication system.
    Therefore, providing that questioned function as a feature of the
    communication system itself is not possible. (Sometimes an incomplete
    version of the function provided by the communication system may be
    useful as a performance enhancement.)"

[End-To-End Arguments in System Design, J.H. Saltzer,
D.P.Reed, D.D.Clark, ACM TOCS, Vol 2, Number 4, November 1984,
pp 277-288.]

If we continue to build things such that upper layers in end systems
need to know what address the upper layer at the other end sees,
this quote applies precisely to dynamic address changes.

    Brian

On 2007-02-26 14:34, Peter Tomsu wrote:
> So you actually think this is the better solution? Just distributing the 
> task?
> 
> Not sure
> 
> Peter
>