Subject: [arch-d] Please ignore this message

From: "Ray Denenberg" <[email-masked]>
Date: Mon, 23 Feb 2009 17:17:14 -0500

Sorry.  I've had a hell of a time trying to subscribe to this list, and I want to see if I've finally been able to.

---

From: "Ray Denenberg, Library of Congress" <[email-masked]>
Date: Mon, 23 Feb 2009 17:26:06 -0500

(This is intended to be part of the thread on version numbers.)

I just ran across this thread. I'm very much interested in the subject, not so much for protocols -- I agree with the sentiments expressed on versions for protocols -- but I'm interested in the issue of versions for formats.

Let's take an example. The MODS format for bibliographic metadata. 

Homepage at http://www.loc.gov/standards/mods/ and the current schema is http://www.loc.gov/standards/mods/v3/mods-3-3.xsd.

The latest version is 3.3. There are several earlier version, and, as is common practice: when we move to a new minor version (e.g. 3.2 to 3.3) instances of the earlier version conform to the new version (though not vice versa); when we move to a new major version (e.g. 3.3 to 4.0) all bets are off. There is a version attribute defined within the schema, a mandatory attribute for every instance.

Now, I am in the process of putting together a registration request for a mime type for MODS, "application/mods+xml". (Among other related formats. This is because people want to do content negotiation among the related formats. But let's not get into that or we'll get terribly sidetracked.)

Studying existing mime type registrations, I cannot find one in which the issue of different possible versions of a format is taken into consideration. 

For example, "application/xhtml+xml" is for xhtml 1.0, according to rfc 3236 . So how does that apply to xhtml 1.1? Is the statement in the rfc that it's for 1.0 just ignored? 

Clearly we don't want to be registering a mime type for every new version, so wouldn't it be better if the registration is independent of version? Could the version instead be indicated, for example by a mime parameter?

I'm very interested in thoughts on this.

--Ray Denenberg