Subject: [armd] Are there any issues with Address Resolution for Multicast (besides ARP/ND) in Data Centers?

From: Linda Dunbar <[email-masked]>
Date: Wed, 22 Feb 2012 23:43:35 +0000

Here are some (non-ARP/ND) multicast applications which people stated on the [email-masked]<mailto:[email-masked]> that are used in data centers:

Joel Jaeggli: ganglia is a common datacenter multicast user vertica clusters can use broadcast for communication and span hundreds of nodes, however unwise that approach may be.

Aldrin Isaac :  Any DC with applications performing heavy pub-sub are more than likely using multicast.  I am aware of many companies for whom multicast is critical and enabled on their DC routers.

Michael Smith: Microsoft is configurable for IGMP Multicast and Unicast.  There are also the other LB protocols such as CARP, VRRP, GLBP, HSRP, etc.

There are also other people stating that multicast has to be disabled in massive sized data centers simply because the multicast improvement is limited, which is not worth the effort in massive sized data centers.

In the context of address resolution, does multicast address resolution have different issues than uni-cast address resolution?

Any comments?

Linda

---

From: Patrick Frejborg <[email-masked]>
Date: Thu, 23 Feb 2012 09:51:51 +0200

Linda,

if you do a search with the words "cluster, multicast" and "NIC
teaming, multicast" you'll find a bunch of solutions that make use of
link local multicast.
These shouldn't be processed by the router, neither should they
traverse over the L3 boundary but will be seen by the router connected
to the L2 domains.

Patrick

On Thu, Feb 23, 2012 at 1:43 AM, Linda Dunbar <[email-masked]> wrote:
>
>
> Here are some (non-ARP/ND) multicast applications which people stated on the
> [email-masked] that are used in data centers:
>
>
>
> Joel Jaeggli: ganglia is a common datacenter multicast user vertica clusters
> can use broadcast for communication and span hundreds of nodes, however
> unwise that approach may be.
>
>
>
> Aldrin Isaac :  Any DC with applications performing heavy pub-sub are more
> than likely using multicast.  I am aware of many companies for whom
> multicast is critical and enabled on their DC routers.
>
>
>
> Michael Smith: Microsoft is configurable for IGMP Multicast and Unicast.
> There are also the other LB protocols such as CARP, VRRP, GLBP, HSRP, etc.
>
>
>
> There are also other people stating that multicast has to be disabled in
> massive sized data centers simply because the multicast improvement is
> limited, which is not worth the effort in massive sized data centers.
>
>
>
> In the context of address resolution, does multicast address resolution have
> different issues than uni-cast address resolution?
>
>
>
> Any comments?
>
>
>
>
>
>
>
>
>
> Linda
>
>
>
>
>
>
> _______________________________________________
> armd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/armd
>