Subject: [armd] Fwd: I-D Action: draft-sakura-6rd-datacenter-03.txt

From: Shishio Tsuchiya <[email-masked]>
Date: Wed, 08 Feb 2012 14:16:57 +0900

v6ops and ARMD
Sakura internet are providing IPv6 service without scalability impact to core network equipment to customer using 6rd.
We thought this is interesting idea,so published the draft.

http://tools.ietf.org/html/draft-sakura-6rd-datacenter-03

I think both of mailing list participants are also interesting in this technique.
If you have any comment and question of the draft,please let me know.

Regards,
-Shishio
-------- Original Message --------
Subject: 	I-D Action: draft-sakura-6rd-datacenter-03.txt
Date: 	Mon, 14 Nov 2011 17:21:26 +0800
From: 	<[email-masked]>
Reply-To: 	<[email-masked]>
To: 	<[email-masked]>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Title : IPv6 Rapid Deployment (6rd) in a Large Data Center
Author(s) : Shishio Tsuchiya
Mark Townsley
Shuichi Ohkubo
Filename : draft-sakura-6rd-datacenter-03.txt
Pages : 15
Date : 2011-11-14

IPv6 Rapid Deployment (6rd) as defined in RFC 5969 focuses on rapid
deployment of IPv6 by an access service provider which has difficulty
deploying native IPv6. This document describes how 6rd can be used
to deliver IPv6 within a Large Data Center.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-sakura-6rd-datacenter-03.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-sakura-6rd-datacenter-03.txt
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Shishio Tsuchiya <[email-masked]>
Date: Wed, 08 Feb 2012 14:39:47 +0900

Yiu
Thanks for comments.
Yes,Free,Swisscom,Softbank and so on already deployed 6rd to the access network.
But Sakura deployed IPv6 to the datacenter network by server based 6rd with variable OSs and 6rd BR.
http://tools.ietf.org/html/draft-sakura-6rd-datacenter-03#section-3

This is my interesting point,and this would be useful information.

Regards,
-Shishio

(2012/02/08 14:23), Lee, Yiu wrote:
> Hi Shishio,
> 
> Thanks for sharing this. I am glad but not surprised to see the result because free.fr has shown to scale 6rd to millions of their users since few years ago.
> 
> Yiu
> 
> On Feb 8, 2012, at 0:17, "Shishio Tsuchiya" <[email-masked]> wrote:
> 
>  > v6ops and ARMD
>  > Softwires mailing list
>  > [email-masked]
>  > https://www.ietf.org/mailman/listinfo/softwires
>

---

From: "Lee, Yiu" <[email-masked]>
Date: Wed, 8 Feb 2012 05:23:40 +0000

Hi Shishio,

Yiu

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 9 Feb 2012 17:26:14 -0600

Shishio,

Thank you very much for sharing the v6 deployment in data center.

I am not an IPv6 expert. So I have a simple question: when you say
"server-based 6rd", do you mean that server does the IPv4 encapsulation?

Does your data center allow hosts/servers under one IPv6 subnet (e.g. /64)
to be placed under different server racks?

Thanks, Linda Dunbar

On Tue, Feb 7, 2012 at 11:16 PM, Shishio Tsuchiya <[email-masked]>wrote:

> v6ops and ARMD
> Sakura internet are providing IPv6 service without scalability impact to
> core network equipment to customer using 6rd.
> armd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/armd
>

---

From: Shishio Tsuchiya <[email-masked]>
Date: Fri, 10 Feb 2012 13:44:29 +0900

Linda
Thanks for comments.

(2012/02/10 8:26), Linda Dunbar wrote:
> I am not an IPv6 expert. So I have a simple question: when you say "server-based 6rd", do you mean that server does the IPv4 encapsulation?

Yes.
6rd is IPv6 over IPv4 tunnel technology.
So backbone operator does not need to care to IPv6 on the core.
Additionally 6rd has stateless feature.
Once the operator has placed/configured 6rd BR on the exit point to the IPv6 internet,does not need additional operation to add 6rd CE(server based 6rd).
And if the server would like to go  to the IPv6 internet,then IPv4 packets will through 6rd BR and de-capsulate.
If the server would like to communicate other 6rd server within the data center,then IPv4 packets will reach 6rd server directly and de-capsulate.

> 
> 
> Does your data center allow hosts/servers under one IPv6 subnet (e.g. /64) to be placed under different server racks?

In Sakura internet 6rd cases,each of 6rd server has one 6rd delegate prefix(/64).
http://tools.ietf.org/html/draft-sakura-6rd-datacenter-03#section-4.1

The 6rd delegate prefix calculates from Sakura's IPv6 prefix(/32) and IPv4 address.
Sakura has the scalability problem which is same as ARMD draft.
http://tools.ietf.org/html/draft-ietf-armd-problem-statement-00

They also had to update switches to resolve security issue(Rogue RA).
http://tools.ietf.org/html/rfc6104

They selected "server-based 6rd" as the solution to avoid scalability and security problem.

Regards,
-Shishio

> 
> Thanks, Linda Dunbar
> 
> 
> 
> 
> 
> On Tue, Feb 7, 2012 at 11:16 PM, Shishio Tsuchiya <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     v6ops and ARMD
>     From: <[email-masked] <mailto:[email-masked]>>
>     Reply-To: <[email-masked] <mailto:[email-masked]>>
>     To: <[email-masked] <mailto:[email-masked]>>
> 
> 
> 
>     [email-masked] <mailto:[email-masked]>
>     Internet-Draft <https://www.ietf.org/mailman/listinfo/i-d-announce%0AInternet-Draft> directories: http://www.ietf.org/shadow.html
>     [email-masked] <mailto:[email-masked]>

---

From: Tina TSOU <[email-masked]>
Date: Fri, 10 Feb 2012 02:10:47 +0000

Tina

From: [email-masked] [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Thursday, February 09, 2012 3:26 PM
To: Shishio Tsuchiya
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [v6ops] [armd] Fwd: I-D Action: draft-sakura-6rd-datacenter-03.txt

Shishio,

[Tina] In my case, yes.

Thanks, Linda Dunbar

On Tue, Feb 7, 2012 at 11:16 PM, Shishio Tsuchiya <[email-masked]<mailto:[email-masked]>> wrote:
v6ops and ARMD
Sakura internet are providing IPv6 service without scalability impact to core network equipment to customer using 6rd.
We thought this is interesting idea,so published the draft.

Regards,
-Shishio
-------- Original Message --------
Subject:        I-D Action: draft-sakura-6rd-datacenter-03.txt
Date:   Mon, 14 Nov 2011 17:21:26 +0800
From:   <[email-masked]<mailto:[email-masked]>>
Reply-To:       <[email-masked]<mailto:[email-masked]>>
To:     <[email-masked]<mailto:[email-masked]>>

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-sakura-6rd-datacenter-03.txt
_______________________________________________
I-D-Announce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft<https://www.ietf.org/mailman/listinfo/i-d-announce%0AInternet-Draft> directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
armd mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/armd