Subject: [armd] Multicast Issues in ARMD Scope

From: Benson Schliesser <[email-masked]>
Date: Sun, 4 Mar 2012 15:08:22 -0800

ARMD participants -

At the last ARMD meeting at IETF82 in Taipei, a few participants made comments about multicast. Specifically, I recall Dino asking if it was in the scope of ARMD's charter. More recently, there has been a discussion on this list about multicast in datacenters. In response, a draft was posted at http://tools.ietf.org/html/draft-mcbride-armd-mcast-overview-00 that discusses various ways that multicast is used in datacenters.

As co-chairs, Linda and I are interested in whether the WG has any work to do on this topic. For instance, draft-mcbride-armd-mcast-overview suggests there might be "address resolution for non ARP/ND multicast traffic".

My view, in absence of WG feedback, is that ARMD's scope does not include "how to run multicast in a datacenter" - that might be more appropriate for the DC-Ops mailing list at this time. But if there are multicast-related problems that can be described in terms of address resolution, then ARMD should discuss them. For instance (if I may speculate) there might be issues with overlay address resolution and/or group-to-MAC mappings. Can you help me understand what those might be?

Your feedback and comments are appreciated.

Cheers,
-Benson and Linda

---

From: Mike McBride <[email-masked]>
Date: Tue, 6 Mar 2012 14:04:57 -0800

Benson,

I agree. Such a draft may better belong in DC-Ops or MBONED. The topic
created a flurry on this list so I thought it would be good to start
documenting the uses and problems.

IP multicast uses direct mapping for address resolution, so certain,
ARMD in the DC, issues may not apply to multicast. I will describe
this in the draft but didn't want to step on the toes of
armd-problem-statement.

You should consider adding some text, in armd-problem-statement, about
multicast direct mapping for address resolution, and perhaps some of
the other points from my draft.

thanks,
mike

On Sun, Mar 4, 2012 at 3:08 PM, Benson Schliesser <[email-masked]> wrote:
> _______________________________________________
> armd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/armd