Subject: Re: [armd] draft-nachum-sarp

From: Thomas Narten <[email-masked]>
Date: Wed, 04 Apr 2012 11:19:07 -0400

I just had a quick look at this document. It appears to me to be a
combination of "learning" and "proxy ARP". IMO, it needs a bit more
detail on some aspects prior to publication, but that is a separate
question.

But, looking at draft-dunbar-armd-arp-nd-scaling-bcp-00.txt, it says:

   Recommendation: Revise RFC1027 with VLAN support and scalability for
   the Data Center Environment.

I.e., update the Proxy ARP RFC. That is what draft-nachum-sarp sort of
does (well, it defines another usage of Proxy ARP).

Updating (or outlining some best practices for) Proxy ARP does not
appear to be in-scope for any WG at the moment. I'm also not sure how
much energy there would be for someone to take on such an activity
(int-area arguably would be a fine home, were there energy).

On the other hand, if we are seeing a renewed interested in using
proxy ARP for DC stuff, and we start seeing additional submissions in
this space, maybe the IETF should do something rather than have a
bunch of individual submissions appear.

Thomas

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 4 Apr 2012 09:50:28 -0700

> bunch of individual submissions appear.
I think there was always interest in this problem.  There were several
solutions posted earlier (prior to ARMD being chartered), but since
the charter excluded solutions, all of the solutions went away.

We have at least 2 other proposals that I'm aware of:
http://www.ietf.org/mail-archive/web/armd/current/msg00176.html
http://tools.ietf.org/html/draft-shah-armd-arp-reduction

It is possible that some of the work on directory-based
address resolution/mapping will make having a solution
in this space less important, but how that pans out and
how well it scales, etc. is still to be seen.

Anoop

---

From: Tal Mizrahi <[email-masked]>
Date: Thu, 5 Apr 2012 14:43:17 +0300

Hi Thomas,

>if we are seeing a renewed interested in using proxy ARP for DC stuff, and we start seeing additional submissions in this space, maybe the IETF should do something rather than have a bunch of individual submissions appear

Fully agree. 
Indeed, the ARMD working group has had less energy lately, but we believe that a WG that deals with ARMD solutions rather than ARMD problems will have much more energy.
Our default choice at this point is to proceed draft-nachum-sarp in the independent submission stream, however we would certainly like to see such a working group and take part in it.

Regards,
Tal.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Narten
Sent: Wednesday, April 04, 2012 6:19 PM
To: Benson Schliesser
Cc: [email-masked]
Subject: Re: [armd] draft-nachum-sarp

I just had a quick look at this document. It appears to me to be a combination of "learning" and "proxy ARP". IMO, it needs a bit more detail on some aspects prior to publication, but that is a separate question.

I.e., update the Proxy ARP RFC. That is what draft-nachum-sarp sort of does (well, it defines another usage of Proxy ARP).

Updating (or outlining some best practices for) Proxy ARP does not appear to be in-scope for any WG at the moment. I'm also not sure how much energy there would be for someone to take on such an activity (int-area arguably would be a fine home, were there energy).

On the other hand, if we are seeing a renewed interested in using proxy ARP for DC stuff, and we start seeing additional submissions in this space, maybe the IETF should do something rather than have a bunch of individual submissions appear.

Thomas

_______________________________________________
armd mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/armd

---

From: "Shah, Himanshu" <[email-masked]>
Date: Fri, 13 Apr 2012 09:36:03 -0400

I agree with Anoop.
We did find a healthy interest on 'arp-reduction' approach based on bang for the bucks.
Besides draft-shah-armd-arp-reduction predates draft-nachum-sarp...

/himanshu

From: [email-masked] [mailto:[email-masked]] On Behalf Of Anoop Ghanwani
Sent: Wednesday, April 04, 2012 12:50 PM
To: Thomas Narten
Cc: [email-masked]
Subject: Re: [armd] draft-nachum-sarp

On Wed, Apr 4, 2012 at 8:19 AM, Thomas Narten <[email-masked]<mailto:[email-masked]>> wrote:

Anoop