Subject: [armd] Gratuitous ARP pre-populating ARP caches.

From: Thomas Narten <[email-masked]>
Date: Mon, 27 Aug 2012 17:29:55 -0400

Hi. The RtgDir review of this document raised an issue, to which I
responded as follows. Anyone care to comment on this point?

Thomas Narten <[email-masked]> writes:

> > 3. Sec 7.1 seems to suggest that Gratuitous ARPs pre-populate ARP
> >  caches on the neighboring devices. Without an explicit description
> >  of what a neighboring device is, I would presume that this also
> >  includes edge/core routers. In that case this statement is not
> >  entirely correct as I am aware of routers that will by default not
> >  pre-populate their ARP caches on receiving Gratuitous ARPs.

> Right. The spec says "don't do this". But I believe it was asserted
> that some implementations do this. That said, I'm not aware of any
> such implementations. I would be willing to remove this sentence in
> the absence of known implementations of this.

Thomas

---

From: Warren Kumari <[email-masked]>
Date: Mon, 27 Aug 2012 20:54:32 -0400

> responded as follows. Anyone care to comment on this point?

Cisco IOS used to prepopulate ARP cache from Gratuitous ARP, but I do not think that this was the default behavior.

I used to rely on the gratuitous ARP behavior in a network back in ~1994. We had some weird home grown network widgets that simply didn't do ARP, and so we had some other device on the same LAN that would send (spoofed) gratuitous ARPs on their behalf every minute or two. 

A number of load balancer (and similar devices) do failover using Gratuitous ARPs -- when the primary goes down the backup sends gARP for all of the VIPs. Netscaler used to send these at GigE line rate -- if there were a large number of VIPs the routers would often nat be able to keep up, and hilarity would ensue…
 
W

> _______________________________________________
> armd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/armd
> 

--
After you'd known Christine for any length of time, you found yourself fighting a desire to look into her ear to see if you could spot daylight coming the other way.

    -- (Terry Pratchett, Maskerade)