Subject: [Asdf] Éric Vyncke's No Objection on charter-ietf-asdf-00-02: (with COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Mon, 05 Oct 2020 01:16:52 -0700

Éric Vyncke has entered the following ballot position for
charter-ietf-asdf-00-02: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-asdf/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Looking forward to seeing this WG in action !

Some comments though:

"the Semantic Definition Format (SDF) was created" should a reference to SDF be
added ? Then, later, it seems that SDF specification is the key work item for
ASDF WG.

"Some 200 models in SDF format have been contributed " a reference to the
repository would be welcome. Should "in 2020" be added to provide more context ?

"they look to the IETF for developing SDF 1.0 further into a high-quality
specification" is positive for the IETF but this claim has no reference.

Expanding "WISHI" would help the non-expert reader (like myself).

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 5 Oct 2020 10:25:26 +0200

Hi Éric,

Thank you!

> added ? Then, later, it seems that SDF specification is the key work item for

The reference would be to draft-onedm-t2trg-sdf, which was a bit too ephemeral to include here, but we certainly could (we could also reference the github repo where that was developed, https://github.com/one-data-model/SDF ).

> repository would be welcome. Should "in 2020" be added to provide more context ?

Sounds good to me (even if 2020 isn’t quite over yet).

> specification" is positive for the IETF but this claim has no reference.

There are several liaison statements of organization contributing to the OneDM process (see IETF108 slides), but OneDM itself is not really an organization that is making statements.  Maybe we can find something to reference if needed.

> Expanding "WISHI" would help the non-expert reader (like myself).

Good point.
Work on IoT Semantic/Hypermedia Interoperability
http://wishi.space
(We need to update that page and make it https…)

Grüße, Carsten

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 5 Oct 2020 08:47:51 +0000

Thank you Carsten for the prompt reply and actions. This should improve the charter.

BTW, when adding TLS to http://wishi.space, also please try to add IPv6 (for IoT-related this is mostly a must) even if it appears to be hosted by github :-O

Regards

-éric

-----Original Message-----
From: Carsten Bormann <[email-masked]>
Date: Monday, 5 October 2020 at 10:25
To: Eric Vyncke <[email-masked]>
Cc: The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Asdf] Éric Vyncke's No Objection on charter-ietf-asdf-00-02: (with COMMENT)

    Hi Éric,

    Thank you!

    Good point.

    Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 5 Oct 2020 22:52:51 +0200

> Thank you Carsten for the prompt reply and actions. This should improve the charter.

Now https://github.com/one-data-model/ietf108/pull/9
(Obviously, this needs to be copied over to https://datatracker.ietf.org/doc/charter-ietf-asdf/ then.)

> BTW, when adding TLS to http://wishi.space, also please try to add IPv6 (for IoT-related this is mostly a must) even if it appears to be hosted by github :-O

I’ll probably need to set up an IPv6 to IPv4 TCP proxy to make that happen for a github-hosted site.
Sounds like a nice project for a winter evening at the fireside…

Grüße, Carsten

---

From: Barry Leiba <[email-masked]>
Date: Tue, 6 Oct 2020 12:42:20 -0400

Done in -00-03.

Barry