Subject: [Autoconf] Continuous detection for address uniqueness

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 22 Mar 2007 05:46:41 -0700

Hello folks,

In draft-baccelli-autoconf-statement-02.txt, it is stated:
>             ...    Phenomena such as MANET merging and MANET
>    partitionning bring the need for a continuous checking for address
>    uniqueness within the specified scope.
This makes me worry.  Someone in the IESG might interpret it
to mean that a candidate solution did not solve the right problem
if it does not specify protocol for making continuous checks for
address uniqueness.

Regards,
Charlie P.

_______________________________________________
Autoconf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/autoconf

---

From: mase <[email-masked]>
Date: Fri, 23 Mar 2007 00:54:10 +0900

Hi, Charlie,

>if it does not specify protocol for making continuous checks for

Thank you for your comments.

Note that this section (Address Uniqueness Requirements) starts with 
the following remarks.

    If address uniqueness is required within a specific scope, and if the
    address/prefix generation mechanism in use does not totally avoid
    address/prefix duplication, then additional issues arise.  This 
section overviews these problems.

So, if this is not the case, the need of continuous address 
uniqueness checking may not occur. Does this resolve your concern? We 
may add this note explicitly in the draft. I also think that the word 
"continuous checking " may be too strong. I would propose the following.

Phenomena such as MANET merging and MANET
    partitionning bring the need for a in-service checking for address
    uniqueness within the specified scope, if address uniqueness is required.
Regard,
Kenichi 
_______________________________________________
Autoconf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/autoconf

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 22 Mar 2007 11:49:40 -0700

Hello Kenichi,

I think your revised wording resolves my
concern.  The introductory comments are
O.K., because there is, in fact, potentially
a problem.  Saying "in-service" instead of
"continuous" is perfect, as long as it is
interpreted to mean that on-demand
solutions are admissible.

Regards,
Charlie P.

ext mase wrote:
>    address/prefix duplication, then additional issues
> arise.  This section overviews these problems.
>
> So, if this is not the case, the need of continuous address uniqueness
> checking may not occur. Does this resolve your concern? We may add this
> note explicitly in the draft. I also think that the word "continuous
> checking " may be too strong. I would propose the following.
>
>

---

From: mase <[email-masked]>
Date: Fri, 23 Mar 2007 04:35:35 +0900

Hi, Charlie,

Ok. we will revise our document in this line.

Thanks,
Kenichi