Subject: [Autoconf] MANET-ARCH-05

From: "Ian Chakeres" <[email-masked]>
Date: Fri, 21 Sep 2007 10:15:05 +0530

I'm happy to report that we've received several excellent comments
regarding MANET-ARCH during WGLC.

I'd also like to write about a few of the changes made in the arch-05
revision. Several of the changes were made based on Fred Templin's
arch-04 comments. I would like to point out that Fred's suggestion to
change usage of term interface to link in many places was not made.
The use of interface, link, subnet, and several other terms have been
highly debated and the current usage has been agreed upon by people
from different areas/backgrounds.

That said, the new revision of the document will address the fine
comments we've received during WGLC.

If you have any additional comments, please send them ASAP.
Ian Chakeres

_______________________________________________
Autoconf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/autoconf

---

From: "Teco Boot" <[email-masked]>
Date: Fri, 21 Sep 2007 09:14:08 +0200

Hi Ian,

Small remark on some diagrams.
Loopback is "internal" interface, but drawn outside the MNR block in section
2.2
In section 5.1, the loopback is drawn inside the MNR block.
Note that all MNR interfaces have an IP address assigned, so the difference
is that on loopback interfaces, there are no external nodes connected.
In the diagram in 5.1, the MNR has itself also a P:2:: address. Below a
proposal for the diagram. 

             MANET     <~~~~~~+~~~~~~>         Delegated
           Interface          |                Prefix
                              |                =========
            ''''''''''''''''''|'''''''''''' <=== P::   =   
            '                 |           '    =========
            '         MANET Router        '    
            '           :     :           '
            ' P:2::mnr=>:     :<=P:1::mnr '    Assigned
            '           :     :           '    Prefixes
            '           :  +--------+     '    =========
            '           :  |Loopback|     ' <=== P:1:: =
            '           :  +--------+     '    =========
            '''''''''''':''''''''''''''''''    
                        :                      =========
  ============     +....:..+.....+       <====== P:2:: =
  =    :     =     :             :             =========
  =    :     =     :<=P:2::1     :<=P:2::k 
  =Classic IP=   +-+-+         +-+-+
  =Interfaces=   | N |  * * *  | N |
  ============   +---+         +---+

I doubt depicting the MANET Interface address. It could be added, as an
introduction to the next section 5.2. It makes the MANET Router and Prefixes
diagram complete.

             MANET     <~~~~~~+~~~~~~>         Delegated
           Interface          |                Prefix
                              |                =========
            ''''''''''''''''''|'''''''''''' <=== P::   =   
            '  Unique Prefix=>|           '    =========
            '                 |           '
            '         MANET Router        '    
            '           :     :           '
            ' P:2::mnr=>:     :<=P:1::mnr '    Assigned
            '           :     :           '    Prefixes
            '           :  +--------+     '    =========
            '           :  |Loopback|     ' <=== P:1:: =
            '           :  +--------+     '    =========
            '''''''''''':''''''''''''''''''    
                        :                      =========
  ============     +....:..+.....+       <====== P:2:: =
  =    :     =     :             :             =========
  =    :     =     :<=P:2::1     :<=P:2::k 
  =Classic IP=   +-+-+         +-+-+
  =Interfaces=   | N |  * * *  | N |
  ============   +---+         +---+

Teco.

> -----Oorspronkelijk bericht-----
> Van: Ian Chakeres [mailto:[email-masked]]
> Verzonden: vrijdag 21 september 2007 6:45
> Aan: [email-masked]
> CC: Singh Shubhranshu (home); Thomas Heide Clausen (work)
> Onderwerp: [Autoconf] MANET-ARCH-05
>

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 21 Sep 2007 08:57:28 -0700

Teco, 

> -----Original Message-----
> From: Teco Boot [mailto:[email-masked]] 
> Sent: Friday, September 21, 2007 12:14 AM
> To: 'Ian Chakeres'
> Cc: [email-masked]
> Subject: RE: [Autoconf] MANET-ARCH-05
> 
> Hi Ian,
> 

Two things here. First, it need not be a singluar loopback
interface. It could be many loopback interfaces and/or other
internal virtual interfaces, with many internal virtual
networks and virtual hosts attached.

Second, MNR's do not assign addresses derived from their
delegated prefixes to interfaces that connect directly to
the Internet/provider/visited network/etc, i.e., in the
case of a MNR that is also a BR. That is why IMHO it is
necessary to distinguish egress interfaces (those that
connect the MNR to the Internet/provider/visited network/etc)
from ingress interfaces (those via which the MNR connects
mobile networks).

Fred
[email-masked]