Subject: [Autoconf] Updated ad hoc addressing model document

From: Emmanuel Baccelli <[email-masked]>
Date: Tue, 26 Jan 2010 13:09:35 +0100

Folks,

here's an updated version of the ad hoc addressing model document, following
the comments gathered during working group last call. We took as much as
possible on board, as discussed on the mailing list. Please review this
revision, and let us know if you have further comments.

http://www.ietf.org/id/draft-ietf-autoconf-adhoc-addr-model-02.txt

Regards,

Emmanuel

---

From: Zach Shelby <[email-masked]>
Date: Wed, 27 Jan 2010 09:54:21 +0200

I took a read through -02, and the changes look fine to me.

Zach 

On Jan 26, 2010, at 14:09 , Emmanuel Baccelli wrote:

> Folks,
> 
> here's an updated version of the ad hoc addressing model document, following the comments gathered during working group last call. We took as much as possible on board, as discussed on the mailing list. Please review this revision, and let us know if you have further comments.
> 
> _______________________________________________
> Autoconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/autoconf

-- 
http://www.sensinode.com
http://zachshelby.org - My blog "On the Internet of Things"
http://6lowpan.net - New book - "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

Zach Shelby
Head of Research
Sensinode Ltd.
Kidekuja 2
88610 Vuokatti, FINLAND

This e-mail and all attached material are confidential and may contain legally privileged information. If you are not the intended recipient, please contact the sender and delete the e-mail from your system without producing, distributing or retaining copies thereof.

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 27 Jan 2010 09:00:09 +0100

Thanks, Zach, for your review.

I'll add my 2 cents and exclaim satisfaction with -02 as well.

I'd be happy to see this iteration go to the AD/IESG.....

Thomas

On Jan 27, 2010, at 8:54 AM, Zach Shelby wrote:

>> here's an updated version of the ad hoc addressing model document,  
>> following the comments gathered during working group last call. We  
>> took as much as possible on board, as discussed on the mailing  
>> list. Please review this revision, and let us know if you have  
>> further comments.
>>
> This e-mail and all attached material are confidential and may  
> contain legally privileged information. If you are not the intended  
> recipient, please contact the sender and delete the e-mail from your  
> system without producing, distributing or retaining copies thereof.
>
>
>
>

---

From: Ryuji Wakikawa <[email-masked]>
Date: Wed, 27 Jan 2010 00:00:07 -0800

Hi all,

Emmanuel updated the document according to the WG last call. 
Please confirm the changes specially if you sent comments during WGLC.

We will pass this document to Jari for the next stage soon.

thanks,
ryuji

---

From: Ryuji Wakikawa <[email-masked]>
Date: Wed, 27 Jan 2010 00:01:09 -0800

Hi Zach,

Thanks for quick review and ack to the changes.

thanks,
ryuji

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 27 Jan 2010 09:43:43 +0100

Same for me, I agree with the text.

Ulrich

On Wed, Jan 27, 2010 at 8:54 AM, Zach Shelby <[email-masked]> wrote:

> following the comments gathered during working group last call. We took as
> much as possible on board, as discussed on the mailing list. Please review
> this revision, and let us know if you have further comments.
> >
> This e-mail and all attached material are confidential and may contain
> legally privileged information. If you are not the intended recipient,
> please contact the sender and delete the e-mail from your system without
> producing, distributing or retaining copies thereof.
>
>
>
>

---

From: "Teco Boot" <[email-masked]>
Date: Fri, 29 Jan 2010 17:13:56 +0100

Ryuji, Thomas,

I commented on the document.
I don't see any reflection in the document, nor received questions
for clarification.

I am quite uncomfortable with a large drawback of the proposed 
addressing model, which makes it unacceptable for the deployed MANETs
I am involved in. 
My requirement is that L3 communication between nodes, that have L2
connectivity, must be possible in all conditions, including conditions
with a non-operational MANET protocol.
Maybe this drawback is overlooked or underestimated.

And the text on link locals does not describe how IPv6 works. LLs are 
used in MANETs for multiple purposes. We can't without.

My other comments are textual or on incompleteness. Especially, the 
document doesn't describe anything useful for assigning globals.

Regards, Teco

>-----Oorspronkelijk bericht-----
>Van: [email-masked] [mailto:[email-masked]] Namens
>Ryuji Wakikawa
>Verzonden: woensdag 27 januari 2010 9:00
>Aan: Emmanuel Baccelli
>CC: [email-masked]
>Onderwerp: Re: [Autoconf] Updated ad hoc addressing model document
>
>Hi all,
>
>following the comments gathered during working group last call. We took
>as much as possible on board, as discussed on the mailing list. Please
>review this revision, and let us know if you have further comments.
>>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 29 Jan 2010 09:10:49 -0800

Hello Teco,

> with a non-operational MANET protocol.

I don't see that the addressing model prevents any such L3 communication.

> Maybe this drawback is overlooked or underestimated.

It doesn't even seem to be a drawback at all as far as I can tell.

> used in MANETs for multiple purposes. We can't without.

This isn't true.  You can build MANETs without using link-local at all
in any fashion.

I'm not saying you have to ignore link-local.

> document doesn't describe anything useful for assigning globals.

Yeah, it would be nice if we could get to the
point of doing address autoconfiguration in
this group.

Regards,
Charlie P.

---

From: "Teco Boot" <[email-masked]>
Date: Fri, 29 Jan 2010 19:04:40 +0100

Hi Charlie,

>I don't see that the addressing model prevents any such L3

How are packets forwarded?
The destination address (which is direct L2 neighbor in this case)
needs to be found in a forwarding table, normally the routing table.
Neighbor cache could be used also.
How to get this info in such a table?

>I'm not saying you have to ignore link-local.

If LLs are configured, they are used for L2 address resolving.
Also for MANET protocols, if destination address is LL mcast.
One can think of updating the IPv6 RFCs. I'll stay on current
practice.

Regards, Teco

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 29 Jan 2010 10:10:28 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Teco Boot
> Sent: Friday, January 29, 2010 10:05 AM
> To: 'Charles E. Perkins'
> Cc: [email-masked]; 'Thomas Heide Clausen'
> Subject: Re: [Autoconf] Updated ad hoc addressing model document
> 
> Hi Charlie,
> 

I believe OSPFv3 for one is going to need link-locals
when it is used as a MANET routing protocol. (That is
not to say that OSPFv3 can only carry IPv6 routes; it
can also use Address Family extensions to carry IPv4
routes.)

Fred
[email-masked]

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 29 Jan 2010 12:40:58 -0800

Hello Teco,

> How to get this info in such a table?

Node A broadcasts a "Hello" message.
Node B hears it, and puts node A in its forwarding table.

The nodes may take subsequent actions to verify
bidirectionality, exchange other table entries, etc.

> Also for MANET protocols, if destination address is LL mcast.

O.K.

> One can think of updating the IPv6 RFCs. I'll stay on current

Me, too.

Current practice includes running AODV and OLSR and DYMO.

One should think of updating the IPv6 RFCs, since the link-local
constructions contained therein were written _explicitly_ in
disregard of the needs for wireless links of the sort familiar to
practitioners in this group.

I was there.  I remember very well the meeting in Boston
where this happened.

Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 29 Jan 2010 12:46:54 -0800

Hello Fred,

> can also use Address Family extensions to carry IPv4

I'd like to see how they are going to do it.

For all the discussion about how some people really
really need link-locals, I somehow missed the part
about how they were really going to be able to do
it -- except under highly restrictive circumstances
(e.g., single hop from backbone, ...).  But, full disclosure
here, I didn't follow the OSPF effort very well.  At one
point, when I was paying attention, it seemed to me that
they were trying to do the right thing.

Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 29 Jan 2010 13:03:05 -0800

Hello again folks,

I should have mentioned that, of course, link-locals
work great with almost no effort, if one can assume
unique L2 addresses.  Mea culpa!

And, as I mentioned before, I think it would be a
really good idea for link-local proponents to write
up a document (perhaps only one paragraph)
saying pretty much exactly that.

Regards,
Charlie P.

---

From: "Teco Boot" <[email-masked]>
Date: Sat, 30 Jan 2010 12:22:00 +0100

Charlie,

>bidirectionality, exchange other table entries, etc.

My point is that L3 communication becomes dependent on a L3 routing
protocol. We didn't have this in the IP stack before.

>Current practice includes running AODV and OLSR and DYMO.

These protocols use link-locals, when RFC5498 and RFC3484 are 
implemented.

>practitioners in this group.

I use link-locals on wireless links, and it works great.
What is your point?

Regards, Teco.

---

From: "Teco Boot" <[email-masked]>
Date: Sat, 30 Jan 2010 12:27:12 +0100

Hi Charlie,

I think you overlook something. Getting unique addresses
applies to any address that should be unique :-).

Why could we assume that non-link-local addresses work great
with almost no effort?

Regards, Teco

>Charles E. Perkins
>Verzonden: vrijdag 29 januari 2010 22:03
>Aan: Templin, Fred L
>CC: [email-masked]; 'Thomas Heide Clausen'