Subject: Re: [avtext] Splicing: Confirmation of decisions at IETF#80

From: Jinwei Xia <[email-masked]>
Date: Mon, 23 May 2011 16:26:06 +0800

As an complement to my previous feedback.

> > 
> > I agree that you need to have content to insert that is 
> very close to 
> > the space you are replacing. The question is what happens 
> when things 
> > are off with a video frame or less, or an audio frame or less.
> > 
> 
> Your concern make senses, one of splicing requirements is 
> Splicer SHOULD NOT cause perceptible media clipping at the 
> splicing joint.  Media source must schedule the splicing 
> point which usually is the boundary of two independently 
> decodable frames. When audio and video are not interleaved, 
> each audio frame is usually decodable for common audio 
> codecs. For video, some predicted frames need to depent on 
> other frames, so the splicing point is usually at the Group 
> of Pictures (GoP) boundary instead.
> 

Meanwhile, the insertion media source or splicer must schedule that the
duration of insertion content  properly matches the gap time, i.e., starting
with an independently decodable frame and ending with another one.

Moreover, to reduce the playout latency, splicer may fill some specific
information (e.g., preamble information for rapid demultiplexing and
decoding insertion content) up the user's buffer with serval seconds earlier
before the presentation time of the insertion content.

Jinwei

---

From: Colin Perkins <[email-masked]>
Date: Mon, 23 May 2011 11:58:11 +0100

On 23 May 2011, at 09:26, Jinwei Xia wrote:
>>> I agree that you need to have content to insert that is very close to the space you are replacing. The question is what happens when things are off with a video frame or less, or an audio frame or less.
>> 
>> Your concern make senses, one of splicing requirements is Splicer SHOULD NOT cause perceptible media clipping at the splicing joint.  Media source must schedule the splicing point which usually is the boundary of two independently decodable frames. When audio and video are not interleaved, each audio frame is usually decodable for common audio codecs. For video, some predicted frames need to depent on other frames, so the splicing point is usually at the Group of Pictures (GoP) boundary instead.
> 
> Meanwhile, the insertion media source or splicer must schedule that the duration of insertion content properly matches the gap time, i.e., starting with an independently decodable frame and ending with another one.
> 
> Moreover, to reduce the playout latency, splicer may fill some specific information (e.g., preamble information for rapid demultiplexing and decoding insertion content) up the user's buffer with serval seconds earlier before the presentation time of the insertion content.

That will need careful specification, since the requirements for rewriting the RTP headers in this case are tricky.

-- 
Colin Perkins
http://csperkins.org/