Subject: Re: [avtext] mixer-to-client audio levels ready (Was: I-D Action: draft-ietf-avtext-mixer-to-client-audio-level-02.txt)

From: Emil Ivov <[email-masked]>
Date: Thu, 02 Jun 2011 15:19:06 +0200

На 09.05.11 12:15, Emil Ivov написа:
> Hey all,
> 
> The authors are confident that all open issues and mailing list comments
> have now been addressed and that this document is now ready to move forward.
> 
> We will be submitting the client-to-mixer draft in the following days.

Done. We believe both documents are now ready to move forward.

Cheers,
Emil

> 
> На 09.05.11 12:05, [email-masked] написа:
>> A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Audio/Video Transport Extensions Working Group of the IETF.
>>
>> 	Title           : A Real-Time Transport Protocol (RTP) Header Extension for Mixer-to- Client Audio Level Indication
>> 	Author(s)       : Emil Ivov
>>                           Enrico Marocco
>>                           Jonathan Lennox
>> 	Filename        : draft-ietf-avtext-mixer-to-client-audio-level-02.txt
>> 	Pages           : 15
>> 	Date            : 2011-05-09
>>
>>    This document describes a mechanism for RTP-level mixers in audio
>>    conferences to deliver information about the audio level of
>>    individual participants.  Such audio level indicators are transported
>>    in the same RTP packets as the audio data they pertain to.
>>
>>
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-ietf-avtext-mixer-to-client-audio-level-02.txt
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> This Internet-Draft can be retrieved at:
>> ftp://ftp.ietf.org/internet-drafts/draft-ietf-avtext-mixer-to-client-audio-level-02.txt
>> _______________________________________________
>> avtext mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/avtext
>>
> 

-- 
Emil Ivov, Ph.D.                       67000 Strasbourg,
Project Lead                           France
Jitsi
[email-masked]                        PHONE: +33.1.77.62.43.30
http://jitsi.org                       FAX:   +33.1.77.62.47.31

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 3 Jun 2011 10:26:19 +0200

(As WG co-chair

Can people do a rapid check and update their view of whether all open issues are adequately addressed or not. Are there any new ones?

If there are none, we will start WGLC. If they are not, then we will have appropriate rounds of discussions to close them.

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Emil Ivov
> Sent: 02 June 2011 14:19
> To: AVTEXT
> Subject: Re: [avtext] mixer-to-client audio levels ready (Was: I-D Action:
> draft-ietf-avtext-mixer-to-client-audio-level-02.txt)
> 
> >> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Audio/Video Transport
> Extensions Working Group of the IETF.
> >>
> >> 	Title           : A Real-Time Transport Protocol (RTP) Header
> Extension for Mixer-to- Client Audio Level Indication
> >> 	Author(s)       : Emil Ivov
> >>                           Enrico Marocco
> >>                           Jonathan Lennox

---

From: Peter Musgrave <[email-masked]>
Date: Sun, 5 Jun 2011 15:33:32 -0400

Hi,

Looking through the diffs:
In section 3 is now the statement "The two-byte header defined in RFC 5285
[RFC5285] may also be used."

I am now a bit confused. I think that if len=2 then the RFC5285 header is
implied? I think it would be good to make this explicit. Could I use a len=2
and have some other level indication?

Other than this, my previous comments have been addressed.

Regards,

Peter Musgrave

2011/6/3 DRAGE, Keith (Keith) <[email-masked]>

> (As WG co-chair
>
> Can people do a rapid check and update their view of whether all open
> issues are adequately addressed or not. Are there any new ones?
>
> If there are none, we will start WGLC. If they are not, then we will have
> appropriate rounds of discussions to close them.
>
> Keith
>

---

From: [email-masked]
Date: Mon, 6 Jun 2011 11:55:51 -0400

> Other than this, my previous comments have been addressed.

RFC 5285 has two forms for how it encodes its header extension elements --
the form with "defined by profile" field 0xBEDE, with a four-bit ID and
four-bit length; and the form with "defined by profile" field 0x100x, with
eight-bit ID and eight-bit length.  The point of this sentence is to make it
clear that although the example uses the 0xBEDE form, the 0x100x form can
also be used.  It's nothing to do with the actual value that's encoded in
the "len" field.

Is there alternative wording that would make this clearer?

-- 
Jonathan Lennox
[email-masked] / [email-masked]

> Hi, <div><br></div><div>Looking through the diffs:</div><div>In section 3 is now the statement &quot;<span class="Apple-style-span" style="font-family: monospace; font-size: 11px; white-space: pre; ">The <span class="insert" style="background-color: rgb(136, 255, 255); ">two-byte header</span> defined in <span class="insert" style="background-color: rgb(136, 255, 255); ">RFC 5285 [RFC5285] may also</span> be <span class="insert" style="background-color: rgb(136, 255, 255); ">used.&quot;</span></span></div>
> <div><font class="Apple-style-span" face="monospace"><span class="Apple-style-span" style="font-size: 11px; white-space: pre;"><br></span></font></div><div><meta charset="utf-8">I am now a bit confused. I think that if len=2 then the RFC5285 header is implied? I think it would be good to make this explicit. Could I use a len=2 and have some other level indication?</div>
> <div><br></div><div>Other than this, my previous comments have been addressed.</div><div><br></div><div>Regards, </div><div><br></div><div>Peter Musgrave</div><div><br><div class="gmail_quote">2011/6/3 DRAGE, Keith (Keith) <span dir="ltr">&lt;<a href="mailto:[email-masked]">[email-masked]</a>&gt;</span><br>
> <blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">(As WG co-chair<br>
> <br>
> Can people do a rapid check and update their view of whether all open issues are adequately addressed or not. Are there any new ones?<br>
> <br>
> If there are none, we will start WGLC. If they are not, then we will have appropriate rounds of discussions to close them.<br>
> <br>
> Keith<br>
> <br>
> &gt; -----Original Message-----<br>
> &gt; From: <a href="mailto:[email-masked]">[email-masked]</a> [mailto:<a href="mailto:[email-masked]">[email-masked]</a>] On Behalf<br>
> &gt; Of Emil Ivov<br>
> &gt; Sent: 02 June 2011 14:19<br>
> &gt; To: AVTEXT<br>
> &gt; Subject: Re: [avtext] mixer-to-client audio levels ready (Was: I-D Action:<br>
> &gt; draft-ietf-avtext-mixer-to-client-audio-level-02.txt)<br>
> <div><div></div><div class="h5">&gt;<br>
> &gt; На 09.05.11 12:15, Emil Ivov написа:<br>
> &gt; &gt; Hey all,<br>
> &gt; &gt;<br>
> &gt; &gt; The authors are confident that all open issues and mailing list comments<br>
> &gt; &gt; have now been addressed and that this document is now ready to move<br>
> &gt; forward.<br>
> &gt; &gt;<br>
> &gt; &gt; We will be submitting the client-to-mixer draft in the following days.<br>
> &gt;<br>
> &gt; Done. We believe both documents are now ready to move forward.<br>
> &gt;<br>
> &gt; Cheers,<br>
> &gt; Emil<br>
> &gt;<br>
> &gt; &gt;<br>
> &gt; &gt; На 09.05.11 12:05, <a href="mailto:[email-masked]">[email-masked]</a> написа:<br>
> &gt; &gt;&gt; A New Internet-Draft is available from the on-line Internet-Drafts<br>
> &gt; directories. This draft is a work item of the Audio/Video Transport<br>
> &gt; Extensions Working Group of the IETF.<br>
> &gt; &gt;&gt;<br>
> &gt; &gt;&gt;    Title           : A Real-Time Transport Protocol (RTP) Header<br>
> &gt; Extension for Mixer-to- Client Audio Level Indication<br>
> &gt; &gt;&gt;    Author(s)       : Emil Ivov<br>
> &gt; &gt;&gt;                           Enrico Marocco<br>
> &gt; &gt;&gt;                           Jonathan Lennox<br>
> &gt; &gt;&gt;    Filename        : draft-ietf-avtext-mixer-to-client-audio-level-<br>
> &gt; 02.txt<br>
> &gt; &gt;&gt;    Pages           : 15<br>
> &gt; &gt;&gt;    Date            : 2011-05-09<br>
> &gt; &gt;&gt;<br>
> &gt; &gt;&gt;    This document describes a mechanism for RTP-level mixers in audio<br>
> &gt; &gt;&gt;    conferences to deliver information about the audio level of<br>
> &gt; &gt;&gt;    individual participants.  Such audio level indicators are<br>
> &gt; transported<br>
> &gt; &gt;&gt;    in the same RTP packets as the audio data they pertain to.<br>
> &gt; &gt;&gt;<br>
> &gt; &gt;&gt;<br>
> &gt; &gt;&gt; A URL for this Internet-Draft is:<br>
> &gt; &gt;&gt; <a href="http://www.ietf.org/internet-drafts/draft-ietf-avtext-mixer-to-client-" target="_blank">http://www.ietf.org/internet-drafts/draft-ietf-avtext-mixer-to-client-</a><br>
> &gt; audio-level-02.txt<br>
> &gt; &gt;&gt;<br>
> &gt; &gt;&gt; Internet-Drafts are also available by anonymous FTP at:<br>
> &gt; &gt;&gt; <a href="ftp://ftp.ietf.org/internet-drafts/" target="_blank">ftp://ftp.ietf.org/internet-drafts/</a><br>
> &gt; &gt;&gt;<br>
> &gt; &gt;&gt; This Internet-Draft can be retrieved at:<br>
> &gt; &gt;&gt; <a href="ftp://ftp.ietf.org/internet-drafts/draft-ietf-avtext-mixer-to-client-" target="_blank">ftp://ftp.ietf.org/internet-drafts/draft-ietf-avtext-mixer-to-client-</a><br>
> &gt; audio-level-02.txt<br>
> &gt; &gt;&gt; _______________________________________________<br>
> &gt; &gt;&gt; avtext mailing list<br>
> &gt; &gt;&gt; <a href="mailto:[email-masked]">[email-masked]</a><br>
> &gt; &gt;&gt; <a href="https://www.ietf.org/mailman/listinfo/avtext" target="_blank">https://www.ietf.org/mailman/listinfo/avtext</a><br>
> &gt; &gt;&gt;<br>
> &gt; &gt;<br>
> &gt;<br>
> &gt; --<br>
> &gt; Emil Ivov, Ph.D.                       67000 Strasbourg,<br>
> &gt; Project Lead                           France<br>
> &gt; Jitsi<br>
> &gt; <a href="mailto:[email-masked]">[email-masked]</a>                        PHONE: <a href="tel:%2B33.1.77.62.43.30" value="+33177624330">+33.1.77.62.43.30</a><br>
> &gt; <a href="http://jitsi.org" target="_blank">http://jitsi.org</a>                       FAX:   <a href="tel:%2B33.1.77.62.47.31" value="+33177624731">+33.1.77.62.47.31</a><br>
> &gt;<br>
> &gt; _______________________________________________<br>
> &gt; avtext mailing list<br>
> &gt; <a href="mailto:[email-masked]">[email-masked]</a><br>
> &gt; <a href="https://www.ietf.org/mailman/listinfo/avtext" target="_blank">https://www.ietf.org/mailman/listinfo/avtext</a><br>
> _______________________________________________<br>
> avtext mailing list<br>
> <a href="mailto:[email-masked]">[email-masked]</a><br>
> <a href="https://www.ietf.org/mailman/listinfo/avtext" target="_blank">https://www.ietf.org/mailman/listinfo/avtext</a><br>
> </div></div></blockquote></div><br></div>

---

From: Peter Musgrave <[email-masked]>
Date: Mon, 6 Jun 2011 19:40:10 -0400

I think what you just said would work.

I'll confess I was too lazy to go dig out the reference - and sadly I expect
there are more people just as lazy as me out there...

I can live with the text as it is. (If I was implementing it I would be less
lazy).

Peter

2011/6/6 <[email-masked]>

> > > > >>    Filename        :
> draft-ietf-avtext-mixer-to-client-audio-level-
> > > > 02.txt
> > > > >>    Pages           : 15
> > > > >>    Date            : 2011-05-09
> > > > >>
> > Hi, <div><br></div><div>Looking through the diffs:</div><div>In section 3
> is now the statement &quot;<span class="Apple-style-span"
> style="font-family: monospace; font-size: 11px; white-space: pre; ">The
> <span class="insert" style="background-color: rgb(136, 255, 255); ">two-byte
> header</span> defined in <span class="insert" style="background-color:
> rgb(136, 255, 255); ">RFC 5285 [RFC5285] may also</span> be <span
> class="insert" style="background-color: rgb(136, 255, 255);
> ">used.&quot;</span></span></div>
> > <div><font class="Apple-style-span" face="monospace"><span
> class="Apple-style-span" style="font-size: 11px; white-space:
> pre;"><br></span></font></div><div><meta charset="utf-8">I am now a bit
> confused. I think that if len=2 then the RFC5285 header is implied? I think
> it would be good to make this explicit. Could I use a len=2 and have some
> other level indication?</div>
> > <div><br></div><div>Other than this, my previous comments have been
> addressed.</div><div><br></div><div>Regards, </div><div><br></div><div>Peter
> Musgrave</div><div><br><div class="gmail_quote">2011/6/3 DRAGE, Keith
> (Keith) <span dir="ltr">&lt;<a href="mailto:[email-masked]
> ">[email-masked]</a>&gt;</span><br>
> > <blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px
> #ccc solid;padding-left:1ex;">(As WG co-chair<br>
> > <br>
> issues are adequately addressed or not. Are there any new ones?<br>
> > <br>
> appropriate rounds of discussions to close them.<br>
> > <br>
> > Keith<br>
> > <br>
> > &gt; From: <a href="mailto:[email-masked]">
> [email-masked]</a> [mailto:<a href="mailto:
> [email-masked]">[email-masked]</a>] On Behalf<br>
> > &gt; Of Emil Ivov<br>
> > &gt; &gt;&gt;    Filename        :
> draft-ietf-avtext-mixer-to-client-audio-level-<br>
> > &gt; 02.txt<br>
> > &gt; &gt;&gt; <a href="
> http://www.ietf.org/internet-drafts/draft-ietf-avtext-mixer-to-client-"
> target="_blank">
> http://www.ietf.org/internet-drafts/draft-ietf-avtext-mixer-to-client-
> </a><br>
> > &gt; &gt;&gt; <a href="ftp://ftp.ietf.org/internet-drafts/"
> target="_blank">ftp://ftp.ietf.org/internet-drafts/</a><br>
> > &gt; &gt;&gt;<br>
> > &gt; &gt;&gt; <a href="
> ftp://ftp.ietf.org/internet-drafts/draft-ietf-avtext-mixer-to-client-"
> target="_blank">
> ftp://ftp.ietf.org/internet-drafts/draft-ietf-avtext-mixer-to-client-
> </a><br>
> > &gt; &gt;&gt; <a href="https://www.ietf.org/mailman/listinfo/avtext"
> target="_blank">https://www.ietf.org/mailman/listinfo/avtext</a><br>
> > &gt; &gt;&gt;<br>
> > &gt; &gt;<br>
> > &gt;<br>
> > &gt; --<br>
> > &gt; <a href="mailto:[email-masked]">[email-masked]</a>
>          PHONE: <a href="tel:%2B33.1.77.62.43.30" value="+33177624330">
> +33.1.77.62.43.30</a><br>
> > &gt; <a href="http://jitsi.org" target="_blank">http://jitsi.org</a>
>                   FAX:   <a href="tel:%2B33.1.77.62.47.31" value="
> +33177624731">+33.1.77.62.47.31</a><br>
> > &gt;<br>
> > &gt; <a href="https://www.ietf.org/mailman/listinfo/avtext"
> target="_blank">https://www.ietf.org/mailman/listinfo/avtext</a><br>
> > <a href="https://www.ietf.org/mailman/listinfo/avtext" target="_blank">
> https://www.ietf.org/mailman/listinfo/avtext</a><br>