Subject: [avtext] Current status of audio level drafts after face to face meeting (and confirmation of decisions)

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 29 Jul 2011 20:19:27 +0200

For:

draft-ietf-avtext-mixer-to-client-audio-level

The WGLC has been held and the comments made are mainly editorial. The document will be updated shortly to address these comments, and the document is ready for publication request. A poll in the meeting identified a significant number of people had read the WGLC version, and that it was ready for publication.

draft-ietf-avtext-client-to-mixer-audio-level

The WGLC has been held. 

There is one significant technical enhancement to be made, where the proposal is to define an SDP extension to Indicate Voice Activity Detection (VAD) support (or lack of). This was the mechanism that had support in the face to face meeting, and I'll use this message to seek confirmation of that decision on the list.

We'll try and get this extension text to the list. We will get the next version of the draft reviewed by MMUSIC experts for this SDP content.

The document will be updated shortly. A poll in the meeting identified a significant number of people had read the WGLC version, and that it was ready for publication.

Apart from this MMUSIC review we will be looking to do the publication request shortly.

And if you have issues with the face-to-face meeting decision to use an SDP extension to Indicate Voice Activity Detection (VAD) support then please post to the list as soon as possible.

Regards

Keith

---

From: "Kevin P. Fleming" <[email-masked]>
Date: Fri, 29 Jul 2011 16:58:17 -0400

> And if you have issues with the face-to-face meeting decision to use an SDP extension to Indicate Voice Activity Detection (VAD) support then please post to the list as soon as possible.

I presume you mean SDP 'parameter' here, right?

Would this parameter indicate:

* that the offerer has VAD ability and will employ it for reporting 
audio levels

* that the offerer wishes the answerer to employ VAD if it can when it 
reports audio levels

* that the offerer *requires* the answerer to employ VAD when it reports 
audio levels

* something else?

Sorry, I missed the meeting yesterday and I don't think the minutes have 
been posted yet or I'd have consulted them before replying :-)

-- 
Kevin P. Fleming
Digium, Inc. | Director of Software Technologies
Jabber: [email-masked] | SIP: [email-masked] | Skype: kpfleming
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
Check us out at www.digium.com & www.asterisk.org

---

From: Emil Ivov <[email-masked]>
Date: Fri, 29 Jul 2011 23:06:43 +0200

Hey Kevin,

> I presume you mean SDP 'parameter' here, right?

Jonathan will be posting a detailed description here but basically it
will be a parameter in the line that advertises support for the level
extension.

> * that the offerer has VAD ability and will employ it for reporting 

If set accordingly - yes. It could also be set to mean that the offerer
is not planning on using VAD.

> * that the offerer *requires* the answerer to employ VAD when it reports 

This is not the intention and we should probably make it clear in the
text that using the vad param is only meant for extension senders. (Good
point btw!)

Cheers,
Emil

-- 
http://jitsi.org

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sat, 30 Jul 2011 02:51:38 +0200

More specific details have been posted by Jonathan.

Yes it means a SDP parameter.

The notes are not yet available but I suspect they will not give a great deal of detail behind the decision. I think the general opinion was that people wanted something explicit.

Regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Kevin P. Fleming
> Sent: 29 July 2011 21:58
> To: [email-masked]
> Subject: Re: [avtext] Current status of audio level drafts after face to
> face meeting (and confirmation of decisions)
> 
> > The WGLC has been held and the comments made are mainly editorial. The
> document will be updated shortly to address these comments, and the
> document is ready for publication request. A poll in the meeting
> identified a significant number of people had read the WGLC version, and
> that it was ready for publication.
> >
> > There is one significant technical enhancement to be made, where the
> proposal is to define an SDP extension to Indicate Voice Activity
> Detection (VAD) support (or lack of). This was the mechanism that had
> support in the face to face meeting, and I'll use this message to seek
> confirmation of that decision on the list.
> >
> > We'll try and get this extension text to the list. We will get the next
> version of the draft reviewed by MMUSIC experts for this SDP content.
> >
> > The document will be updated shortly. A poll in the meeting identified a
> significant number of people had read the WGLC version, and that it was
> ready for publication.
> >
> > And if you have issues with the face-to-face meeting decision to use an
> SDP extension to Indicate Voice Activity Detection (VAD) support then
> please post to the list as soon as possible.
> 
> _______________________________________________
> avtext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avtext