Subject: [avtext] 答复: Splicing notification draft-xia-avtext-splicing-notification-01

From: Xiajinwei <[email-masked]>
Date: Wed, 9 Oct 2013 03:31:04 +0000

Hi Lingli,

Thank your interest and support on this work, I just try to reactivate it soon.

The splicing use cases you mentioned indeed make sense, RTP Splicing document (RFC6828) keeps the local AD insertion as the representative use case, but it can also considers several other use cases, e.g., emergency information, etc. You can refer the first bullet of introduction section in RFC6828.

Targeted advertising can also use the mixer defined in RFC6828 to handle RTP splicing, while the mixer needs to be more powerful to insert different content for different end users simultaneously. It is an mixer implementation issue IMO.

By the way, China Mobile also has fixed broadband network, right?

BR
Jinwei

发件人: 邓灵莉/Lingli Deng [mailto:[email-masked]]
发送时间: 2013年10月9日 10:21
收件人: Xiajinwei
抄送: [email-masked]
主题: Re: [avtext] Splicing notification draft-xia-avtext-splicing-notification-01

Hi Jinwei,
I also find this work interesting and would like to see it moving forward.
In particular, besides local ad substitution, have you considered applying it to other cases, such as
1, urgent information publication (in case of typhoon, disaster, war, etc) where the mixer could be deployed and owned by the network operator, and
2, target ad insertion based on subscriber’s personal/group profile information provided by the network operator.
I am not sure that the above cases can be addressed by the existing proposal, though.
BR
Lingli
发件人: avtext-bounces at ietf.org [mailto:avtext-bounces at ietf.org] 代表 Jinwei Xia
发送时间: 2013年4月19日 06:29
收件人: avtext at ietf.org
主题: Re: [avtext] Splicing notification draft-xia-avtext-splicing-notification-01

Hi Roni,
Thank your support on this work. The draft aims to provide one generic approach to carry the splicing related metadata to the splicer regardless of the media codec in the RTP payload.
Anybody who review the draft at your convenient time can show your comments to me, it is very appreciated.
BR
Jinwei
发件人: avtext-bounces at ietf.org [mailto:avtext-bounces at ietf.org] 代表 Roni Even
发送时间: 2013年4月17日 21:54
收件人: avtext at ietf.org
主题: [avtext] Splicing notification draft-xia-avtext-splicing-notification-01
Hi,
I read draft-xia-avtext-splicing-notification-01<http://tools.ietf.org/html/draft-xia-avtext-splicing-notification-01> and think it is an important building block for the RTP splicing topology specified in RFC6828.
It allows splicing at RTP level and not only for MPEG2 TS (Transport streams).
I support going forward with this work
Roni Even

---

From: Xiajinwei <[email-masked]>
Date: Thu, 10 Oct 2013 06:14:42 +0000

Lingli,

>[dll] Glad that you are also considering other cases. Would the sender-decided/off-line time slot synchronization between the main sender and the substitution sender requirement be an obstacle to the flexibility of the substitutive content as desired by these cases? For instance, both the start/end time points and the duration of the substitutive media maybe unpredictable to both senders in such cases. But as you said, it could be an implementation issue, since the current document clearly sets the offline negotiation mechanism out of scope:)

Right, the draft aims to solve predictable event, but the unpredictable event (e.g., emergency information) may occur anytime, in such case, ISP just needs to continue the main content at the breaking point. It is out of scope of this draft.

>[dll] Yes, we have been providing xDSL service nationwide since 2008, when China Tietong’s public ISP department merged with China Mobile.

Very glad to hear that as RTP splicing technology might be expected to be used in IPTV environment in the fixed network IMHO.

BR
Jinwei

发件人: 邓灵莉/Lingli Deng [mailto:[email-masked]]
发送时间: 2013年10月10日 11:42
收件人: Xiajinwei
抄送: [email-masked]
主题: 答复: [avtext] Splicing notification draft-xia-avtext-splicing-notification-01

Hi Jinwei,

Thank you for your quick reply.
Plz find my inline comments below.

BR
Lingli

发件人: Xiajinwei [mailto:[email-masked]]
发送时间: 2013年10月9日 11:31
收件人: 邓灵莉/Lingli Deng
抄送: [email-masked]
主题: 答复: [avtext] Splicing notification draft-xia-avtext-splicing-notification-01

Hi Lingli,

[dll] Glad that you are also considering other cases. Would the sender-decided/off-line time slot synchronization between the main sender and the substitution sender requirement be an obstacle to the flexibility of the substitutive content as desired by these cases? For instance, both the start/end time points and the duration of the substitutive media maybe unpredictable to both senders in such cases. But as you said, it could be an implementation issue, since the current document clearly sets the offline negotiation mechanism out of scope:)

[dll] Yes, we have been providing xDSL service nationwide since 2008, when China Tietong’s public ISP department merged with China Mobile.

BR
Jinwei

Hi Jinwei,

Hi Roni,