Subject: [avtext] RTP Topologies and Taxonomy

From: Magnus Westerlund <[email-masked]>
Date: Wed, 6 Nov 2013 07:32:01 -0800

AVTEXT and AVTCORE
(Please respond to AVTEXT only)

In yesterdays WG session in AVTEXT it was brought up a question
regarding Section 4 of draft-ietf-avtext-rtp-grouping-taxonomy-00. This
was the question if this belongs in this draft or should be part of the
RTP Topologies.

My understanding it was put into the taxonomy draft to provide some
examples of how the entities definitions actually relate in some cases.
However, they can also be seen to duplicate quite a lot of the RTP
topologies drafts. And that draft needs an update that uses the
taxonomy, as editor I have that on my todo list. Thus we get to the
question of what should be done in the taxonomy document.

I think there are three alternatives here:

1. Remove all the topologies related discussion and at most make an
explicit reference to topologies as showing how taxonomy can be used to
describe the RTP Topologies.

2. Select a very small number (1 or 2) enlightening examples just to
show what can be done.

3. Include all the main topologies and focus on the bigger picture and
point to how RTP and signalling relate using communication and
multi-media sessions etc.

I personally are not certain between alternative 1 and 2. RTP Topologies
do have some signaling discussion, but may get more to function as good
examples for the entities concepts. Thus, I might lean slightly more
towards 2, with the purpose of focusing on how the communication and
multi-media session interacts with participants, end points and RTP
sessions.

Please provide your opinion or if you think there are additional
alternatives?

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 6 Nov 2013 15:44:35 +0000

-----Original Message-----
From: Magnus Westerlund <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Wednesday, November 6, 2013 at 4:32 PM
To: IETF AVTCore WG <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [AVTCORE] RTP Topologies and Taxonomy

>describe the RTP Topologies.

I am in favor of this approach. It makes it cleaner and easier for someone
getting into this stuff for the first time.

>_______________________________________________
>Audio/Video Transport Core Maintenance
>[email-masked]
>https://www.ietf.org/mailman/listinfo/avt
>

---

From: Colin Perkins <[email-masked]>
Date: Wed, 6 Nov 2013 13:14:07 -0800

On 6 Nov 2013, at 07:44, Ali C. Begen (abegen) <[email-masked]> wrote:
>> 1. Remove all the topologies related discussion and at most make an explicit reference to topologies as showing how taxonomy can be used to describe the RTP Topologies.
> 
> I am in favor of this approach. It makes it cleaner and easier for someone getting into this stuff for the first time.

Agree - if it can be done cleanly, I'd prefer to see all the topologies discussion in one place, rather than duplicating some of it into this draft.

-- 
Colin Perkins
http://csperkins.org/

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 6 Nov 2013 21:44:39 +0000

Agree

The function of the taxononmy document is to define the fundamental RTP terminology.

The topology document should then use that taxonomy.

Keith 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Colin Perkins
> Sent: 06 November 2013 21:14
> To: Ali C. Begen (abegen)
> Cc: [email-masked]
> Subject: Re: [avtext] [AVTCORE] RTP Topologies and Taxonomy
> 
> >> regarding Section 4 of draft-ietf-avtext-rtp-grouping-taxonomy-00. 
> >> This was the question if this belongs in this draft or 
> should be part 
> >> of the RTP Topologies.
> >> 
> >> 1. Remove all the topologies related discussion and at 
> most make an explicit reference to topologies as showing how 
> taxonomy can be used to describe the RTP Topologies.
> > 
> > I am in favor of this approach. It makes it cleaner and 
> easier for someone getting into this stuff for the first time.
> 
> 
> Agree - if it can be done cleanly, I'd prefer to see all the 
> topologies discussion in one place, rather than duplicating 
> some of it into this draft.
> 
> --
> Colin Perkins
> http://csperkins.org/
> 
> 
> 
> avtext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avtext
>

---

From: "Roni Even" <[email-masked]>
Date: Thu, 7 Nov 2013 00:52:03 +0200

Support Colin's and Ali's view
Roni

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Colin Perkins
> Sent: 06 November, 2013 11:14 PM
> >> This was the question if this belongs in this draft or should be part
> >> of the RTP Topologies.
> >>
explicit
> reference to topologies as showing how taxonomy can be used to describe
the
> Agree - if it can be done cleanly, I'd prefer to see all the topologies
discussion
> in one place, rather than duplicating some of it into this draft.
> 
> --
> Colin Perkins
> http://csperkins.org/
> 
> 
>