Subject: [avtext] taxonomy Packet Stream

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 6 Nov 2013 18:49:56 -0800

I have questions about the Packet Stream in the taxonomy.  It says "At any given point in time, a Packet Stream can have one and only one SSRC."  So is it possible for a particular packet stream to have one SSRC value at one time, and then have a different SSRC value some other time, but it is still the same packet stream? What are some examples of this?

For a media switching mixer (from rtp-topologies-update document), it sends a packet stream with its own SSRC value.  So when it switches between available sources, the outgoing SSRC from the mixer doesn't change, so all those packets with the same SSRC belong to the same packet stream both before and after a switch occurs, is that right?

And what about a selective forwarding middlebox? In this case the SSRC changes when a switch occurs, so does this mean a new packet stream starts and the previous packet stream ends? Or do you consider it all the same packet stream even though the SSRC has changed?

Mark Duckworth

---

From: Roni Even <[email-masked]>
Date: Thu, 7 Nov 2013 06:11:39 +0000

Mark,

SSRC collison

Roni

________________________________
From: [email-masked] [[email-masked]] on behalf of Duckworth, Mark [[email-masked]]
Sent: Thursday, November 07, 2013 4:49 AM
To: [email-masked]
Subject: [avtext] taxonomy Packet Stream

I have questions about the Packet Stream in the taxonomy.  It says “At any given point in time, a Packet Stream can have one and only one SSRC.”  So is it possible for a particular packet stream to have one SSRC value at one time, and then have a different SSRC value some other time, but it is still the same packet stream? What are some examples of this?

For a media switching mixer (from rtp-topologies-update document), it sends a packet stream with its own SSRC value.  So when it switches between available sources, the outgoing SSRC from the mixer doesn’t change, so all those packets with the same SSRC belong to the same packet stream both before and after a switch occurs, is that right?

Mark Duckworth

---

From: Mary Barnes <[email-masked]>
Date: Thu, 7 Nov 2013 10:12:11 -0600

Roni,

Can you elaborate a bit more - i.e., answer each of Mark's questions?

Mary.

On Thu, Nov 7, 2013 at 12:11 AM, Roni Even <[email-masked]>wrote:

>  Mark,
>
> SSRC collison
>
> Roni
>  ------------------------------
> *From:* [email-masked] [[email-masked]] on behalf of
> Duckworth, Mark [[email-masked]]
> *Sent:* Thursday, November 07, 2013 4:49 AM
> *To:* [email-masked]
> *Subject:* [avtext] taxonomy Packet Stream
>
>   I have questions about the Packet Stream in the taxonomy.  It says “At
> any given point in time, a Packet Stream can have one and only one SSRC.”
> So is it possible for a particular packet stream to have one SSRC value at
> one time, and then have a different SSRC value some other time, but it is
> still the same packet stream? What are some examples of this?
>
>
>
> For a media switching mixer (from rtp-topologies-update document), it
> sends a packet stream with its own SSRC value.  So when it switches between
> available sources, the outgoing SSRC from the mixer doesn’t change, so all
> those packets with the same SSRC belong to the same packet stream both
> before and after a switch occurs, is that right?
>
>
>
> And what about a selective forwarding middlebox? In this case the SSRC
> changes when a switch occurs, so does this mean a new packet stream starts
> and the previous packet stream ends? Or do you consider it all the same
> packet stream even though the SSRC has changed?
>
>
>
> Mark Duckworth
>
> _______________________________________________
> avtext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avtext
>
>

---

From: Roni Even <[email-masked]>
Date: Thu, 7 Nov 2013 16:46:01 +0000

Mary,

The taxonomy  question was

"So is it possible for a particular packet stream to have one SSRC value at one time, and then have a different SSRC value some other time, but it is still the same packet stream? What are some examples of this?"

 and one exmple is SSRC collison

The other topics are about toplogies and maybe should be sent to avtcore mailing list with regards to the topologies draft

Roni

________________________________
From: Mary Barnes [[email-masked]]
Sent: Thursday, November 07, 2013 6:12 PM
To: Roni Even
Cc: Duckworth, Mark; [email-masked]
Subject: Re: [avtext] taxonomy Packet Stream

Roni,

Mary.

On Thu, Nov 7, 2013 at 12:11 AM, Roni Even <[email-masked]<mailto:[email-masked]>> wrote:

Mark,

SSRC collison

Roni

________________________________
From: [email-masked]<mailto:[email-masked]> [[email-masked]<mailto:[email-masked]>] on behalf of Duckworth, Mark [[email-masked]<mailto:[email-masked]>]
Sent: Thursday, November 07, 2013 4:49 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [avtext] taxonomy Packet Stream

Mark Duckworth

_______________________________________________
avtext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/avtext

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 8 Nov 2013 09:53:45 -0800

Thanks Roni.  It makes sense that SSRC collision is one reason why the SSRC in a packet stream can change. Is that the only reason? I suggest we make this more clear in section 2.1.10.2, the characteristics of a packet stream.

I will ask the other questions in avtcore.

Mark

From: Roni Even [mailto:[email-masked]]
Sent: Thursday, November 07, 2013 8:46 AM
To: Mary Barnes
Cc: Duckworth, Mark; [email-masked]
Subject: RE: [avtext] taxonomy Packet Stream

Mary,

Roni

Mary.

Mark,

SSRC collison

Roni

Mark Duckworth

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 8 Nov 2013 18:23:35 +0000

If you have any suggestions on what the text in the taxonomy draft should say, that always helps the editors

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Duckworth, Mark
Sent: 08 November 2013 17:54
To: [email-masked]
Subject: Re: [avtext] taxonomy Packet Stream

Mark

Mary,

Roni

Mary.

Mark,

SSRC collison

Roni

Mark Duckworth

---

From: Bo Burman <[email-masked]>
Date: Thu, 14 Nov 2013 10:48:03 +0000

For the moment, SSRC collision is the only valid reason I can come to think of. I will add a sentence about that in the draft. Suggestions of other possible reasons are welcome.

With the current taxonomy, Mark is correct on the consequences of the topology-related questions:

*         A media-switching mixer that uses its own SSRC on the outgoing Packet Stream across switches should be regarded as generating a single Packet Stream.

*         A selective forwarding middlebox that keeps original SSRC intact across switches generates a time multiplex of different Packet Streams.

/Bo

From: [email-masked] [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: den 8 november 2013 19:24
To: Duckworth, Mark; [email-masked]
Subject: Re: [avtext] taxonomy Packet Stream

Keith

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Duckworth, Mark

Mark

From: Roni Even [mailto:[email-masked]]
Sent: Thursday, November 07, 2013 8:46 AM
To: Mary Barnes
Cc: Duckworth, Mark; [email-masked]<mailto:[email-masked]>
Subject: RE: [avtext] taxonomy Packet Stream

Mary,

Roni

Cc: Duckworth, Mark; [email-masked]<mailto:[email-masked]>

Mary.

Mark,

SSRC collison

Roni

Mark Duckworth

---

From: Jonathan Lennox <[email-masked]>
Date: Thu, 14 Nov 2013 16:58:47 +0000

Another case for an SSRC change is a clock rate change, following the recommendation of draft-ietf-avtext-multiple-clock-rates.

Also - a selective forwarding middlebox doesn't necessarily keep the original SSRCs intact.  Its important feature is that each forwarded stream gets a distinct SSRC, but these SSRCs might be locally-generated rather than being the original ones.  Despite this quibble, I agree with your characterizations, though.

From: Bo Burman [mailto:[email-masked]]
Sent: Thursday, November 14, 2013 5:48 AM
To: DRAGE, Keith (Keith); Duckworth, Mark; [email-masked]
Subject: Re: [avtext] taxonomy Packet Stream

/Bo

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: den 8 november 2013 19:24
To: Duckworth, Mark; [email-masked]<mailto:[email-masked]>
Subject: Re: [avtext] taxonomy Packet Stream

Keith

Mark

Mary,

Roni

Mary.

Mark,

SSRC collison

Roni

Mark Duckworth