Subject: [avtext] taxonomy question about endpoint and participant

From: "Roni Even" <[email-masked]>
Date: Wed, 6 Nov 2013 01:16:18 +0200

Hi,

I am not sure what is the difference between endpoint and participant.

Some terms from H.323

endpoint: An H.323 terminal, Gateway, or MCU. An endpoint can call and be
called. It generates and/or terminates information streams.

addressable: An H.323 entity on the network having a Transport Address is
addressable. Not the same as being callable. A terminal, Gateway, or MCU is
addressable and callable. A Gatekeeper is addressable but not callable. An
MC or MP is neither callable nor addressable but is contained within an
endpoint or Gatekeeper that is. In a composite Gateway, both the MGC and the
MG are addressable, but only the MGC is callable.

terminal: An H.323 Terminal is an endpoint on the network which provides for
real-time, two-way communications with another H.323 terminal, Gateway, or
Multipoint Control Unit. This communication consists of control,
indications, audio, moving colour video pictures, and/or data between the
two terminals. A terminal may provide speech only, speech and data, speech
and video, or speech, data and video.

Note the distinction between terminal and intermediaries like MCUs and
Gateways

Roni

---

From: Bo Burman <[email-masked]>
Date: Thu, 14 Nov 2013 10:24:17 +0000

The intent of a "Participant" in the taxonomy seems to be very similar to an H.323 "endpoint" below.

The reason to also have an "Endpoint" in the taxonomy comes from the possibility that the "terminal" (in below H.323 terms) used by a single Participant can consist of several "boxes" (Endpoints) with separate transport addresses. For example, a single Participant uses separately addressable equipment for audio codec, for video codec (even several of them) and for signaling logic.

The current definition of "Endpoint" in the taxonomy includes a single transport address. If you use the "addressable" definition below, I guess that there could be several "addressable" "sub-parts" of an H.323 "endpoint", right?

Do we need a separate name for those H.323 "endpoint sub-parts"?

If not, we could merge the current taxonomy Participant and Endpoint into a common concept, similar to the H.323 definition.

/Bo

From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni Even
Sent: den 6 november 2013 00:16
To: [email-masked]
Subject: [avtext] taxonomy question about endpoint and participant

Hi,

Some terms from H.323

endpoint: An H.323 terminal, Gateway, or MCU. An endpoint can call and be called. It generates and/or terminates information streams.

addressable: An H.323 entity on the network having a Transport Address is addressable. Not the same as being callable. A terminal, Gateway, or MCU is addressable and callable. A Gatekeeper is addressable but not callable. An MC or MP is neither callable nor addressable but is contained within an endpoint or Gatekeeper that is. In a composite Gateway, both the MGC and the MG are addressable, but only the MGC is callable.

terminal: An H.323 Terminal is an endpoint on the network which provides for real-time, two-way communications with another H.323 terminal, Gateway, or Multipoint Control Unit. This communication consists of control, indications, audio, moving colour video pictures, and/or data between the two terminals. A terminal may provide speech only, speech and data, speech and video, or speech, data and video.

Note the distinction between terminal and intermediaries like MCUs and Gateways

Roni