Subject: Re: [avtext] Taxonomy

From: Peter Thatcher <[email-masked]>
Date: Wed, 23 Jul 2014 06:38:25 -0700

On the issues of MST/SST, in the meeting, I proposed that we use
non-acronyms, something like:

single-stream-single-transport
multi-stream-single-transport
multi-stream-multi-transport

I still think that this would be more readable and preferable to have
in specs and formal documentation.  However, I understand the tendency
toward acronyms, and I find your proposed acronyms (SRST, MRST, MRMT)
quite readable, and a big improvement over the existing ones.  Would
it be valuable for the Taxonomy to give both a "long form" for more
readable spec and documentation and a "short acronym" for when
acronyms are desired, like so?

Single RTP Stream over Single Transport: single-stream-single-transport or SRST
Multiple RTP Streams over Single Transport:
multi-stream-single-transport or MRST
Multiple RTP Streams over Multiple Transports:
multi-stream-multi-transport or MRMT

Or would everyone just end up using the acronym everywhere?

And while we're playing with names, I'd like to suggest a slight tweak
of the names to highlight the "one to many "or "many to many"
relationship by using the words "one to one" and "one to many".  It
also has the property that "S" can go back in the acronym rather than
"R" for "RTP stream":t

One RTP Stream over One Transport: one-stream-one-transport or OSOT
Many RTP Streams over One Transport: many-streams-one-transport or MSOT
Many RTP Streams over Many Transports: many-streams-many-transports or MSMT

What do you think of that?  Better, worse, or the same?

> Hi,
> In today’s AVTEXT session, the following issues related to the
> taxonomy draft were discussed.
>
> 1. MST/SST: I suggest new terminology focused on Single/Multiple
> Transport (rather than RTP Session) combined with Single/Multiple RTP
> Stream.
> MRMT (Multiple RTP Streams over Multiple Transports)
> MRST (Multiple RTP Streams over Single Transport)
> SRST (Single RTP Stream over Single Transport)
>
> 2. There is no term for referring to a media source or sink. Endpoint
> comes to mind, but that is fundamentally different in -taxonomy.
> Terminal is another possibility, but is generally not used in RTP
> (outside H.323). Another possibility is simply ‘media source/sink’, if
> the usage is not expected to be very high. This issue came up in
> drafting text for the BUNDLE RTP mid, which applies to all RTP streams
> between a pair of media sources/sinks.
>
> 3. There is no term for referring to the set of RTP streams between a
> media source and sink. Transport comes to mind, but that is
> fundamentally different in -taxonomy. Channel is another possibility,
> but is generally not used in RTP. Another possibility is simply ‘RTP
> streams between media source/sink X/Y’, if the usage is not expected
> to be very high. This issue came up in drafting text for the BUNDLE
> RTP mid, which applies to all RTP streams between a pair of media
> sources/sinks.
>
> Mo

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 23 Jul 2014 13:42:56 +0000

My individual preference is to avoid the acronyms, and my sense was that a number of people in the room held that view as well.

Keith 

> -----Original Message-----
> From: avtext [mailto:[email-masked]] On Behalf Of 
> Peter Thatcher
> Sent: 23 July 2014 14:38
> To: [email-masked]
> Subject: Re: [avtext] Taxonomy
> 
> On the issues of MST/SST, in the meeting, I proposed that we 
> use non-acronyms, something like:
> 
> I still think that this would be more readable and preferable 
> to have in specs and formal documentation.  However, I 
> understand the tendency toward acronyms, and I find your 
> proposed acronyms (SRST, MRST, MRMT) quite readable, and a 
> big improvement over the existing ones.  Would it be valuable 
> for the Taxonomy to give both a "long form" for more readable 
> spec and documentation and a "short acronym" for when 
> Single RTP Stream over Single Transport: 
> single-stream-single-transport or SRST Multiple RTP Streams 
> over Single Transport:
> And while we're playing with names, I'd like to suggest a 
> slight tweak of the names to highlight the "one to many "or 
> "many to many"
> relationship by using the words "one to one" and "one to 
> many".  It also has the property that "S" can go back in the 
> acronym rather than "R" for "RTP stream":t
> 
> One RTP Stream over One Transport: one-stream-one-transport 
> or OSOT Many RTP Streams over One Transport: 
> many-streams-one-transport or MSOT Many RTP Streams over Many 
> Transports: many-streams-many-transports or MSMT
> 
> > In today's AVTEXT session, the following issues related to the 
> > MRMT (Multiple RTP Streams over Multiple Transports) MRST (Multiple 
> > RTP Streams over Single Transport) SRST (Single RTP Stream 
> over Single 
> > Transport)
> >
> > (outside H.323). Another possibility is simply 'media 
> source/sink', if 
> > but is generally not used in RTP. Another possibility is 
> simply 'RTP 
> > streams between media source/sink X/Y', if the usage is not 
> expected 
> _______________________________________________
> avtext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avtext
>