Subject: Re: [avtext] Taxonomy

From: Bo Burman <[email-masked]>
Date: Wed, 20 Aug 2014 07:45:57 +0000

Hi Mo, all, see inline.

From: avtext [mailto:[email-masked]] On Behalf Of Mo Zanaty (mzanaty)
Sent: den 23 juli 2014 07:03
To: [email-masked]
Subject: [avtext] Taxonomy

Hi,
In today's AVTEXT session, the following issues related to the taxonomy draft were discussed.

1. MST/SST: I suggest new terminology focused on Single/Multiple Transport (rather than RTP Session) combined with Single/Multiple RTP Stream.
MRMT (Multiple RTP Streams over Multiple Transports)
MRST (Multiple RTP Streams over Single Transport)
SRST (Single RTP Stream over Single Transport)
[BoB] I have no problem with that, if it can finally remove the confusion around this issue.

2. There is no term for referring to a media source or sink. Endpoint comes to mind, but that is fundamentally different in -taxonomy. Terminal is another possibility, but is generally not used in RTP (outside H.323). Another possibility is simply 'media source/sink', if the usage is not expected to be very high. This issue came up in drafting text for the BUNDLE RTP mid, which applies to all RTP streams between a pair of media sources/sinks.
[BoB] Endpoint (or End Point) is different in -taxonomy in that a single End Point may handle/contain several media sources or sinks, if that is an important aspect. I currently don't have a good name suggestion for a single "media source/sink", being one part of an End Point. Suggestions are welcome!

3. There is no term for referring to the set of RTP streams between a media source and sink. Transport comes to mind, but that is fundamentally different in -taxonomy. Channel is another possibility, but is generally not used in RTP. Another possibility is simply 'RTP streams between media source/sink X/Y', if the usage is not expected to be very high. This issue came up in drafting text for the BUNDLE RTP mid, which applies to all RTP streams between a pair of media sources/sinks.
[BoB] Given that most applicable terms will already have been used somewhere, I guess we cannot start totally fresh in that choosing a term will potentially "conflict" with existing RFCs. I see you don't suggest "RTP channel" because it is not used, so I assume a "new" term is also not desirable? What about "RTP flow", which I have seen being used as a set of RTP streams (one or more)? I checked its use in several RFCs and it is consistently used that way; probably more often denoting a single RTP stream than several, but I think that is manageable by including a note in -taxonomy on use of the term in pre-taxonomy RFCs. In that case, I think an RTP flow would have to be defined as distinctly different from "transport flow", which is more general and a heavily overloaded term that should probably be avoided in -taxonomy.

Mo

---

From: Alex Eleftheriadis <[email-masked]>
Date: Wed, 20 Aug 2014 12:06:02 +0000

I like Mo's suggestions for (1), they appear clear enough.

For (2), maybe the best choice is to avoid a specific term and use the full "single media source/sink" or "individual media source/sink".

For (3), what about distinguishing between "multiple media streams between endpoints", vs. "multiple media streams between media sources/sinks". If the term "endpoint" can refer to both single and multiple sources/sinks, would both cases of "multimedia media streams" be referred to as flows?

Part of the problem (in my mind) with the word flow is that it is lacking the grouping connotation - it could equally well apply to a single media stream. Could "bundle" work better?

--Alex

On Aug 20, 2014, at 10:45 AM, Bo Burman <[email-masked]<mailto:[email-masked]>> wrote:

Hi Mo, all, see inline.

From: avtext [mailto:[email-masked]] On Behalf Of Mo Zanaty (mzanaty)
Sent: den 23 juli 2014 07:03
To: [email-masked]<mailto:[email-masked]>
Subject: [avtext] Taxonomy

Hi,
In today’s AVTEXT session, the following issues related to the taxonomy draft were discussed.

2. There is no term for referring to a media source or sink. Endpoint comes to mind, but that is fundamentally different in -taxonomy. Terminal is another possibility, but is generally not used in RTP (outside H.323). Another possibility is simply ‘media source/sink’, if the usage is not expected to be very high. This issue came up in drafting text for the BUNDLE RTP mid, which applies to all RTP streams between a pair of media sources/sinks.
[BoB] Endpoint (or End Point) is different in –taxonomy in that a single End Point may handle/contain several media sources or sinks, if that is an important aspect. I currently don’t have a good name suggestion for a single “media source/sink”, being one part of an End Point. Suggestions are welcome!

3. There is no term for referring to the set of RTP streams between a media source and sink. Transport comes to mind, but that is fundamentally different in -taxonomy. Channel is another possibility, but is generally not used in RTP. Another possibility is simply ‘RTP streams between media source/sink X/Y’, if the usage is not expected to be very high. This issue came up in drafting text for the BUNDLE RTP mid, which applies to all RTP streams between a pair of media sources/sinks.
[BoB] Given that most applicable terms will already have been used somewhere, I guess we cannot start totally fresh in that choosing a term will potentially “conflict” with existing RFCs. I see you don’t suggest “RTP channel” because it is not used, so I assume a “new” term is also not desirable? What about “RTP flow”, which I have seen being used as a set of RTP streams (one or more)? I checked its use in several RFCs and it is consistently used that way; probably more often denoting a single RTP stream than several, but I think that is manageable by including a note in –taxonomy on use of the term in pre-taxonomy RFCs. In that case, I think an RTP flow would have to be defined as distinctly different from “transport flow”, which is more general and a heavily overloaded term that should probably be avoided in -taxonomy.

Mo

_______________________________________________
avtext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/avtext

---

From: Bo Burman <[email-masked]>
Date: Thu, 21 Aug 2014 14:05:09 +0000

For (3) I agree that "RTP flow" lacks the grouping connotation.

The only possible reason for use of multiple RTP streams between a single media source/sink pair is when the media source is encoded with MRMT or MRST (to use the newly introduced terms below) and/or when making use of redundancy streams. The set of those RTP streams, related to a single Media Source, is the transported representation of a single Source Stream. Since there is already a name for it, although not on "transport level", can maybe "Source Stream" be used without causing confusion and despite also not having any grouping connotation?

To come back to your question below, and if using the term "RTP flow", "multiple media (RTP) streams between media sources/sinks" would constitute single RTP flows (between each media source/sink pair), while "multiple media (RTP) streams between endpoints" is unspecific and could consist of one or more RTP flows, depending on the number of media sources/sinks used in those endpoints.

I'm a bit hesitant on using "bundle", or maybe "RTP bundle", to denote the set of RTP streams between a single media source/sink pair. I think that would risk being expected to have the same scope as an SDP bundle (as in the BUNDLE draft), which clearly covers multiple media source/sink pairs.

Cheers,
Bo

From: Alex Eleftheriadis [mailto:[email-masked]]
Sent: den 20 augusti 2014 14:06
To: Bo Burman
Cc: Mo Zanaty (mzanaty); [email-masked]; Christer Holmberg
Subject: Re: [avtext] Taxonomy

--Alex

Hi Mo, all, see inline.

Hi,

Mo

---

From: "Mo Zanaty (mzanaty)" <[email-masked]>
Date: Thu, 21 Aug 2014 14:59:23 +0000

I’m inclined to think taxonomy only needs to define terms for 1 but not 2 or 3. 1 is expected to be used quite often in different drafts, while 2 and 3 may be concepts that rarely need discussion outside the bundle draft. The full descriptions of 2 and 3 are also short enough that new terms may not be warranted.

Mo

From: Bo Burman <[email-masked]<mailto:[email-masked]>>
Date: Thursday, August 21, 2014 at 10:05 AM
To: Alex Eleftheriadis <[email-masked]<mailto:[email-masked]>>
Cc: mzanaty <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Subject: RE: [avtext] Taxonomy

For (3) I agree that “RTP flow” lacks the grouping connotation.

The only possible reason for use of multiple RTP streams between a single media source/sink pair is when the media source is encoded with MRMT or MRST (to use the newly introduced terms below) and/or when making use of redundancy streams. The set of those RTP streams, related to a single Media Source, is the transported representation of a single Source Stream. Since there is already a name for it, although not on “transport level”, can maybe “Source Stream” be used without causing confusion and despite also not having any grouping connotation?

To come back to your question below, and if using the term “RTP flow”, “multiple media (RTP) streams between media sources/sinks” would constitute single RTP flows (between each media source/sink pair), while “multiple media (RTP) streams between endpoints” is unspecific and could consist of one or more RTP flows, depending on the number of media sources/sinks used in those endpoints.

I’m a bit hesitant on using “bundle”, or maybe “RTP bundle”, to denote the set of RTP streams between a single media source/sink pair. I think that would risk being expected to have the same scope as an SDP bundle (as in the BUNDLE draft), which clearly covers multiple media source/sink pairs.

Cheers,
Bo

From: Alex Eleftheriadis [mailto:[email-masked]]
Sent: den 20 augusti 2014 14:06
To: Bo Burman
Cc: Mo Zanaty (mzanaty); [email-masked]<mailto:[email-masked]>; Christer Holmberg
Subject: Re: [avtext] Taxonomy

--Alex

Hi Mo, all, see inline.

Hi,

Mo