Subject: [avtext] [RTP stream pause & resume]: middleboxes (ITU-T H.248.PAURES)

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Wed, 22 Apr 2015 08:35:49 +0000

Hello Christian,

perhaps you noticed already that we've submitted early contributions based on a review and consideration of specific use cases for H.248 IP-to-IP media gateways (besides the obvious primary scenarios for H.248 media servers).

http://wftp3.itu.int/av-arch/avc-site/2013-2016/1506_Che/1506_Che.html

AVD-4695<http://wftp3.itu.int/av-arch/avc-site/2013-2016/1506_Che/AVD-4695.zip>

3

H.248.PAURES: H.248 use cases and design considerations (clauses 1 to 7)

Alcatel-Lucent

AVD-4696<http://wftp3.itu.int/av-arch/avc-site/2013-2016/1506_Che/AVD-4696.zip>

3

H.248.PAURES: Part II - Package review

Alcatel-Lucent

AVD-4697<http://wftp3.itu.int/av-arch/avc-site/2013-2016/1506_Che/AVD-4697.zip>

3

H.248.PAURES: Part III - Possible interactions with RTP topologies

Alcatel-Lucent

Hello Bo & Azam,

when trying to figure out the exact protocol behaviour in the protocol endpoints of the RTP sender and RTP receiver entities, then we ended always in state models, which essentially allow to concentrate the entire specification "in a single place" (which is so far distribute over clauses 5, 6 and 8).

Thus, Fig. 4 "RTP pause states" is the key part at RTP sender side.

Two comments/questions:

1) the RTP sender state model seems to be not fully complete, thus, supposing that the Fig. just highlights the major state transitions, right?

2) a RTP receiver state model is missing, - why?

FYI: above contribution AVD-4696 provides a new proposed Appendix for ITU-T H.248.PAURES related to state modeling and above questions.

Regards,

Albrecht

---

From: Bo Burman <[email-masked]>
Date: Thu, 23 Apr 2015 12:09:11 +0000

Hello Albrecht,

Please find my answers inline below.

BR
/Bo

From: avtext [mailto:[email-masked]] On Behalf Of Schwarz, Albrecht (Albrecht)
Sent: den 22 april 2015 10:36
To: [email-masked]; Christian Groves; Yangweiwei (Tommy)
Cc: [email-masked]
Subject: [avtext] [RTP stream pause & resume]: middleboxes (ITU-T H.248.PAURES)

Hello Christian,

3

Alcatel-Lucent

3

Alcatel-Lucent

3

Alcatel-Lucent

Hello Bo & Azam,

Two comments/questions:

[BoB] Figure 4 is not intended as an RTP sender state model, but describes RTP stream states. This is stated in the first sentence of section 6, just above Figure 4. There is no intention to make this state model "complete", like describing all possible events and actions as state transitions, so the answer to your question is "yes". Figure 4 is included to describe what is actually new RTP stream states compared to RFC 3550, give structure to the text, and (hopefully) enhance the reader's understanding. The figure is intentionally kept simple for clarity, for example omitting transitions for staying in the same state - one reason being that ASCII art with a lot of information is somewhat hard to keep simple. The RTP sender and receiver details are instead provided as text in section 8.

[BoB] For the same reason as above; the state model applies to the RTP stream itself. This is unambiguous, since an RTP stream is always uni-directional.

Regards,

Albrecht