Subject: [avtext] I-D Action: draft-ietf-avtext-rtp-grouping-taxonomy-07.txt

From: [email-masked]
Date: Tue, 23 Jun 2015 06:03:24 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Audio/Video Transport Extensions Working Group of the IETF.

        Title           : A Taxonomy of Semantics and Mechanisms for Real-Time Transport Protocol (RTP) Sources
        Authors         : Jonathan Lennox
                          Kevin Gross
                          Suhas Nandakumar
                          Gonzalo Salgueiro
                          Bo Burman
	Filename        : draft-ietf-avtext-rtp-grouping-taxonomy-07.txt
	Pages           : 47
	Date            : 2015-06-23

Abstract:
   The terminology about, and associations among, Real-Time Transport
   Protocol (RTP) sources can be complex and somewhat opaque.  This
   document describes a number of existing and proposed properties and
   relationships among RTP sources, and defines common terminology for
   discussing protocol entities and their relationships.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-avtext-rtp-grouping-taxonomy/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-avtext-rtp-grouping-taxonomy-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-avtext-rtp-grouping-taxonomy-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Bo Burman <[email-masked]>
Date: Tue, 23 Jun 2015 13:10:41 +0000

This version should address all received AD review and GenArt review comments.

I've created a few additional sections to handle the GenArt review comment about not mentioning anything about security and SRTP. I've named the forward transformation "RTP-based Security", even though "RTP-based Encryption" was discussed and more or less agreed here on the list. While editing I found having "Encryption" in the name to be misleading, since I think the concept must cover both confidentiality (encryption), authentication and integrity protection. I think "security" is then a more general and better word. I then chose "RTP-based Validation" as reverse transform, which was the best I could come up with that was still reasonably short.

List of changes from -06 version (also in the document), for your convenience:
   o  Added RTP-based Security and RTP-based Validation transform
      sections, as well as Secured RTP Stream and Received Secured RTP
      Stream sections.
   o  Improved wording in Abstract and Introduction sections.
   o  Clarified what is considered "media" in section 2.1.2 Media
      Capture.
   o  Changed a number of "Characteristics" lists to more suitable prose
      text.
   o  Re-worded text around use of Encoded and Dependent RTP Streams in
      section 2.1.9 Media Packetizer.
   o  Clarified description of Source RTP Stream in section 2.1.10.
   o  Clarified motivation to use separate Media Transports for
      Simulcast in section 3.6.
   o  Added local descriptions of terms imported from CLUE framework.
   o  Editorial improvements.

Cheers,
Bo

> -----Original Message-----
> From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: den 23 juni 2015 15:03
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-avtext-rtp-grouping-taxonomy-07.txt
> 
> 
> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are
> available at tools.ietf.org.
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt