Subject: [avtext] Spencer Dawkins' Yes on draft-ietf-avtext-rtp-grouping-taxonomy-07: (with COMMENT)

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 09 Jul 2015 04:22:21 -0700

Spencer Dawkins has entered the following ballot position for
draft-ietf-avtext-rtp-grouping-taxonomy-07: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-avtext-rtp-grouping-taxonomy/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Wow, I wish we'd had this document when RTCWeb and CLUE were starting in
parallel! Thank you all for producing it.

Jitter is called out separately from delay in 2.1.16, but not in 2.1.18,
2.1.23, or 2.1.24. Was that intentional?

2.1.16 also calls out inter packet spacings separately. I'm not sure if
that's also relevant in 2.1.18, 2.1.23, or 2.1.24, but wanted to ask.

---

From: Bo Burman <[email-masked]>
Date: Thu, 9 Jul 2015 11:43:03 +0000

Hi Spencer,

> Jitter is called out separately from delay in 2.1.16, but not in 2.1.18, 2.1.23, or 2.1.24. Was that intentional?
Not really.
2.1.18 uses "varying delay on a per packet basis"
2.1.23 uses "varying transmission delay"
2.1.24 also uses "varying transmission delay"
...all of which should cover both delay and delay jitter in some general sense, but are not explicit about it.
This can of course be aligned and made explicit.

> 2.1.16 also calls out inter packet spacings separately. I'm not sure if that's also relevant in 2.1.18, 2.1.23, or 2.1.24, but
> wanted to ask.
It is relevant, but the idea is that _intentional_ inter packet spacing is something that can be introduced by a Media Transport Sender. For any type of "unaware" network and for a received stream, it is thought to be covered by "varying delay", since that is then the only observable property and assumedly not as intentional. Do you think it would be beneficial to add a few words on that?

Cheers,
Bo

> -----Original Message-----
> From: Spencer Dawkins [mailto:[email-masked]]
> Sent: den 9 juli 2015 13:22
> To: The IESG
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Spencer Dawkins' Yes on draft-ietf-avtext-rtp-grouping-taxonomy-07: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines.
> (Feel free to cut this introductory paragraph, however.)
> 
> 
> Wow, I wish we'd had this document when RTCWeb and CLUE were starting in parallel! Thank you all for producing it.
> 
> Jitter is called out separately from delay in 2.1.16, but not in 2.1.18, 2.1.23, or 2.1.24. Was that intentional?
> 
> 2.1.16 also calls out inter packet spacings separately. I'm not sure if that's also relevant in 2.1.18, 2.1.23, or 2.1.24, but
> wanted to ask.
>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 9 Jul 2015 13:51:19 +0200

> This can of course be aligned and made explicit.
Some background info in RFC 5481.

Regards, Benoit

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 9 Jul 2015 08:52:31 -0500

Hi, Bo,

> This can of course be aligned and made explicit.

I don't have hugely strong feelings about this, but aligned is good. Using
a variety of phrasings makes readers wonder whether there are intentional
differences.

> It is relevant, but the idea is that _intentional_ inter packet spacing is
> something that can be introduced by a Media Transport Sender. For any type
> of "unaware" network and for a received stream, it is thought to be covered
> by "varying delay", since that is then the only observable property and
> assumedly not as intentional. Do you think it would be beneficial to add a
> few words on that?

That was my guess, but I was guessing. If you inserted "intentional", that
would have clued me in more completely.

> > Cc: [email-masked];
> [email-masked];
> > [email-masked];
> [email-masked]; [email-masked];
> > [email-masked]
> > Subject: Spencer Dawkins' Yes on
> draft-ietf-avtext-rtp-grouping-taxonomy-07: (with COMMENT)
> >
> email addresses included in the To and CC lines.
> > Please refer to
> https://www.ietf.org/iesg/statement/discuss-criteria.html