Subject: [avtext] I-D Action: draft-ietf-avtext-sdes-hdr-ext-03.txt

From: [email-masked]
Date: Mon, 15 Feb 2016 08:16:05 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Audio/Video Transport Extensions of the IETF.

        Title           : RTP Header Extension for RTCP Source Description Items
        Authors         : Magnus Westerlund
                          Bo Burman
                          Roni Even
                          Mo Zanaty
	Filename        : draft-ietf-avtext-sdes-hdr-ext-03.txt
	Pages           : 15
	Date            : 2016-02-15

Abstract:
   Source Description (SDES) items are normally transported in RTP
   control protocol (RTCP).  In some cases it can be beneficial to speed
   up the delivery of these items.  Mainly when a new source (SSRC)
   joins an RTP session and the receivers needs this source's identity,
   relation to other sources, or its synchronization context, all of
   which may be fully or partially identified using SDES items.  To
   enable this optimization, this document specifies a new RTP header
   extension that can carry SDES items.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-avtext-sdes-hdr-ext/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-avtext-sdes-hdr-ext-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-avtext-sdes-hdr-ext-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Bo Burman <[email-masked]>
Date: Mon, 15 Feb 2016 16:45:22 +0000

This version addresses the AD evaluation comments on the security section (6).

The AD comments on starting an explicit IANA RTP header extension sub-registry with urn:ietf:params:rtp-hdrext:sdes as root are still open. The draft reserves a "sub-space" of the existing registry, but establishes new rules for the new sub-space, which may not be so obvious for anyone making additions to this "sub-space" unless this is documented in IANA.

Should the draft rather be explicit in requesting a new sub-registry, registering...:sdes:cname, and moving the (existing) ...:sdes:mid into this sub-registry?

Further comments are welcome!

/Bo B

> -----Original Message-----
> From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: den 15 februari 2016 17:16
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-avtext-sdes-hdr-ext-03.txt
> 
> 
> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are
> available at tools.ietf.org.
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Jonathan Lennox <[email-masked]>
Date: Mon, 15 Feb 2016 17:36:30 +0000

> On Feb 15, 2016, at 11:45 AM, Bo Burman <[email-masked]> wrote:
> 

(Speaking as an individual:) This seems like a good idea to me.

---

From: "Ben Campbell" <[email-masked]>
Date: Fri, 19 Feb 2016 16:50:01 -0600

Hi,

For the record, I think this version will be ready for working group 
last call as soon as people close on this issue.

Thanks!

Ben.

On 15 Feb 2016, at 10:45, Bo Burman wrote:

> The AD comments on starting an explicit IANA RTP header extension 
> sub-registry with urn:ietf:params:rtp-hdrext:sdes as root are still 
> open. The draft reserves a "sub-space" of the existing registry, but 
> establishes new rules for the new sub-space, which may not be so 
> obvious for anyone making additions to this "sub-space" unless this is 
> documented in IANA.
>
> Should the draft rather be explicit in requesting a new sub-registry, 
> registering...:sdes:cname, and moving the (existing) ...:sdes:mid into 
> this sub-registry?
>
>> Please note that it may take a couple of minutes from the time of 
>> submission until the htmlized version and diff are
>> Internet-Draft directories: http://www.ietf.org/shadow.html or 
>> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> avtext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avtext