Subject: [babel] Benoit Claise's No Objection on charter-ietf-babel-00-02: (with COMMENT)

From: "Benoit Claise" <[email-masked]>
Date: Thu, 02 Jun 2016 02:16:41 -0700

Benoit Claise has entered the following ballot position for
charter-ietf-babel-00-02: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-babel/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Not really a DISCUSS, but I would like to at least try to convince you if
you disagree.

"Address manageability of Babel by producing an informational model,
for use by other network management, and a YANG module based on it, to
be consistent with the ongoing effort to use YANG modules in the
Routing Area.  This is required as part of moving Babel to Proposed
Standard."

Do the WG really want to focus on an information model first, as opposed
to go directly to a data model?
See RFC3444. The end goal is a YANG data model, as you correctly
stressed.

Proposal (we used this sentence in SUPA): 
If the working group finds it necessary to work on an information model 
before the data model, to help provide guidance and derive the data 
models, it may do so. The working group will decide later whether the 
information model needs to be published as an RFC.

Also, "This is required as part of moving Babel to Proposed Standard."
I want to make sure we set the right expectations for this.
Babel will not move to Proposed Standard unless we publish the YANG data
model at the same time. 
If so, I like that. You might want to make it clear, in the charter text
or the milestones.

Editorial: YANG module => YANG data model

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 2 Jun 2016 14:06:08 +0000

> Not really a DISCUSS, but I would like to at least try to convince you if you
> disagree.
> 
> "Address manageability of Babel by producing an informational model, for
> use by other network management, and a YANG module based on it, to be
> consistent with the ongoing effort to use YANG modules in the Routing Area.
> This is required as part of moving Babel to Proposed Standard."
> 
> Do the WG really want to focus on an information model first, as opposed to
> go directly to a data model?
> See RFC3444. The end goal is a YANG data model, as you correctly stressed.
> 
> before the data model, to help provide guidance and derive the data models,
> it may do so. The working group will decide later whether the information
> model needs to be published as an RFC.
> 
> If so, I like that. You might want to make it clear, in the charter text or the
> milestones.
> 

As I mentioned in Buenos Aires...
Since Babel is intended for more of an unmanaged home network environment, and homenet WG intends to create a profile that hopefully will require little to no management; 
 - and any management in such an environment would ideally be done through a UI by the user; 
 - and the only managed routers that currently exist in this environment are TR-069 managed routers (to the best of knowledge there are no netconf or restconf managed routers in home networks); 
 - and there are 100s of millions of TR-069 managed routers deployed 

-> I believe it is very important that the process allows for efficient and simple derivation of the TR-069 data model. I accept that a YANG model is necessary from a dogmatic perspective, in spite of the fact that no home network devices are managed at this time using netconf or restconf. But backing into TR-069 from YANG is more difficult than going into TR-069 from an information model. I'm having first-hand experience in LMAP where the YANG modeler is constantly trying to make changes to the information model to make it exactly match how he wants to do the YANG model, while ignoring the needs of TR-069.

I'm willing to work on the information model and to work with whoever does the YANG data model to make sure the information model meets the needs of both YANG and TR-069. I'm fine if it's in one doc. But if the info model is just going to be derived from the YANG model, and to heck with TR-069, I'm not so interested. I will still participate to prevent the model from being overly bloated with all sorts of unnecessary configuration and statistics reporting parameters. Whatever model we come up with must be very, very simple. 
Barbara

---

From: Alia Atlas <[email-masked]>
Date: Thu, 2 Jun 2016 10:16:06 -0400

Barbara's concern and point about needing TR-069 is why there's an
information model instead of just the YANG data model.

I don't think we will hold up the main Babel draft for completion of the
YANG data model - but both need to be done as part of the process.

We can add some text indicating the second expected use.

Thanks,
Alia

On Thu, Jun 2, 2016 at 10:06 AM, STARK, BARBARA H <[email-masked]> wrote:

> models,
> or the
> Since Babel is intended for more of an unmanaged home network environment,
> and homenet WG intends to create a profile that hopefully will require
> little to no management;
>  - and the only managed routers that currently exist in this environment
> are TR-069 managed routers (to the best of knowledge there are no netconf
> or restconf managed routers in home networks);
> -> I believe it is very important that the process allows for efficient
> and simple derivation of the TR-069 data model. I accept that a YANG model
> is necessary from a dogmatic perspective, in spite of the fact that no home
> network devices are managed at this time using netconf or restconf. But
> backing into TR-069 from YANG is more difficult than going into TR-069 from
> an information model. I'm having first-hand experience in LMAP where the
> YANG modeler is constantly trying to make changes to the information model
> to make it exactly match how he wants to do the YANG model, while ignoring
> the needs of TR-069.
>
> I'm willing to work on the information model and to work with whoever does
> the YANG data model to make sure the information model meets the needs of
> both YANG and TR-069. I'm fine if it's in one doc. But if the info model is
> just going to be derived from the YANG model, and to heck with TR-069, I'm
> not so interested. I will still participate to prevent the model from being
> overly bloated with all sorts of unnecessary configuration and statistics
> reporting parameters. Whatever model we come up with must be very, very
> simple.
> Barbara
>
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel
>

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 2 Jun 2016 10:56:21 -0400

Hi,

> We can add some text indicating the second expected use.

Adding a specific reference to the Broadband Forum TR-069 is straightforward.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

>> are TR-069 managed routers (to the best of knowledge there are no netconf or
>> restconf managed routers in home networks);

---

From: Bob Hinden <[email-masked]>
Date: Thu, 2 Jun 2016 08:52:40 -0700

Barbara,

> On Jun 2, 2016, at 7:06 AM, STARK, BARBARA H <[email-masked]> wrote:
> 

My understanding is that TR-069 is used by ISPs to manage routers they deploy at the edge of the customers network, I am not sure it is appropriate to have an ISP managing routers in a homenet (that is, homes, small enterprises, etc.).  There may be multiple ISP connections as well.

As you point out the environment where Babel appears to be very useful is in an unmanaged homenet, so I don’t see the need to include a TR-069 information model in the Babel charter.

Thanks,
Bob

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 2 Jun 2016 16:26:19 +0000

> My understanding is that TR-069 is used by ISPs to manage routers they
> deploy at the edge of the customers network, I am not sure it is appropriate
> to have an ISP managing routers in a homenet (that is, homes, small
> enterprises, etc.).  There may be multiple ISP connections as well.
> 
> As you point out the environment where Babel appears to be very useful is
> in an unmanaged homenet, so I don’t see the need to include a TR-069
> information model in the Babel charter.

Hi Bob,
I fully expect the ISP-managed customer edge router to participate in many homenets. Naturally, people should always have the option of firewalling between the homenet and this ISP router (which is what I do). But most people don't do that. The ISP-managed router is a key component of most home networks. 

If ISPs want to help their customers turn their home network into a "homenet" home network, then the ISP will put protocols like Babel into the ISP-managed customer edge router. In that case, the ISP will expect to be able to manage aspects of Babel in that one router -- enable/disable it, enable/disable specific components like IPv4, be able to retrieve statistics/info to help with troubleshooting when the customer calls the help desk, etc. 

I absolutely do not want to see the ISP managing any other router inside the home network.
Barbara

---

From: Juliusz Chroboczek <[email-masked]>
Date: Thu, 02 Jun 2016 21:44:52 +0200

> I fully expect the ISP-managed customer edge router to participate in
> many homenets.

I've heard both opinions -- that the CPE participates in HNCP/Babel, and
that the CPE only announces itself to the Homenet using DHCPv6-PD.  Hnetd
supports both models out of the box, while shncpd currently only supports
the former (without some creative scripting).

DHCPv6-PD works fine if there's only one Homenet router directly connected
to the CPE.  If there are more than one, however, you get as many prefixes
assigned to your Homenet as there are successful prefix delegations, which
can be as many as there are routers.

My take is that while we don't know how Homenet will be deployed, we
should certainly anticipate the (desirable) case where the CPE implements
HNCP and Babel (possibly a stub subset).  TR-069 for Babel would be
a goodness.

-- Juliusz

---

From: Benoit Claise <[email-masked]>
Date: Mon, 6 Jun 2016 12:45:12 +0200

Barbara,
>   - and there are 100s of millions of TR-069 managed routers deployed
Disclaimer: I was not in the BoF, I'm not following the mailing list, 
and I'm not that familiar with Babel. So I worked from the charter text.
So those Babel use cases are new to me. A sentence or two in the charter 
justifying this information model this way would have helped me.
>
> -> I believe it is very important that the process allows for efficient and simple derivation of the TR-069 data model. I accept that a YANG model is necessary from a dogmatic perspective, in spite of the fact that no home network devices are managed at this time using netconf or restconf.
FYI.  http://www.sysrepo.org/. In one sentence: NETCONF  YANG-based 
management of home gateway routers running on LINUX OS (OpenWRT).

> But backing into TR-069 from YANG is more difficult than going into TR-069 from an information model.
That sounds logical.
> I'm having first-hand experience in LMAP where the YANG modeler is constantly trying to make changes to the information model to make it exactly match how he wants to do the YANG model, while ignoring the needs of TR-069.
>
> I'm willing to work on the information model and to work with whoever does the YANG data model to make sure the information model meets the needs of both YANG and TR-069. I'm fine if it's in one doc. But if the info model is just going to be derived from the YANG model,
... then we have a problem.
The IM should be start, the DM the more specific information derived 
from the IM.
See RFC3444.

Regards, Benoit
> and to heck with TR-069, I'm not so interested. I will still participate to prevent the model from being overly bloated with all sorts of unnecessary configuration and statistics reporting parameters. Whatever model we come up with must be very, very simple.
> Barbara
>
> .
>

---

From: Alia Atlas <[email-masked]>
Date: Mon, 6 Jun 2016 10:14:11 -0400

Hi Benoit,

Do you see additional text changes desired from
https://datatracker.ietf.org/doc/charter-ietf-babel/?

I've updated it to say:

- Address manageability of Babel by producing an informational model for
use by other network management such as the Broadband Forum TR-069, and a
YANG data module based on that information model.  The former supports the
case where the Customer-Premise Equipment (CPE) is managed by the Service
Provider (SP) as is done today.  The latter YANG model supports management
of home gateway routers and is  consistent with the ongoing effort to use
YANG data modules in the Routing Area. This work is required as part of
moving Babel to Proposed Standard.

Thanks,
Alia

On Mon, Jun 6, 2016 at 6:45 AM, Benoit Claise <[email-masked]> wrote:

>> Since Babel is intended for more of an unmanaged home network
>> environment, and homenet WG intends to create a profile that hopefully will
>> require little to no management;
> Disclaimer: I was not in the BoF, I'm not following the mailing list, and
> I'm not that familiar with Babel. So I worked from the charter text.
>> network devices are managed at this time using netconf or restconf.
>>
>> I'm having first-hand experience in LMAP where the YANG modeler is
>> constantly trying to make changes to the information model to make it
>> exactly match how he wants to do the YANG model, while ignoring the needs
>> of TR-069.
>>
>> I'm willing to work on the information model and to work with whoever
>> does the YANG data model to make sure the information model meets the needs
>> of both YANG and TR-069. I'm fine if it's in one doc. But if the info model
>> is just going to be derived from the YANG model,
>>
> The IM should be start, the DM the more specific information derived from
> the IM.
> See RFC3444.
>
> Regards, Benoit
>
>> and to heck with TR-069, I'm not so interested. I will still participate
>> to prevent the model from being overly bloated with all sorts of
>> unnecessary configuration and statistics reporting parameters. Whatever
>> model we come up with must be very, very simple.
>> Barbara
>>
>> .
>>
>>
>

---

From: Benoit Claise <[email-masked]>
Date: Mon, 6 Jun 2016 17:07:27 +0200

That works for me.
Thanks Alia.

Regards, Benoit
> - Address manageability of Babel by producing an informational model 
> for use by other network management such as the Broadband Forum 
> TR-069, and a YANG data module based on that information model.  The 
> former supports the case where the Customer-Premise Equipment (CPE) is 
> managed by the Service Provider (SP) as is done today.  The latter 
> YANG model supports management of home gateway routers and is 
>  consistent with the ongoing effort to use YANG data modules in the 
> Routing Area. This work is required as part of moving Babel to 
> Proposed Standard.
>
> Thanks,
> Alia
>
> On Mon, Jun 6, 2016 at 6:45 AM, Benoit Claise <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Barbara,
>
>         environment, and homenet WG intends to create a profile that
>         hopefully will require little to no management;
>           - and the only managed routers that currently exist in this
>         environment are TR-069 managed routers (to the best of
>         knowledge there are no netconf or restconf managed routers in
>         home networks);
>     Disclaimer: I was not in the BoF, I'm not following the mailing
>     list, and I'm not that familiar with Babel. So I worked from the
>     charter text.
>     So those Babel use cases are new to me. A sentence or two in the
>     charter justifying this information model this way would have
>     helped me.
>
>
>         -> I believe it is very important that the process allows for
>         efficient and simple derivation of the TR-069 data model. I
>         accept that a YANG model is necessary from a dogmatic
>         perspective, in spite of the fact that no home network devices
>         are managed at this time using netconf or restconf.
>
>         I'm having first-hand experience in LMAP where the YANG
>         modeler is constantly trying to make changes to the
>         information model to make it exactly match how he wants to do
>         the YANG model, while ignoring the needs of TR-069.
>
>         I'm willing to work on the information model and to work with
>         whoever does the YANG data model to make sure the information
>         model meets the needs of both YANG and TR-069. I'm fine if
>         it's in one doc. But if the info model is just going to be
>         derived from the YANG model,
>
>     The IM should be start, the DM the more specific information
>     derived from the IM.
>     See RFC3444.
>
>     Regards, Benoit
>
>         and to heck with TR-069, I'm not so interested. I will still
>         participate to prevent the model from being overly bloated
>         with all sorts of unnecessary configuration and statistics
>         reporting parameters. Whatever model we come up with must be
>         very, very simple.
>         Barbara
>
>         .
>
>
>