Subject: [babel] FW: New Version Notification for draft-stark-babel-information-model-00.txt

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 7 Jul 2016 21:18:45 +0000

I created a very rough first draft of an information model for Babel. I'm not wed to any part of it, so throw anything at it you want.
Barbara

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, July 07, 2016 5:17 PM
To: Barbara Stark <[email-masked]>
Subject: New Version Notification for draft-stark-babel-information-model-00.txt

A new version of I-D, draft-stark-babel-information-model-00.txt
has been successfully submitted by Barbara Stark and posted to the IETF repository.

Name:		draft-stark-babel-information-model
Revision:	00
Title:		Babel Information Model
Document date:	2016-07-07
Group:		Individual Submission
Pages:		8
URL:            https://www.ietf.org/internet-drafts/draft-stark-babel-information-model-00.txt
Status:         https://datatracker.ietf.org/doc/draft-stark-babel-information-model/
Htmlized:       https://tools.ietf.org/html/draft-stark-babel-information-model-00

Abstract:
   This Babel Information Model can be used to create data models under
   various data modeling regimes (e.g., YANG).  It allows a Babel
   implementation (via a management protocol such as netconf) to report
   on its current state and may allow some limited configuration of
   protocol constants.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Juliusz Chroboczek <[email-masked]>
Date: Fri, 15 Jul 2016 22:33:23 +0200

Dear Barbara, dear list,

I am in favour of adoption of this document.

Detailed comments:

> int                   babel-version;

This should be a string.  Possible values might be "babeld-1.7.1-64-g75de8a4"
and "bird-1.6.1".

This should be renamed to "babel-implementation-version".

> int                   babel-self-router-id;

This is an opaque 64-bit identifier.  Should it be an int?

> babel-interfaces-obj  babel-interfaces<1..*>;
> babel-sources-obj     babel-sources<1..*>;
> babel-routes-obj      babel-routes<1..*>;

Why are these optional, rather than non-optional <0..*>?  (It's
equivalent, but it seems more natural that way.)

> }babel-constants-obj;

I suggest removing all of these values except the UDP port, and having
per-interface values.  These are just default values in the reference
implementation, I'm not sure they should be standardised.

Multicast group should be added.
 
> }babel-interfaces-obj;

This needs further discussion, I fear some of these are implementation
details.

> [int                  babel-neighbor-router-id;]
> [...]
> }babel-neighbors-obj;

The router ID of a neighbour cannot be reliably determined in general: if
a router doesn't announce any routes, it never announces its router-id.
Suggest removing.

Thanks again lot for your work, Barbara.

-- Juliusz