Subject: [babel] routing tables of death

From: Dave Taht <[email-masked]>
Date: Fri, 8 Sep 2017 12:12:40 -0700

I confess curiosity, now that we have quagga, bird, and mainline
babeld versions, and nifty new stuff like unicast hellos, as to how
well they interoperate at this point, as well as perform, under a
stress test like:

https://github.com/dtaht/rtod

-- 

Dave Täht
CEO, TekLibre, LLC
http://www.teklibre.com
Tel: 1-669-226-2619

---

From: "Russ White" <[email-masked]>
Date: Tue, 12 Sep 2017 16:28:34 -0400

> I confess curiosity, now that we have quagga, bird, and mainline babeld
> versions, and nifty new stuff like unicast hellos, as to how well they
> interoperate at this point, as well as perform, under a stress test like:

And FRR...

😊

Russ

---

From: Juliusz Chroboczek <[email-masked]>
Date: Wed, 13 Sep 2017 11:15:28 +0200

> And FRR...

Babeld and FRR are known to interoperate, but that's little surprise,
since they're based on the same code.

Quagga (the better-named ancestor of FRR) does not have a Babel
implementation.

Perhaps Toke and David can tell us more about the tests they've done with
their respective implementations.

(It would definitely be a cool thing to organise an interop event, perhaps
here in Paris.  Not before 2018, though, the way my schedule is going.)

-- Juliusz

---

From: Dave Taht <[email-masked]>
Date: Wed, 13 Sep 2017 12:01:39 -0700

> their respective implementations.

David's implementation also does unicast route transfer?

> here in Paris.  Not before 2018, though, the way my schedule is going.)

Regrettably I have no time either, before 2018, it seems. I do hope to
have completed removing infinite buffering from a wifi mcast queue,
replacing it with a drop head, fq'd version by then.

fiddling with rtod sparked a great deal of (largely futile) thinking
about deadline scheduling and sanely shedding (cpu or bandwidth) load,
some of which I just wrote up here:

https://plus.google.com/u/0/107942175615993706558/posts/ER5Kcp5KGRj?cfem=1

-- 

Dave Täht
CEO, TekLibre, LLC
http://www.teklibre.com
Tel: 1-669-226-2619

---

From: David Schinazi <[email-masked]>
Date: Thu, 14 Sep 2017 10:10:58 -0700

I haven't had the time to test interop or under load since we added unicast hellos, this would be an interesting experiment.
If an interop event is happening in Paris early 2018, having it the week before or after IETF 101 (March 18-23) would greatly increase my odds of attending.

David

> On Sep 13, 2017, at 12:01, Dave Taht <[email-masked]> wrote:
> 
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel

---

From: Dave Taht <[email-masked]>
Date: Tue, 26 Sep 2017 13:01:20 -0700

I too may be able to visit Paris in late march.

also, a start at an alternative to shortest path metrics, with so many
problems that I'd run off this page writing them up, but I was happy
to read it this morning.

 http://ieeexplore.ieee.org/abstract/document/8025937/

---

From: Jehan Tremback <[email-masked]>
Date: Wed, 27 Sep 2017 10:00:08 -0700

Unfortunately there's a paywall on that article, but I was wondering, what
advantages does their queue aware technique have over latency based routing?

On Tue, Sep 26, 2017 at 1:01 PM, Dave Taht <[email-masked]> wrote:

> Babel-users mailing list
> [email-masked]
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/babel-users
>