Subject: [babel] information-model: hmac-key datatype

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 16 Jan 2019 17:16:29 +0000

What datatype should we use for the hmac-key parameter?
Choices are binary or hex (I think we've already agreed on not "string").

My preference is "binary", because we aren't using hex for anything else, so I'd have to add a definition for it. Of course, when I do a TR-181 data model, I'll be using the TR-181 "hexBinary" datatype that's defined as "hex encoded binary".
Barbara

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Fri, 18 Jan 2019 17:52:02 +0000

> My preference is "binary", because we aren't using hex for anything else, so
> I'd have to add a definition for it. Of course, when I do a TR-181 data model,
> I'll be using the TR-181 "hexBinary" datatype that's defined as "hex encoded
> binary".

Having heard no other preferences expressed, I declare my preference of "binary" to be the winner.
Barbara