Subject: [babel] information-model: Message Log Format

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 18 Feb 2019 15:00:21 +0000

Hi Babel,
We had discussion in January about what sort of message log format to require (?) for the (optional to implement) Babel message log. There was general agreement that libpcap was the best format, but not on how to require it. I don't think that a conditional mandatory (something that MUST be true if an optional element is implemented) is the same as mandatory, but I'm not willing to argue strongly about this. I'm also unwilling to define a new format within IETF to avoid an external-to-IETF reference. My proposal then is to make libpcap a "SHOULD". I think the risk of someone who chooses to implement Babel message logging selecting some other format is low. But if this is also no good, my next solution will be to remove the message log data elements from the information model.

Here's a link to the thread in the archive:
https://mailarchive.ietf.org/arch/browse/babel/?gbt=1&q=info-model%20message%20log

Proposed language (under babel-interfaces):

babel-message-log: : A reference or url link to a file that contains a timestamped log of messages received and sent on babel-udp-port on this interface. The {{libpcap}} file format with .pcap file extension SHOULD be supported for message log files. Logging is enabled / disabled by babel-message-log-enable.

Normative Reference
libpcap: 
title: Libpcap 
org: Wireshark 
date: 2015 
target: https://wiki.wireshark.org/Development/LibpcapFileFormat

Barbara

---

From: Gabriel Kerneis <[email-masked]>
Date: Mon, 18 Feb 2019 16:58:04 +0100

On Mon, Feb 18, 2019 at 4:00 PM STARK, BARBARA H <[email-masked]> wrote:

> My proposal then is to make libpcap a "SHOULD". I think the risk of
> someone who chooses to implement Babel message logging selecting some other
> format is low.
>

I support this choice.

babel-message-log: : A reference or url link to a file that contains a
> timestamped log of messages received and sent on babel-udp-port on this
> interface. The {{libpcap}} file format with .pcap file extension SHOULD be
> supported for message log files. Logging is enabled / disabled by
> babel-message-log-enable.
>

Do we want to explicitly that additional formats MAY be supported or is
that always expected?

Gabriel

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 18 Feb 2019 16:18:01 +0000

>> babel-message-log: : A reference or url link to a file that contains 
>> a timestamped log of messages received and sent on babel-udp-port 
>> on this interface. The {{libpcap}} file format with .pcap file extension 
>> SHOULD be supported for message log files. Logging is enabled / disabled by babel-message-log-enable.

> Do we want to explicitly that additional formats MAY be supported or is that always expected?

I think it's always expected in the absence of a prohibition. In my experience, MAY statements are really only useful when there's a desire to encourage a behavior and there's no agreement that it's a "SHOULD". My reading of the thread is there's no desire to actively encourage other formats. So I think the implicit (unspoken) "MAY" rather than explicit "MAY" is better.
Barbara