Subject: [babel] info-model: link properties

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 18 Apr 2019 19:00:42 +0000

Hi Babel,
I'm working through the issues discussed in Prague. I'll be sending separate emails for separate issues. This email is about the Link Properties registry (formerly Link Types) and associated parameters.

The conclusions I recorded from Prague were that "Link Types" was not an accurate name, because the registry items are really more a collection of link properties. We should change the name, use names for the registry items that better evoke a collection of properties, and change the descriptions to talk some about the link properties that the registry item is for. 

Here's what I propose, and the questions I still have:
Change to Link Properties registry, and the parameters are babel-supported-link-properties (read-only list of supported registry items) and babel-link-properties (the link properties currently associated with an interface).

Change registry items to
other: no link property information available
tunnel: a tunneled interface over unknown physical link
wired: 
wireless:

Questions: 
Are wired and wireless the right names to use?
How should these 2 be described? That is, what are the properties we care about, that make a link considered to be wired or wireless (or whatever name we give these property collections)?

Barbara

---

From: Juliusz Chroboczek <[email-masked]>
Date: Fri, 26 Apr 2019 12:21:00 +0200

> tunnel: a tunneled interface over unknown physical link

That is not my understanding of what we agreed to.

I was under the impression that we had decided that the classification of
link types in wired/wireless/tunnel is an internal implementation detail
of babeld, and that what we wanted to export were the underlying
properties, which are:

  - link cost estimator (ETX or 2-out-of-3);
  - use split-horizon (boolean);
  - use RTT (boolean).

wired means 2-out-of-3, split-horizon, no RTT.
wireless means ETX, no split-horizon, no RTT.
tunnel means 2-out-of-3, split-horizon, RTT.

It is clear to me that the interface type abstration is useful for the
user, who doesn't want to deal with technical details such as whether the
split-horizon optimisation is allowable on a given link type, but it's
difficult to export from the management interface.

-- Juliusz