Subject: [babel] info-model: calculated and received metrics

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 18 Apr 2019 20:33:59 +0000

This was discussed in Prague, but I think it still didn't come to the right conclusion (in my head) as I look at it again.

>From reading rfc6126bis, it appears that 
 - all routes advertised by neighbors will have a received metric
 - all routes advertised by this router will have a calculated metric
 - routes originated by this router will not have a received metric
 - routes with infinite received metrics don't need a calculated metric

For a route to exist in the info model babel-routes object, either the received or calculated metric MUST be non-zero (rfc6126bis only mentions the received metric as being in its route table).
Both parameters will be non-zero if the route is received and selected.
Both parameters are important and need to be implemented.

Are these accurate statements?
Barbara

---

From: Juliusz Chroboczek <[email-masked]>
Date: Fri, 26 Apr 2019 12:22:50 +0200

>  - routes with infinite received metrics don't need a calculated metric

In the last case -- the calculated metric will necessarily be infinite.

> For a route to exist in the info model babel-routes object, either the
> received or calculated metric MUST be non-zero (rfc6126bis only mentions
> the received metric as being in its route table).

Zero is a perfectly fine value for a metric (actually, the very best).
Perhaps you meant defined instead of non-zero?

-- Juliusz