Subject: [BEEPwg] SOAP Profile Over BEEP - Boot State

From: fundooguy love <[email-masked]>
Date: Sun, 31 Mar 2002 23:31:07 -0800 (PST)

Hi

I have just joined this group and I am currently
looking in SOAP profile over Beep's current draft -
Using SOAP in BEEP by E. O' Tuathail and M. Rose.

Its written that peers can go in ready state either
during channel initialization or after the channel has
been created. In case peers do not perform profile
initialization at the time of channel initialization,
"the peer requesting the creation of the channel sends
the 'bootmsg' ... in a 'MSG' message."

Now my question is what should the 'listener' peer in
the boot state do when it receives a "MSG" message
without containing "bootmsg".

Should it neglect the message, or should it respond
with an error (with some error number and a message!)?

Love Singhal

__________________________________________________
Do You Yahoo!?
Yahoo! Greetings - send holiday greetings for Easter, Passover
http://greetings.yahoo.com/
_______________________________________________
BEEPwg mailing list
[email-masked]
http://lists.beepcore.org/mailman/listinfo/beepwg

---

From: Marshall Rose <[email-masked]>
Date: Mon, 1 Apr 2002 09:41:24 -0800

> without containing "bootmsg".

send an ERR because SOAP hasn't started yet.

/mtr