Subject: [BEEPwg] BEEP and .Net

From: "Michael J. Riggio" <[email-masked]>
Date: Tue, 29 Jul 2003 21:42:19 -0400

Hi,
      I was wondering if there is a .Net implementation of BEEP?  I haven't worked with BEEP in a long time, and when I did it wasn't very deep, but I do remember that there were/are several implementations in languages such as java and c.  I was wondering if there is a reason why no one has taken the .Net (c#) approach yet?  Am I missing in something in the framework that provides functionality similar to BEEP?

      Any links or suggestions would be greatly appreciated.

Thanks,
-Mike Riggio

---

From: Olof Härwell <[email-masked]>
Date: Wed, 30 Jul 2003 08:39:38 +0200

Hi

Intel published a P2P framework a year ago in c# that used a BEEP-based 
remoting provider for the .NET framework. It used to be on the 
www.gotdotnet.com site but now I can't find it there.

Cheers
Olof Härwell

Michael J. Riggio wrote:
> Hi,
>       I was wondering if there is a .Net implementation of BEEP?  I 
> haven't worked with BEEP in a long time, and when I did it wasn't very 
> deep, but I do remember that there were/are several implementations in 
> languages such as java and c.  I was wondering if there is a reason why 
> no one has taken the .Net (c#) approach yet?  Am I missing in something 
> in the framework that provides functionality similar to BEEP?
>  

-- 
/*
   Olof Härwell
   Systems Architect
   Labs2 AB

   Direct:   +46 46 540 01 10
   Mobile:   +46 70 941 20 10
   Phone:    +46 46 13 74 25
   Fax:      +46 46 13 74 26
   Address:  Winstrupsgatan 1, SE-222 22 Lund, Sweden
   Internet: http://www.labs2.com
*/

_______________________________________________
BEEPwg mailing list
[email-masked]
http://lists.beepcore.org/mailman/listinfo/beepwg

---

From: "Michael Iles" <[email-masked]>
Date: Wed, 30 Jul 2003 12:12:21 -0400

Clipcode apparently had plans to release a C# BEEP implementation, in
fact someone from Clipcode announced the start of the beta on this list
in Nov 2001. Does anyone know what happened to this? The project is
described on their site but no code seems to be available.

A BEEP implementation for .NET would be very useful: the network
transports provided by .NET (remoting and web services) are both
connectionless.

Mike.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Olof Härwell
Sent: July 30, 2003 2:40 AM
To: Michael J. Riggio
Cc: [email-masked]
Subject: Re: [BEEPwg] BEEP and .Net

Hi

Cheers
Olof Härwell

-- 
/*
   Olof Härwell
   Systems Architect
   Labs2 AB

   Direct:   +46 46 540 01 10
   Mobile:   +46 70 941 20 10
   Phone:    +46 46 13 74 25
   Fax:      +46 46 13 74 26