Subject: [BEEPwg] (no subject)

From: "Ingo Funken" <[email-masked]>
Date: Thu, 5 Feb 2004 12:32:05 +0100 (MET)

Hi beepwg,

I have the following problem:
I implemented an application which starts several threads at the same time.
Everyone of these threads starts a channel. Messages are transmitted over
these parallel channels independently. I use ethereal for intercepting and
looking at the beep messages they were exchanged. 
But I see in some beep messages that the payload of these messages contains
an another beep message entirely. A section of ethereal looks like:

Blocks Extensible Exchange Protocol

      Header:
           Command: MSG
           Channel: 9
           Msgno: 1
           More: complete
           Seqno: 0
           Size: 555
            .
            .
            .
      Payload: (payload of MSG 9)END\r\nMSG  0 10 . 1980 214 ..........

Another example is like:

Blocks Extensible Exchange Protocol (no header section like above)

       Payload: MSG 11 1 . 0 600 \r\nContent-Type:
       Payload: application/xml\r\n\r\n (here comes the real payload)......

But my application works without any problems. There is no session
termination because of poorly-formed messages. Is this behavior  of beep normal? I
didn't see any section in rfc 3080 that refers to such problems.

Ingo 

-- 
GMX ProMail (250 MB Mailbox, 50 FreeSMS, Virenschutz, 2,99 EUR/Monat...)
jetzt 3 Monate GRATIS + 3x DER SPIEGEL +++ http://www.gmx.net/derspiegel +++

_______________________________________________
BEEPwg mailing list
[email-masked]
http://lists.beepcore.org/mailman/listinfo/beepwg

---

From: Marshall Rose <[email-masked]>
Date: Thu, 5 Feb 2004 11:07:40 -0800

> I have the following problem:

what beep implementation are you using?
    
1. if frames are being sent out with an incorrect length field, then a
   properly behaving receiver will see that the frame doesn't end with
   "END" and generate an error.
    
2. or, whatever version of ethereal you are using is misreporting the
   traffic it is analyzing.
    
/mtr

---

From: "Ingo Funken" <[email-masked]>
Date: Fri, 6 Feb 2004 12:24:49 +0100 (MET)

> what beep implementation are you using?

I am using the java implementation 0.9.07 of beepcore.

>    "END" and generate an error.

Frames end with "END" and messages are transmitted without errors. 

> 2. or, whatever version of ethereal you are using is misreporting the

I am using ethereal 0.9.4 with GTK+ 1.2.10, with GLib 1.2.10,  with licap
0.6., with libz 1.1.4
   
Ingo

---

From: Marshall Rose <[email-masked]>
Date: Fri, 6 Feb 2004 07:21:57 -0800

> ... 

it sounds like ethereal isn't reporting correctly. you should probably ask this
question on the beepcore-java mailing list and see what folks say there.

/mtr