Subject: Re: [BEHAVE] BEHAVE WG errata review

From: Wesley Eddy <[email-masked]>
Date: Fri, 01 Jun 2012 22:13:32 -0400

On 1/19/2012 3:10 PM, Dave Thaler wrote:
> | RFC6145 |      3060 | 2011-12-23     | Gandhar Gokhale | behave   | Technical | 
> 
> I believe the filer is correct.  The RFC does not contain the right statement with
> respect to handling of IPv6 extension headers.   It says they're skipped when 
> filling in the payload but it doesn't say they're skipped when filling in the
> length field.
> 
> Propose to move to "Approved" per guideline "Only errors that could cause 
> implementation or deployment problems or significant confusion should be
> Approved."
> 
> However, since the filer proposes what the "corrected" behavior is, I believe
> we need WG consensus to approve that statement.

I didn't see anyone in the WG pushback on this, and so
moved it to "Approved", as recommended, based on the
logic that it seems reasonable and that silence must
mean consensus from the WG. ;)

-- 
Wes Eddy
MTI Systems

---

From: SM <[email-masked]>
Date: Tue, 05 Jun 2012 15:17:38 -0700

> > | RFC6145 |      3060 | 2011-12-23     | Gandhar Gokhale | 

[snip]

>mean consensus from the WG. ;)

This erratum is a significant change and it introduces a 
requirement.  I suggest "Rejected".

Regards,
-sm

---

From: Dave Thaler <[email-masked]>
Date: Tue, 5 Jun 2012 22:23:45 +0000

Rejected implies the original text matches WG intent.
It does not, two places in the doc contradict each other.   The question is between 
Hold for Document Update
	vs
Approved.

The argument for Approved is that it's an interoperability issue, so you need
to know which place is right and which place is wrong in the doc.

The problem is that the suggested text includes both a correction (which in my opinion should be approved),
and an additional rule, which might be Rejected.  That is, the first sentence suggested is a correction,
and the second sentence is an addition.

> Total Length: If the Next Header field of the Fragment Header is not an extension header (except ESP) 
> then Total Length MUST be set to Payload Length value from IPv6 header, minus length of extension
> headers up to Fragmentation Header, minus 8 for the Fragment Header, plus the size of the IPv4 header.
> If the Next Header field of the Fragment Header is an extension header (except ESP) then the packet 
> SHOULD be dropped and logged.

-Dave

> -----Original Message-----
> From: SM [mailto:[email-masked]]
> Sent: Tuesday, June 5, 2012 3:18 PM
> To: Wesley Eddy; Dave Thaler
> Cc: [email-masked]
> Subject: Re: [BEHAVE] BEHAVE WG errata review
> 
> >I didn't see anyone in the WG pushback on this, and so moved it to
> >"Approved", as recommended, based on the logic that it seems reasonable
> >and that silence must mean consensus from the WG. ;)
> 
> This erratum is a significant change and it introduces a requirement.  I suggest
> "Rejected".
> 
> Regards,
> -sm
>

---

From: SM <[email-masked]>
Date: Tue, 05 Jun 2012 15:44:08 -0700

>to know which place is right and which place is wrong in the doc.

Yes.

>The problem is that the suggested text includes both a correction 
>(which in my opinion should be approved),

The problem is the MUST and the SHOULD.  Given that it changes the 
intended consensus, I would pick "Hold for Document Update".  Some 
people might ignore the erratum unless the issue is serious enough 
(guideline 1) for the requirement to be followed.

Regards,
-sm

---

From: Wesley Eddy <[email-masked]>
Date: Tue, 05 Jun 2012 19:02:23 -0400

> and the second sentence is an addition.

The two sentences cover the two cases of "isn't an extension header"
and "is an extension header".  If we only retained the first, then
there would still be some ambiguity about what to do in the case
that the second is covering.

In my opinion, the second sentence's "SHOULD" leaves sufficient wiggle
room to do something else, if an implementer has some reasonable
justification, though it may not be ideal.

-- 
Wes Eddy
MTI Systems

---

From: Dave Thaler <[email-masked]>
Date: Wed, 6 Jun 2012 01:36:44 +0000

I agree.   I'm fine with Approved.

-Dave

> From: Wesley Eddy [mailto:[email-masked]]
> Sent: Tuesday, June 5, 2012 4:02 PM
> To: Dave Thaler
> Cc: SM; [email-masked]
> > (which in my opinion should be approved), and an additional rule,
> > which might be Rejected.  That is, the first sentence suggested is a
> correction, and the second sentence is an addition.
> 
> and "is an extension header".  If we only retained the first, then there would
> still be some ambiguity about what to do in the case that the second is
> covering.
>