Subject: Re: [BEHAVE] AD review of LSN requirements draft

From: <[email-masked]>
Date: Fri, 1 Jun 2012 14:19:11 +0200

Hi Simon, all,

>-----Message d'origine-----
>De : [email-masked] [mailto:[email-masked]] 
>De la part de Simon Perreault
>Envoyé : jeudi 31 mai 2012 19:40
>À : Wesley Eddy
>Cc : [email-masked]; 
>[email-masked]
>Objet : Re: [BEHAVE] AD review of LSN requirements draft
>
>
>> (6) I think it would be good to have an advisory
>> reference to the issues in:
>> http://tools.ietf.org/html/draft-donley-nat444-impacts-03
>> and whether or not following the recommendations in this
>> document helps to avoid such issues.  The RFC 6269
>> reference already in the introduction is okay, but it
>> probably glosses over this topic too quickly.
>
>In addition to Dan's response, the draft-donley does not evaluate CGNs 
>that have a PCP server, which our draft requires. I think the 
>inclusion 
>of PCP would affect the results significantly.

Med: Agree. FWIW, an example of a detailed report for an application tested in draft-donley-* is available at: http://tools.ietf.org/html/draft-boucadair-pcp-bittorrent-00 (various combinations are tested including playing with the configuration of the BT clients to allow multiple connections from the same IP).

---

From: Wesley Eddy <[email-masked]>
Date: Fri, 01 Jun 2012 08:41:09 -0400

> Med: Agree. FWIW, an example of a detailed report for an application tested in draft-donley-* is available at: http://tools.ietf.org/html/draft-boucadair-pcp-bittorrent-00 (various combinations are…

I think it would be great to add a sentence in the justification
of the PCP requirement to specifically say that it's intended
to improve on prior CGN implementations that did not include PCP
and were found to have problems with certain applications (with
citations).

-- 
Wes Eddy
MTI Systems

---

From: Simon Perreault <[email-masked]>
Date: Fri, 01 Jun 2012 09:00:11 -0400

On 2012-06-01 08:41, Wesley Eddy wrote:
>>>> (6) I think it would be good to have an advisory reference to
>>>> the issues in:
>>>> http://tools.ietf.org/html/draft-donley-nat444-impacts-03 and
>>>> whether or not following the recommendations in this document
>>>> helps to avoid such issues.  The RFC 6269 reference already in
>>>> the introduction is okay, but it probably glosses over this
>>>> topic too quickly.
>>>
>>> In addition to Dan's response, the draft-donley does not evaluate
>>> CGNs that have a PCP server, which our draft requires. I think
>>> the inclusion of PCP would affect the results significantly.
>>
>> Med: Agree. FWIW, an example of a detailed report for an
>> application tested in draft-donley-* is available at:
>> http://tools.ietf.org/html/draft-boucadair-pcp-bittorrent-00
>> (various combinations are tested including playing with the
>> configuration of the BT clients to allow multiple connections from
>> the same IP).
>
> I think it would be great to add a sentence in the justification of
> the PCP requirement to specifically say that it's intended to improve
> on prior CGN implementations that did not include PCP and were found
> to have problems with certain applications (with citations).

Makes sense.

We had this:

    Justification:  Allowing subscribers to manipulate the NAT state
       table with PCP greatly increases the likelihood that applications
       will function properly.

I added this:

       A study of PCP-less CGN impacts can be found in
       [I-D.donley-nat444-impacts].  Another study considering the
       effects of PCP on a peer-to-peer file sharing protocol can be
       found in [I-D.boucadair-pcp-bittorrent].

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca