Subject: Re: [BEHAVE] comment on draft-li-behave-nat444-test-00, FTP active/passive

From: "Zhangzongjian (Thomas)" <[email-masked]>
Date: Wed, 11 Jul 2012 03:39:44 +0000

Dear Dan
In fact we tested the typical FTP active model as an illustration for the FTP scenarios. In such an example, the FTP server is in public networks and FTP client is in private network. Thanks for your comments. We will add the detailed description in the next version.

Thomas
Best regards

-----Original Message-----
From: Dan Wing [mailto:[email-masked]] 
Sent: Wednesday, July 11, 2012 8:24 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Will Liu (Shucheng); Zhangzongjian (Thomas)
Subject: comment on draft-li-behave-nat444-test-00, FTP active/passive

Hi.

It would be helpful in your FTP test results if you indicated if passive
(PASV) or active mode was tested.

-d

---

From: "Will Liu (Shucheng)" <[email-masked]>
Date: Wed, 11 Jul 2012 08:44:26 +0000

Hi,

One thing I would like to add here is, this draft mainly focuses on the diversity of application tested. What we listed in the draft basically covers almost all the current typical popular applications. By posting this draft, we are able to show the outline of support situation of CGN for getting vast majority of applications through NAT, to both network man as well as those who are also interested in network software development. There might still be some scenarios we have not covered. If anybody is interested in those we did not mention in our draft, we are appreciated to your comments.

Have a nice day!
Will

-----Original Message-----
From: Zhangzongjian (Thomas) 
Sent: Wednesday, July 11, 2012 11:40 AM
To: Dan Wing; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Will Liu (Shucheng)
Cc: [email-masked]
Subject: RE: comment on draft-li-behave-nat444-test-00, FTP active/passive

Dear Dan

Thomas
Best regards

-----Original Message-----
From: Dan Wing [mailto:[email-masked]] 
Sent: Wednesday, July 11, 2012 8:24 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Will Liu (Shucheng); Zhangzongjian (Thomas)
Subject: comment on draft-li-behave-nat444-test-00, FTP active/passive

Hi.

-d

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 11 Jul 2012 08:07:56 -0700

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Zhangzongjian (Thomas)
> Sent: Tuesday, July 10, 2012 8:40 PM
> To: Dan Wing; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; Will Liu
> (Shucheng)
> Cc: [email-masked]
> Subject: Re: [BEHAVE] comment on draft-li-behave-nat444-test-00, FTP
> active/passive
> 
> Dear Dan
> In fact we tested the typical FTP active model as an illustration for
> the FTP scenarios.

My statistics show that active FTP is not typical.  Several years ago I
obtained logs from ftp.cisco.com and 99% of our connections were
passive-mode FTP.  It was only one user, downloading several files, that was
using active-mode FTP, and had an IP address belonging to Boeing.  All web
browsers do passive-mode FTP by default or exclusively, including IE 7 and
up, Safari, Firefox, Opera, and Chrome.

Do you have statistics showing a high number of active mode FTP?  Perhaps
this is caused by IE 6, which I know is still used extensively in China, and
defaults to active-mode FTP.  It would be interesting to know how often
active mode FTP is used considering it would also require FTP ALG support in
existing WiFi access points (restaurants, hotels, and airports).

> In such an example, the FTP server is in public
> networks and FTP client is in private network. Thanks for your
> comments. We will add the detailed description in the next version.

Thanks, that would be helpful.  As you know, passive FTP does not need an
FTP ALG.

-d

> To: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; Will Liu (Shucheng);
> Zhangzongjian (Thomas)
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 11 Jul 2012 16:40:59 +0000

Hello,

Some comments on your draft which I believe is interesting.

Most of your tests are subscriber initiated connections which results in
Internet (I) ->subscriber (S) traffic over TCP/UDP. We all know this works
well with CGN. The interesting cases are I/S<->S for gratuitous
connections. In that sense, some comments below.

Is on-line gaming with consoles popular in China? PS3, XBOX, Nintendo?

People do not seed torrents in China? That is very popular in other parts
of the world. 

I would like to understand how the CGN was configured. Were mappings APP
enabled? EIM & EIF? Hairpinning enabled? This, of course is specially
interesting on the I/S<->S scenarios.

As far a VPN goes, the interesting ones from CGN perspective are IPsec
(not over UDP) and PPTP.

Thanks,

- RP

>In fact we tested the typical FTP active model as an illustration for the
>FTP scenarios. In such an example, the FTP server is in public networks
>and FTP client is in private network. Thanks for your comments. We will
>add the detailed description in the next version.
>
>Thomas
>Best regards
>
>

---

From: "Will Liu (Shucheng)" <[email-masked]>
Date: Thu, 12 Jul 2012 03:10:27 +0000

Thanks for sharing your statistics, which is very interesting and also helpful for us. You are correct. As far as we know, both IE6 and ftp command in DOS (in windows) are using the Active(PORT) mode as the default mode, which are still widely used in China. However, as IE8/Firefox/chrome and Win7 spread in China in recent years, more and more FTPs are working under the passive mode. For your question about the number of active mode FTP, we afraid that we do not have the statistics for the number of active/passive mode.
As I double checked our testing result, it was generated from the default DOS (in windows) ftp command, under the PASSIVE mode. Just as you mentioned, passive FTP does not need an FTP ALG. That's why I used the "typical" word. 

I hope my answer is helpful. 

Cheers,
Will

-----Original Message-----
From: Dan Wing [mailto:[email-masked]] 
Sent: Wednesday, July 11, 2012 11:08 PM
To: Zhangzongjian (Thomas); [email-masked]; [email-masked]; [email-masked]; [email-masked]; Will Liu (Shucheng)
Cc: [email-masked]
Subject: RE: [BEHAVE] comment on draft-li-behave-nat444-test-00, FTP active/passive

-d

---

From: "Zhangzongjian (Thomas)" <[email-masked]>
Date: Thu, 12 Jul 2012 03:55:12 +0000

Dear Penno

The answers are online below.

Best regards
thomas

-----Original Message-----
From: Reinaldo Penno (repenno) [mailto:[email-masked]] 
Sent: Thursday, July 12, 2012 12:41 AM
To: Will Liu (Shucheng); Zhangzongjian (Thomas); Dan Wing (dwing); [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Some comments on draft-li-behave-nat444-test-00

Hello,

Is on-line gaming with consoles popular in China? PS3, XBOX, Nintendo?
Thomas:
PS3, XBOX, Nintendo is seldom played in China. PS3, XBOX, Nintendo are not published in China and there are no game servers for these three game in China.

People do not seed torrents in China? That is very popular in other parts
of the world. 
Thomas:
Yes, People seed torrents, but rarely.   
We mainly tested download in Bittorrent and eMule.

I would like to understand how the CGN was configured. Were mappings APP
enabled? EIM & EIF? Hairpinning enabled? This, of course is specially
interesting on the I/S<->S scenarios.
Thomas:
Mappings are enabled by a service board in CGN device.  CGN packets will be sent to this board.  I am not sure whether this answer can satisfy your question.
The mapping is EIM without EIF.
Which application CGN configuration are you interesting in? what configuration do you want to know?  I will try to provide more information for you, though I not sure I can get configure from China Telecom.

As far a VPN goes, the interesting ones from CGN perspective are IPsec
(not over UDP) and PPTP.
Thomas:
In VPN fields, only iAccess is tested. IPsec and PPTP are not tested.

Thanks,

- RP