Subject: Re: [bess] Shepherd review on draft-ietf-bess-l2l3-vpn-mcast-mib-01

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 26 Jan 2016 01:20:24 +0000

Mach,

Thank you very much for the review. Please see zzh> below.

> -----Original Message-----
> From: Mach Chen [mailto:[email-masked]]
> Sent: Tuesday, December 22, 2015 4:04 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Shepherd review on draft-ietf-bess-l2l3-vpn-mcast-mib-01
> 
> Hi Authors,
> 
> I am requested (by the WG chairs) to shepherd this draft, here are my
> shepherd review comments on this document.
> 
> 
> 1. Idnits tool shows:
>   ** There are 4 instances of too long lines in the document, the longest
> one
>      being 3 characters in excess of 72.

Zzh> will try to address that. I intended to cut & paste text from some existing RFCs.

> 
> 2. Expand the unwell-known abbreviations when first use.

Zzh> Will do.

> 
> 2. Abstract says:
> "This memo defines an experimental portion of the Management
>    Information Base for use with network management protocols in the
>    Internet community."
> 
> But the intended status of this document is "Standards Track", what's the
> real intention?

Zzh> Will change to "standard".

> 
> 3. From the title, the document is to define mibs for L2 and L3 Multicast
> VPNs, it's better to define and scope what are L2 multicast VPN and L3
> multicast VPN.
> And the draft uses "Multicast in VPN" to identify MVPN, it
> seems not accurate. It's better to use the consistent definition and
> description for MVPN through the whole document IMHO.

Zzh> The Introduction section makes it clear that the scope is for VPLS and (IP) VPN Multicast. As I just alluded to in the previous sentence, I'll use "IP VPN" for L3 case. Is that ok?

> 
> 4. Section 4,
> The LAST-UPDATED, ORGANIZATION, CONTACT-INFO and the Revision history
> should be updated to reflect the latest status.

Zzh> I had expected to update this at the final step of publication. Will follow appropriate advice.

> 
> 5. Page 5,
> 
> This document defines the following flags:
> 
>        + Leaf Information Required (L)"
> 
> s/+ Leaf Information Required (L)"/ Leaf Information Required (L)"

Zzh> The text is quoting RFC 6514, " 5.  PMSI Tunnel Attribute". Having said that, I'll just remove the quote and simply say it's the flag field in the PMSI Tunnel Attribute, because other flags could be defined in other specifications.

> 
> 6.
> Section 5.  Security Considerations
>    "N/A"
> 
> The same issue as the MVPN mib, please enhance it.

Zzh> Will research.

> 
> 7. Please make sure that the MIB Modules are compiled cleanly.

Zzh> Please let me know if you've noticed any issue.

Thanks!
Jeffrey

> Best regards,
> Mach

---

From: Mach Chen <[email-masked]>
Date: Tue, 26 Jan 2016 06:54:38 +0000

Hi Jeffery,

Some responses inline...

> 
> >
> > 3. From the title, the document is to define mibs for L2 and L3
> > Multicast VPNs, it's better to define and scope what are L2 multicast
> > VPN and L3 multicast VPN.
> > And the draft uses "Multicast in VPN" to identify MVPN, it seems not
> > accurate. It's better to use the consistent definition and description
> > for MVPN through the whole document IMHO.
> 
> Zzh> The Introduction section makes it clear that the scope is for VPLS and (IP)
> VPN Multicast. As I just alluded to in the previous sentence, I'll use "IP VPN" for
> L3 case. Is that ok?

According to RFC6513, Multicast in BGP/MPLS in IP VPN is called MVPN, you may take a look at RFC6513 and try to align the terms with it.

> Zzh> The text is quoting RFC 6514, " 5.  PMSI Tunnel Attribute". Having said
> that, I'll just remove the quote and simply say it's the flag field in the PMSI
> Tunnel Attribute, because other flags could be defined in other specifications.

OK.

> > The same issue as the MVPN mib, please enhance it.

Sure, please.

> Zzh> Please let me know if you've noticed any issue.

No.

Once the document updated, we can start the MIB doctor review.

Best regards,
Mach