Subject: [bess] draft-rosen-mpls-rfc3107bis

From: <[email-masked]>
Date: Wed, 13 Apr 2016 11:32:40 +0000

Eric,

Could the draft clarifies the BGP Route Reflector behavior when reflecting a route received from a buggy 3107 implementation with S=0?
a) One may argue that the RR should not modify the NLRI and hence reflect the route with S=0
b) One may argue that the RR should reflect the route after setting S=1 in order to be a speaker compliant with 3107bis & 3107.
c) One may argue that this is an error and treat the IP Prefix as withdraw

IMO I think I would prefer b) in order to not propagate the bug.

Thanks,
Regards,
Bruno

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 13 Apr 2016 09:01:28 -0400

> IMO I think I would prefer b) in order to not propagate the bug.

Normally I would argue for c.  What I'm really curious about is
implementations that may not be setting end-of-stack currently for their
3107.

Time to read what our code does upon receipt.

-- Jeff