Subject: [bess] FW: New Version Notification for draft-surajk-evpn-access-security-00.txt

From: Suraj Kumar <[email-masked]>
Date: Mon, 16 Jan 2017 05:24:41 +0000

Hi,
I have submitted a draft 
   "The draft defines a new BGP EVPN route message for syncing DHCP
     packet contents as well as snoop entry among PEs in an Ethernet
     Segment (ES).  The snoop entry is required to implement Dynamic ARP
     inspection (DAI), IP Source Guard (IPSG/IPSGv6) and IPv6 Neighbor.
     Discovery Inspection (NDI) access security features."

Please review this and provide your comments.

-Thanks,
Suraj

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, January 12, 2017 5:37 PM
To: Deepak Kakrania <[email-masked]>; Suraj Kumar <[email-masked]>; Vijay Kumar Dunna <[email-masked]>; Vijay Kumar Dunna <[email-masked]>
Subject: New Version Notification for draft-surajk-evpn-access-security-00.txt

A new version of I-D, draft-surajk-evpn-access-security-00.txt
has been successfully submitted by Suraj Kumar and posted to the IETF repository.

Name:		draft-surajk-evpn-access-security
Revision:	00
Title:		EVPN ACCESS SECURITY
Document date:	2017-01-12
Group:		Individual Submission
Pages:		12
URL:            https://www.ietf.org/internet-drafts/draft-surajk-evpn-access-security-00.txt
Status:         https://datatracker.ietf.org/doc/draft-surajk-evpn-access-security/
Htmlized:       https://tools.ietf.org/html/draft-surajk-evpn-access-security-00

Abstract:
   The draft defines a new BGP EVPN route message for syncing DHCP
   packet contents as well as snoop entry among PEs in an Ethernet
   Segment (ES).  The snoop entry is required to implement Dynamic ARP
   inspection (DAI), IP Source Guard (IPSG/IPSGv6) and IPv6 Neighbor
   Discovery Inspection (NDI) access security features.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Alexander Marhold" <[email-masked]>
Date: Mon, 16 Jan 2017 07:45:51 +0100

Hi !

By checking your draft I think you missed the original type 5 route already
defined not in the base EVOPN RFC but in other drafts for L3 information
when writing, therefore should it not be type 6 ?

   This draft defines a new route (DHCP Snoop Advertisement route) The
   PE uses this route message for exchanging DHCP packet contents as
   well as complete bindings with other PE.
######################################
   + 5 - DHCP Snoop Advertisement route
######################################
   An DHCP Snoop Advertisement route type specific EVPN NLRI consists of
   the following:

regards

Alexander Marhold

-----Ursprüngliche Nachricht-----
Von: BESS [mailto:[email-masked]] Im Auftrag von Suraj Kumar
Gesendet: Montag, 16. Januar 2017 06:25
An: [email-masked]
Betreff: [bess] FW: New Version Notification for
draft-surajk-evpn-access-security-00.txt

Hi,
I have submitted a draft 

-Thanks,
Suraj

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, January 12, 2017 5:37 PM
To: Deepak Kakrania <[email-masked]>; Suraj Kumar
<[email-masked]>; Vijay Kumar Dunna <[email-masked]>; Vijay Kumar
Dunna <[email-masked]>
Subject: New Version Notification for
draft-surajk-evpn-access-security-00.txt

A new version of I-D, draft-surajk-evpn-access-security-00.txt
has been successfully submitted by Suraj Kumar and posted to the IETF
repository.

Name:		draft-surajk-evpn-access-security
Revision:	00
Title:		EVPN ACCESS SECURITY
Document date:	2017-01-12
Group:		Individual Submission
Pages:		12
URL:
https://www.ietf.org/internet-drafts/draft-surajk-evpn-access-security-00.tx
t
Status:
https://datatracker.ietf.org/doc/draft-surajk-evpn-access-security/
Htmlized:
https://tools.ietf.org/html/draft-surajk-evpn-access-security-00

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
BESS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bess

---

From: Suraj Kumar <[email-masked]>
Date: Mon, 16 Jan 2017 06:48:23 +0000

Hi Alexander,
Thanks for your review. 
I have noted this .

-Thanks,
Suraj

-----Original Message-----
From: Alexander Marhold [mailto:[email-masked]] 
Sent: Monday, January 16, 2017 12:16 PM
To: Suraj Kumar <[email-masked]>; [email-masked]
Subject: AW: [bess] FW: New Version Notification for draft-surajk-evpn-access-security-00.txt

Hi !

By checking your draft I think you missed the original type 5 route already defined not in the base EVOPN RFC but in other drafts for L3 information when writing, therefore should it not be type 6 ?

regards

Alexander Marhold

-----Ursprüngliche Nachricht-----
Von: BESS [mailto:[email-masked]] Im Auftrag von Suraj Kumar
Gesendet: Montag, 16. Januar 2017 06:25
An: [email-masked]
Betreff: [bess] FW: New Version Notification for draft-surajk-evpn-access-security-00.txt

Hi,
I have submitted a draft 

-Thanks,
Suraj

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, January 12, 2017 5:37 PM
To: Deepak Kakrania <[email-masked]>; Suraj Kumar <[email-masked]>; Vijay Kumar Dunna <[email-masked]>; Vijay Kumar Dunna <[email-masked]>
Subject: New Version Notification for

Abstract:

The IETF Secretariat

---

From: "Rabadan, Jorge (Nokia - US)" <[email-masked]>
Date: Mon, 16 Jan 2017 19:16:24 +0000

Hi,

Not only route type 5. Types 6 to 11 are also requested in other BESS documents.
Check out draft-ietf-bess-evpn-bum-procedure-updates for instance.
Please do not use those.

Thx
Jorge

On 1/16/17, 3:48 PM, "BESS on behalf of Suraj Kumar" <[email-masked] on behalf of [email-masked]> wrote:

Hi Alexander,
Thanks for your review. 
I have noted this .

-Thanks,
Suraj

-----Original Message-----
From: Alexander Marhold [mailto:[email-masked]] 
Sent: Monday, January 16, 2017 12:16 PM
To: Suraj Kumar <[email-masked]>; [email-masked]
Subject: AW: [bess] FW: New Version Notification for draft-surajk-evpn-access-security-00.txt

Hi !

regards

Alexander Marhold

-----Ursprüngliche Nachricht-----
Von: BESS [mailto:[email-masked]] Im Auftrag von Suraj Kumar
Gesendet: Montag, 16. Januar 2017 06:25
An: [email-masked]
Betreff: [bess] FW: New Version Notification for draft-surajk-evpn-access-security-00.txt

Hi,
I have submitted a draft 

-Thanks,
Suraj

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, January 12, 2017 5:37 PM
To: Deepak Kakrania <[email-masked]>; Suraj Kumar <[email-masked]>; Vijay Kumar Dunna <[email-masked]>; Vijay Kumar Dunna <[email-masked]>
Subject: New Version Notification for

Abstract:

The IETF Secretariat

---

From: Thomas Morin <[email-masked]>
Date: Tue, 17 Jan 2017 10:02:18 +0100

Hi Jorge,

It sounds a lot like we should register an early allocation for route 
type 5 ?
As the editor of draft-ietf-bess-evpn-prefix-advertisement 
<https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-prefix-advertisement/>, 
would you be ok to bootstrap the early allocation process [1] ?
This draft looks to me like it would match the requirements for early 
allocations ([2]).

We can consider doing the same for 
draft-ietf-bess-evpn-bum-procedure-updates 
<https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-bum-procedure-updates/>, 
as soon as we're certain enough that the specs are stable.
Opinions are welcome on this.

Best,

-Thomas

[1] https://tools.ietf.org/html/rfc7120#section-3.1
[2] https://tools.ietf.org/html/rfc7120#section-2