Subject: Re: [bess] Call for adoption: draft-sajassi-bess-evpn-igmp-mld-proxy-01

From: John E Drake <[email-masked]>
Date: Wed, 1 Feb 2017 23:27:07 +0000

Thomas,

Not surprisingly I support the adoption of this draft.  Here is our IPR disclosure for it:  https://datatracker.ietf.org/ipr/2942/

Yours Irrespectively,

John

> -----Original Message-----
> From: Thomas Morin [mailto:[email-masked]]
> Sent: Tuesday, January 31, 2017 9:58 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [bess] Call for adoption: draft-sajassi-bess-evpn-igmp-mld-proxy-01
> 
> Hello working group,
> 
> This email starts a two-week poll on adopting
> draft-sajassi-bess-evpn-igmp-mld-proxy-01 [1] as a working group item.
> 
> Please send comments to the list and state if you support adoption or not (in the
> later case, please also state the reasons).
> 
> This poll runs until **February 14th**.
> 
> *Coincidentally*, we are also polling for knowledge of any IPR that applies to
> this draft, to ensure that IPR has been disclosed in compliance with IETF IPR
> rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
> 
> ==> *If* you are listed as a document author or contributor please respond to
> this email and indicate whether or not you are aware of any relevant IPR.
> 
> The draft will not be adopted until a response has been received from each
> author and contributor.
> 
> If you are not listed as an author or contributor, then please explicitly respond
> only if you are aware of any IPR that has not yet been disclosed in conformance
> with IETF rules.
> 
> Thank you,
> 
> Martin & Thomas
> bess chairs
> 
> [1]
> https://datatracker.ietf.org/doc/draft-sajassi-bess-evpn-igmp-mld-proxy-01

---

From: Wen Lin <[email-masked]>
Date: Tue, 7 Feb 2017 19:03:36 +0000

Support as a co-author.

Thanks,
Wen

On 1/31/17, 9:58 AM, "Thomas Morin" <[email-masked]> wrote:

    Hello working group,

    Please send comments to the list and state if you support adoption or 
    not (in the later case, please also state the reasons).

    *Coincidentally*, we are also polling for knowledge of any IPR that 
    applies to this draft, to ensure that IPR has been disclosed in 
    compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for 
    more details).
    
    ==> *If* you are listed as a document author or contributor please 
    respond to this email and indicate whether or not you are aware of any 
    relevant IPR.
    
    The draft will not be adopted until a response has been received from 
    each author and contributor.
    
    If you are not listed as an author or contributor, then please 
    explicitly respond only if you are aware of any IPR that has not yet 
    been disclosed in conformance with IETF rules.
    
    Thank you,
    
    Martin & Thomas
    bess chairs
    
    [1]

---

From: Derek Yeung <[email-masked]>
Date: Tue, 7 Feb 2017 20:27:53 +0000

Support as a co-author. I am not aware of any IPR related to this draft.

Thanks,
Derek

        Hello working group,

        

        

        Thank you,
        
        Martin & Thomas
        bess chairs
        
        [1] 

    _______________________________________________
    BESS mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/bess

---

From: Aldrin Isaac <[email-masked]>
Date: Wed, 8 Feb 2017 03:11:52 +0000 (UTC)

I would also like to indicate my support.  
Cheers,Aldrin

On Tue, Jan 31, 2017 at 6:58 AM -0800, "Thomas Morin" <[email-masked]> wrote:

Hello working group,

Thank you,

Martin & Thomas
bess chairs

[1]

---

From: "Samir Thoria (sthoria)" <[email-masked]>
Date: Wed, 8 Feb 2017 18:59:46 +0000

Support as a co-author.  There is an IPR related to this draft and IETF should get Cisco “standard notification" on it shortly.

Thanks,
Samir.

On 1/31/17, 6:58 AM, "Thomas Morin" <[email-masked]> wrote:

    Hello working group,

    

    

    Thank you,
    
    Martin & Thomas
    bess chairs
    
    [1]

---

From: "Rabadan, Jorge (Nokia - US)" <[email-masked]>
Date: Thu, 9 Feb 2017 08:30:24 +0000

I support this document for WG adoption.

Having said that, I made a few observations to the authors, and I believe they agreed to make some changes in the next revision. The main things that I believe should be reflected in the next rev after WG adoption are:

1- Simplified BGP route encoding
I discussed with the authors that the Join and Leave synch behavior may have been achieved with a single route type, as opposed to the proposed two types (type 7 and 8). 
The authors believe it is better to keep both, which is ok, but: 
a) the route type 8 – IGMP leave synch route – should be simplified: the max response time and sequence number fields in the route introduce an unnecesary complexity and should be removed. 
b) Route type 8 should be optional since: i) It is actually not needed for IGMPv1 and 2) It is not needed either if a fast leave mechanism is used (see point 2).

2- Fast Leave addition to the draft
There are quite a few igmp-snooping implementations in the market that support a “Fast Leave” mechanism. EVPN should incorporate/document this too.
Implementations allow the use of "Fast Leave" when the IGMP host is directly connected to the PE/NVE and, only in that case is recommended. Fast Leave is a local administrative option on the PE, that, if enabled, allows the removal of a (x,G) state immediately after the reception of an IGMP Leave message for the (x,G). In the case of an ES AC, Fast Leave is only allowed in the case that a single IGMP host is multi-homed to the PEs in the ES. When Fast Leave is configured in an ES AC, the reception of an IGMP Leave message will remove the (x,G) state for the ES AC immediately and will trigger the withdrawal of the IGMP State Synch route. Assuming the remote PE is configured for "Fast Leave" too, the reception of the (x,G) route withdrawal for the ES will remove the (x,G) state completely.

3- Multicast Flags EC
The Tunnel Type field looks not big enough for the different tunnel types that EVPN can use. I would recommend taking more space from the reserved bits and include all the allocated tunnel types in here: http://www.iana.org/assignments/bgp-parameters/bgp-parameters.xhtml#pmsi-tunnel-types

Thank you.
Jorge

On 1/31/17, 3:58 PM, "BESS on behalf of Thomas Morin" <[email-masked] on behalf of [email-masked]> wrote:

    Hello working group,

    

    

    Thank you,
    
    Martin & Thomas
    bess chairs
    
    [1]