Subject: Re: [bess] AD Review of draft-ietf-bess-evpn-vpws-07

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Tue, 21 Feb 2017 19:22:11 +0000

Folks,

Why don’t we simply mention that the Eth–Tag is a 32 bit value and MAY be set to a 24 bits instance
When 24 bits value is used is MAY be right aligned.

Regards,
Patrice Brissette

On 2017-02-21, 2:18 PM, "BESS on behalf of Sami Boutros" <[email-masked] on behalf of [email-masked]> wrote:

    Hi John,
    
    I can add that the value is from 0 to 0x00ffffff, will that work?

    Thanks,
    
    Sami
    On 2/21/17, 10:56 AM, "John E Drake" <[email-masked]> wrote:
    
    >Sami,
    >
    >Snipped, comment inline
    >
    >Yours Irrespectively,
    >
    >John
    >
    >> >
    >> >> Ethernet Tag ID 32-bit field MUST be set to the 24-bit VPWS service instance
    >> identifier value."
    >> >
    >> >
    >> >
    >> >Ok, but you still didn’t mention how the 24-bit value is to be aligned in the 32-
    >> bit field.  I’m guessing there will be some 0-padding, but will that the at the
    >> beginning or the end?
    >> >
    >> 
    >> I made the VPWS service instance identifier a 32-bit value in the new draft.
    >> 
    >
    >[JD]   I don't think you can do this as there are multiple implementations that use 24 bits  
    >
    _______________________________________________
    BESS mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/bess

---

From: "Shah, Himanshu" <[email-masked]>
Date: Tue, 21 Feb 2017 19:51:42 +0000

‘MAY’ does not work. 
It has to be ‘MUST’, IMO. 

Thanks,
Himanshu

On 2/21/17, 2:22 PM, "BESS on behalf of Patrice Brissette (pbrisset)" <[email-masked] on behalf of [email-masked]> wrote:

    Folks,

    Regards,
    Patrice Brissette

        Hi John,

        Thanks,
        
        Sami

---

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Wed, 22 Feb 2017 02:39:12 +0000

Himanshu,

I don’t think we should make the Eth-tag a MUST be 24 bit. It should be MAY  but if you decide to use 24 bits, it MUST be right aligned.

Regards,
Patrice Brissette

On 2017-02-21, 2:51 PM, "Shah, Himanshu" <[email-masked]> wrote:

    ‘MAY’ does not work. 
    
    Thanks,
    Himanshu

        Folks,

        Regards,
        Patrice Brissette

            Hi John,

            Thanks,
            
            Sami

---

From: "Rabadan, Jorge (Nokia - US)" <[email-masked]>
Date: Wed, 22 Feb 2017 10:48:23 +0000

Agree with Patrice.

The initial value was coming from the RFC7432 spec:

“An Ethernet Tag ID is a 32-bit field containing either a 12-bit or
   24-bit identifier that identifies a particular broadcast domain
   (e.g., a VLAN) in an EVPN instance.”

And now there are a few implementations out there that may check that the eth-tag is 24 bits and not larger. 
I prefer low order 24-bits rather than right aligned…

Thanks.
Jorge

On 2/22/17, 3:39 AM, "BESS on behalf of Patrice Brissette (pbrisset)" <[email-masked] on behalf of [email-masked]> wrote:

    Himanshu,

    Regards,
    Patrice Brissette

        ‘MAY’ does not work. 
        
        Thanks,
        Himanshu

            Folks,

            Regards,
            Patrice Brissette

                Hi John,

                Thanks,
                
                Sami

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 22 Feb 2017 12:50:22 +0000

Yes, I agree. I should have been more clearer, I meant must for right alignment since,
Not mandating that would cause interop issues.

Himanshu using iPad (so excuse the auto-corrects...)
________________________________
From: Patrice Brissette (pbrisset) <[email-masked]>
Sent: Tuesday, February 21, 2017 9:39:12 PM
To: Shah, Himanshu; Sami Boutros; John E Drake; Alvaro Retana (aretana); [email-masked]
Cc: Jeffrey (Zhaohui) Zhang; [email-masked]; [email-masked]
Subject: Re: [bess] AD Review of draft-ietf-bess-evpn-vpws-07

Himanshu,

Regards,
Patrice Brissette

    ‘MAY’ does not work.

    Thanks,
    Himanshu

        Folks,

        Regards,
        Patrice Brissette

            Hi John,

            Thanks,

            Sami