Subject: Re: [bess] BGP common parameter Yang module

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 10 Feb 2017 14:51:38 +0000

Hi Patrice - we are working fervently on a common IETF routing types model. We have both route-target and router-distinguisher types defined there. The work is being done in the Routing WG. Our intension is to accelerate standardization so it doesn't hold up standardization of the importing modules. Please comment as to whether you think this meets BESS requirements.

https://www.ietf.org/id/draft-ietf-rtgwg-routing-types-00.txt

Thanks,
Acee
P.S. We plan an update next week but the RD and RT definitions have not changed.

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of "Patrice Brissette (pbrisset)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 10, 2017 at 9:26 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Dhanendra Jain (dhjain)" <[email-masked]<mailto:[email-masked]>>, Himanshu Shah <[email-masked]<mailto:[email-masked]>>
Subject: [bess] BGP common parameter Yang module

Folks,

As part of EVPN, L2VPn and L3VPN Yang model, there is a "module" common to all 3 Yang models.

      |     +--rw bgp-parameters
      |     |  +--rw common
      |     |     +--rw rd-rt* [route-distinguisher]
      |     |        +--rw route-distinguisher    string
      |     |        +--rw vpn-target* [rt-value]
      |     |           +--rw rt-value    string
      |     |           +--rw rt-type     bgp-rt-type

It will be interesting to create a common BGP parameter Yang module as shown above. I think it just makes sense.
However, there is a minor challenge; that module require a home (a draft).
I'm looking for feedback about the best place/draft for such a module.

Thanks for your help.
Regards,
Patrice Brissette

---

From: Giles Heron <[email-masked]>
Date: Fri, 10 Feb 2017 16:18:42 +0000

Hi Acee,

In general seems that for any BGP VPN (L2 or L3) you have an RD plus a list of RTs (which can be import, export or both) - so I’d prefer that to be defined in a shared grouping (more or less as per the structure Patrice gave below) than to force each model to redefine it.

Giles

> On 10 Feb 2017, at 14:51, Acee Lindem (acee) <[email-masked]> wrote:
> 
> Hi Patrice – we are working fervently on a common IETF routing types model. We have both route-target and router-distinguisher types defined there. The work is being done in the Routing WG. Our intension is to accelerate standardization so it doesn’t hold up standardization of the importing modules. Please comment as to whether you think this meets BESS requirements. 
> 
> https://www.ietf.org/id/draft-ietf-rtgwg-routing-types-00.txt <https://www.ietf.org/id/draft-ietf-rtgwg-routing-types-00.txt>
> 
> Thanks,
> Acee 
> From: BESS <[email-masked] <mailto:[email-masked]>> on behalf of "Patrice Brissette (pbrisset)" <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Cc: "Dhanendra Jain (dhjain)" <[email-masked] <mailto:[email-masked]>>, Himanshu Shah <[email-masked] <mailto:[email-masked]>>
> As part of EVPN, L2VPn and L3VPN Yang model, there is a “module” common to all 3 Yang models.
>  
>       |     +--rw bgp-parameters
>       |     |  +--rw common
> I’m looking for feedback about the best place/draft for such a module.
>  
> Thanks for your help.
> Regards,
> Patrice Brissette
> _______________________________________________
> BESS mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/bess <https://www.ietf.org/mailman/listinfo/bess>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 10 Feb 2017 16:42:40 +0000

Hi Giles,
I will add the route-target-type type (enum of import, export, both) but for a general grouping, it appears there are some discrepancies between the 3 models. Assuming the types: route-discriminator, route-target, and route-target-type, can you provide a consensus grouping that all the models would use?
Thanks,
Acee

From: Giles Heron <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 10, 2017 at 11:18 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: "Patrice Brissette (pbrisset)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Himanshu Shah <[email-masked]<mailto:[email-masked]>>, "Dhanendra Jain (dhjain)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] BGP common parameter Yang module

Hi Acee,

In general seems that for any BGP VPN (L2 or L3) you have an RD plus a list of RTs (which can be import, export or both) - so I'd prefer that to be defined in a shared grouping (more or less as per the structure Patrice gave below) than to force each model to redefine it.

Giles

On 10 Feb 2017, at 14:51, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Acee

Folks,

      |     +--rw bgp-parameters
      |     |  +--rw common

Thanks for your help.
Regards,
Patrice Brissette
_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 10 Feb 2017 11:43:22 -0800

I’d prefer common grouping in draft-ietf-rtgwg-routing-types and references from any other model using it 

Cheers,

Jeff

From: BESS <[email-masked]> on behalf of "Acee Lindem (acee)" <[email-masked]>
Date: Friday, February 10, 2017 at 08:42
To: Giles Heron <[email-masked]>
Cc: "Patrice Brissette (pbrisset)" <[email-masked]>, "Shah, Himanshu" <[email-masked]>, "[email-masked]" <[email-masked]>, "Dhanendra Jain (dhjain)" <[email-masked]>
Subject: Re: [bess] BGP common parameter Yang module

Hi Giles,

Thanks,

Acee 

From: Giles Heron <[email-masked]>
Date: Friday, February 10, 2017 at 11:18 AM
To: Acee Lindem <[email-masked]>
Cc: "Patrice Brissette (pbrisset)" <[email-masked]>, "[email-masked]" <[email-masked]>, Himanshu Shah <[email-masked]>, "Dhanendra Jain (dhjain)" <[email-masked]>
Subject: Re: [bess] BGP common parameter Yang module

Hi Acee, 

Giles

Thanks,

Acee 

 

From: BESS <[email-masked]> on behalf of "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Friday, February 10, 2017 at 9:26 AM
To: "[email-masked]" <[email-masked]>
Cc: "Dhanendra Jain (dhjain)" <[email-masked]>, Himanshu Shah <[email-masked]>
Subject: [bess] BGP common parameter Yang module

Folks,

      |     +--rw bgp-parameters

      |     |  +--rw common

 

Thanks for your help.

Regards,

Patrice Brissette

[email-masked]

_______________________________________________ BESS mailing list [email-masked] https://www.ietf.org/mailman/listinfo/bess

---

From: "Patrice Brissette (pbrisset)" <[email-masked]>
Date: Sat, 11 Feb 2017 13:23:05 +0000

Hi Folks,

Same here. Can we do something about it?  And agree, all 3 VPN models should have the same commonality.

Regards,
Patrice Brissette

From: Jeff Tantsura <[email-masked]>
Date: Friday, February 10, 2017 at 2:43 PM
To: "Acee Lindem (acee)" <[email-masked]>, Giles Heron <[email-masked]>
Cc: Patrice Brissette <[email-masked]>, "Shah, Himanshu" <[email-masked]>, "[email-masked]" <[email-masked]>, "Dhanendra Jain (dhjain)" <[email-masked]>
Subject: Re: [bess] BGP common parameter Yang module

Cheers,
Jeff

Hi Giles,

Hi Acee,

Giles

Thanks,
Acee

Folks,

      |     +--rw bgp-parameters
      |     |  +--rw common

Thanks for your help.
Regards,
Patrice Brissette

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 11 Feb 2017 17:46:08 +0000

Given that there is no paucity of authors and contributors on these three BESS YANG models, I’d hope that one of them could provide a suggested common grouping. For now, I’ve added the route-target-type type on which there seems to be consensus.

Thanks,
Acee

From: "Patrice Brissette (pbrisset)" <[email-masked]<mailto:[email-masked]>>
Date: Saturday, February 11, 2017 at 8:23 AM
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, Acee Lindem <[email-masked]<mailto:[email-masked]>>, Giles Heron <[email-masked]<mailto:[email-masked]>>
Cc: Himanshu Shah <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Dhanendra Jain (dhjain)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] BGP common parameter Yang module

Hi Folks,

Regards,
Patrice Brissette

From: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 10, 2017 at 2:43 PM
To: "Acee Lindem (acee)" <[email-masked]<mailto:[email-masked]>>, Giles Heron <[email-masked]<mailto:[email-masked]>>
Cc: Patrice Brissette <[email-masked]<mailto:[email-masked]>>, "Shah, Himanshu" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Dhanendra Jain (dhjain)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] BGP common parameter Yang module

I’d prefer common grouping indraft-ietf-rtgwg-routing-types and references from any other model using it

Cheers,
Jeff

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of "Acee Lindem (acee)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 10, 2017 at 08:42
To: Giles Heron <[email-masked]<mailto:[email-masked]>>
Cc: "Patrice Brissette (pbrisset)" <[email-masked]<mailto:[email-masked]>>, "Shah, Himanshu" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Dhanendra Jain (dhjain)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] BGP common parameter Yang module

Hi Giles,

Hi Acee,

Giles

Thanks,
Acee

Folks,

      |     +--rw bgp-parameters
      |     |  +--rw common

Thanks for your help.
Regards,
Patrice Brissette

_______________________________________________ BESS mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/bess

---

From: "Xufeng Liu" <[email-masked]>
Date: Mon, 13 Feb 2017 10:21:43 -0500

In EVPN, as Patrice described, the structure is:

      |     +--rw bgp-parameters

      |     |  +--rw common

In L2VPN, the structure is:

             +--ro bgp-auto-discovery

             |  +--ro route-distinguisher?   string

             |  +--ro vpn-target* [rt-value]

             |  |  +--ro rt-value    string

             |  |  +--ro rt-type     bgp-rt-type

In L3VPN, the current structure is:

      +--rw route-distinguisher

      |  +--rw config

      |  |  +--rw rd?   string

      +--rw ipv4

      |  +--rw unicast

      |     +--rw route-targets

      |     |  +--rw config

      |     |  |  +--rw rts* [rt]

      |     |  |  |  +--rw rt         string

      |     |  |  |  +--rw rt-type?   Enumeration

      +--rw ipv6

         +--rw unicast

            +--rw route-targets

            |  +--rw config

            |  |  +--rw rts* [rt]

            |  |  |  +--rw rt         string

            |  |  |  +--rw rt-type?   enumeration

Hi Dhanendra and All, 

Are we ok to move the route targets section out of the AF specific location
to where RD is specified? If so, we can define the following common
grouping:

             |  +--ro route-distinguisher?   string

             |  +--ro vpn-target* [rt-value]

             |  |  +--ro rt-value    string

             |  |  +--ro rt-type     bgp-rt-type

Otherwise, we can only define a grouping without the RD:

             |  +--ro vpn-target* [rt-value]

             |  |  +--ro rt-value    string

             |  |  +--ro rt-type     bgp-rt-type

Thanks,

- Xufeng

From: BESS [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Saturday, February 11, 2017 12:46 PM
To: Patrice Brissette (pbrisset) <[email-masked]>; Jeff Tantsura
<[email-masked]>; Giles Heron <[email-masked]>
Cc: [email-masked]; Dhanendra Jain (dhjain)
<[email-masked]>; [email-masked]; Shah, Himanshu <[email-masked]>
Subject: Re: [bess] BGP common parameter Yang module

Given that there is no paucity of authors and contributors on these three
BESS YANG models, I'd hope that one of them could provide a suggested common
grouping. For now, I've added the route-target-type type on which there
seems to be consensus. 

Thanks,

Acee  

From: "Patrice Brissette (pbrisset)" <[email-masked]
<mailto:[email-masked]> >
Date: Saturday, February 11, 2017 at 8:23 AM
To: Jeff Tantsura <[email-masked] <mailto:[email-masked]>
>, Acee Lindem <[email-masked] <mailto:[email-masked]> >, Giles Heron
<[email-masked] <mailto:[email-masked]> >
Cc: Himanshu Shah <[email-masked] <mailto:[email-masked]> >,
"[email-masked] <mailto:[email-masked]> " <[email-masked]
<mailto:[email-masked]> >, "Dhanendra Jain (dhjain)" <[email-masked]
<mailto:[email-masked]> >
Subject: Re: [bess] BGP common parameter Yang module

Hi Folks,

Same here. Can we do something about it?  And agree, all 3 VPN models should
have the same commonality.

Regards,

Patrice Brissette

From: Jeff Tantsura <[email-masked]
<mailto:[email-masked]> >
Date: Friday, February 10, 2017 at 2:43 PM
To: "Acee Lindem (acee)" <[email-masked] <mailto:[email-masked]> >, Giles
Heron <[email-masked] <mailto:[email-masked]> >
Cc: Patrice Brissette <[email-masked] <mailto:[email-masked]> >,
"Shah, Himanshu" <[email-masked] <mailto:[email-masked]> >, "[email-masked]
<mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >, "Dhanendra
Jain (dhjain)" <[email-masked] <mailto:[email-masked]> >
Subject: Re: [bess] BGP common parameter Yang module

I'd prefer common grouping indraft-ietf-rtgwg-routing-types and references
from any other model using it 

Cheers,

Jeff

From: BESS <[email-masked] <mailto:[email-masked]> > on behalf
of "Acee Lindem (acee)" <[email-masked] <mailto:[email-masked]> >
Date: Friday, February 10, 2017 at 08:42
To: Giles Heron <[email-masked] <mailto:[email-masked]> >
Cc: "Patrice Brissette (pbrisset)" <[email-masked]
<mailto:[email-masked]> >, "Shah, Himanshu" <[email-masked]
<mailto:[email-masked]> >, "[email-masked] <mailto:[email-masked]> "
<[email-masked] <mailto:[email-masked]> >, "Dhanendra Jain (dhjain)"
<[email-masked] <mailto:[email-masked]> >
Subject: Re: [bess] BGP common parameter Yang module

Hi Giles,

I will add the route-target-type type (enum of import, export, both) but for
a general grouping, it appears there are some discrepancies between the 3
models. Assuming the types: route-discriminator, route-target, and
route-target-type, can you provide a consensus grouping that all the models
would use? 

Thanks,

Acee 

From: Giles Heron <[email-masked] <mailto:[email-masked]> >
Date: Friday, February 10, 2017 at 11:18 AM
To: Acee Lindem <[email-masked] <mailto:[email-masked]> >
Cc: "Patrice Brissette (pbrisset)" <[email-masked]
<mailto:[email-masked]> >, "[email-masked] <mailto:[email-masked]> "
<[email-masked] <mailto:[email-masked]> >, Himanshu Shah <[email-masked]
<mailto:[email-masked]> >, "Dhanendra Jain (dhjain)" <[email-masked]
<mailto:[email-masked]> >
Subject: Re: [bess] BGP common parameter Yang module

Hi Acee, 

In general seems that for any BGP VPN (L2 or L3) you have an RD plus a list
of RTs (which can be import, export or both) - so I'd prefer that to be
defined in a shared grouping (more or less as per the structure Patrice gave
below) than to force each model to redefine it.

Giles

On 10 Feb 2017, at 14:51, Acee Lindem (acee) <[email-masked]
<mailto:[email-masked]> > wrote:

Hi Patrice - we are working fervently on a common IETF routing types model.
We have both route-target and router-distinguisher types defined there. The
work is being done in the Routing WG. Our intension is to accelerate
standardization so it doesn't hold up standardization of the importing
modules. Please comment as to whether you think this meets BESS
requirements. 

 <https://www.ietf.org/id/draft-ietf-rtgwg-routing-types-00.txt>
https://www.ietf.org/id/draft-ietf-rtgwg-routing-types-00.txt

Thanks,

Acee 

P.S. We plan an update next week but the RD and RT definitions have not
changed. 

From: BESS < <mailto:[email-masked]> [email-masked]> on behalf
of "Patrice Brissette (pbrisset)" < <mailto:[email-masked]>
[email-masked]>
Date: Friday, February 10, 2017 at 9:26 AM
To: " <mailto:[email-masked]> [email-masked]" < <mailto:[email-masked]>
[email-masked]>
Cc: "Dhanendra Jain (dhjain)" < <mailto:[email-masked]> [email-masked]>,
Himanshu Shah < <mailto:[email-masked]> [email-masked]>
Subject: [bess] BGP common parameter Yang module

Folks,

As part of EVPN, L2VPn and L3VPN Yang model, there is a "module" common to
all 3 Yang models.

      |     +--rw bgp-parameters

      |     |  +--rw common

 

It will be interesting to create a common BGP parameter Yang module as shown
above. I think it just makes sense.

Thanks for your help.

Regards,

Patrice Brissette

_______________________________________________
BESS mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/bess>
https://www.ietf.org/mailman/listinfo/bess

_______________________________________________ BESS mailing list
[email-masked] <mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

---

From: "Dhanendra Jain (dhjain)" <[email-masked]>
Date: Tue, 14 Feb 2017 19:27:24 +0000

Hi Xufeng,

inline..

From: Xufeng Liu <[email-masked]<mailto:[email-masked]>>
Date: Monday, February 13, 2017 at 7:21 AM
To: "Acee Lindem (acee)" <[email-masked]<mailto:[email-masked]>>, "Patrice Brissette (pbrisset)" <[email-masked]<mailto:[email-masked]>>, 'Jeff Tantsura' <[email-masked]<mailto:[email-masked]>>, 'Giles Heron' <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Cisco Employee <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "'Shah, Himanshu'" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [bess] BGP common parameter Yang module

      |     +--rw bgp-parameters
      |     |  +--rw common

Hi Dhanendra and All,

Are we ok to move the route targets section out of the AF specific location to where RD is specified? If so, we can define the following common grouping:

Dhjain> I think one way to handle this is to have separate common groupings for RD and RT. So that we can retain AF level granularity for RT grouping for import/export rules.

Thanks,
Dhanendra.

From: BESS [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Saturday, February 11, 2017 12:46 PM
To: Patrice Brissette (pbrisset) <[email-masked]<mailto:[email-masked]>>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Giles Heron <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Dhanendra Jain (dhjain) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Shah, Himanshu <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] BGP common parameter Yang module

Thanks,
Acee

Hi Folks,

Regards,
Patrice Brissette

Cheers,
Jeff

Hi Giles,

Hi Acee,

Giles

Thanks,
Acee

Folks,

      |     +--rw bgp-parameters
      |     |  +--rw common

Thanks for your help.
Regards,
Patrice Brissette

---

From: "Xufeng Liu" <[email-masked]>
Date: Tue, 14 Feb 2017 14:44:57 -0500

Hi Dhanendra,

More below. 

Thanks,

- Xufeng

From: Dhanendra Jain (dhjain) [mailto:[email-masked]] 
Sent: Tuesday, February 14, 2017 2:27 PM
To: Xufeng Liu <[email-masked]>; Acee Lindem (acee)
<[email-masked]>; Patrice Brissette (pbrisset) <[email-masked]>; 'Jeff
Tantsura' <[email-masked]>; 'Giles Heron' <[email-masked]>
Cc: [email-masked]; [email-masked]; 'Shah, Himanshu'
<[email-masked]>
Subject: Re: [bess] BGP common parameter Yang module

Hi Xufeng,

inline..

From: Xufeng Liu <[email-masked]
<mailto:[email-masked]> >
Date: Monday, February 13, 2017 at 7:21 AM
To: "Acee Lindem (acee)" <[email-masked] <mailto:[email-masked]> >, "Patrice
Brissette (pbrisset)" <[email-masked] <mailto:[email-masked]> >,
'Jeff Tantsura' <[email-masked] <mailto:[email-masked]> >,
'Giles Heron' <[email-masked] <mailto:[email-masked]> >
Cc: "[email-masked]
<mailto:[email-masked]> "
<[email-masked]
<mailto:[email-masked]> >, Cisco Employee
<[email-masked] <mailto:[email-masked]> >, "[email-masked]
<mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >, "'Shah,
Himanshu'" <[email-masked] <mailto:[email-masked]> >
Subject: RE: [bess] BGP common parameter Yang module

      |     +--rw bgp-parameters

      |     |  +--rw common

             +--ro bgp-auto-discovery

      |  +--rw config

      |  |  +--rw rd?   string

      +--rw ipv4

      |  +--rw unicast

      |     +--rw route-targets

      |     |  +--rw config

      |     |  |  +--rw rts* [rt]

      |     |  |  |  +--rw rt         string

      +--rw ipv6

         +--rw unicast

            +--rw route-targets

            |  +--rw config

            |  |  +--rw rts* [rt]

            |  |  |  +--rw rt         string

Hi Dhanendra and All,

Dhjain> I think one way to handle this is to have separate common groupings
for RD and RT. So that we can retain AF level granularity for RT grouping
for import/export rules. 

[Xufeng] Yes. That will be the approach below, to have separate an RT
grouping. The question is: do we need/want to retain the AF level
granularity for RT rules?

Thanks,

Dhanendra.

Thanks,

- Xufeng

From: BESS [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Saturday, February 11, 2017 12:46 PM
To: Patrice Brissette (pbrisset) <[email-masked]
<mailto:[email-masked]> >; Jeff Tantsura <[email-masked]
<mailto:[email-masked]> >; Giles Heron <[email-masked]
<mailto:[email-masked]> >
Cc: [email-masked]
<mailto:[email-masked]> ; Dhanendra Jain (dhjain)
<[email-masked] <mailto:[email-masked]> >; [email-masked]
<mailto:[email-masked]> ; Shah, Himanshu <[email-masked]
<mailto:[email-masked]> >
Subject: Re: [bess] BGP common parameter Yang module

Thanks,

Acee  

Hi Folks,

Regards,

Patrice Brissette

 

Cheers,

Jeff

Hi Giles,

Thanks,

Acee 

Hi Acee, 

Giles

Thanks,

Acee 

 

Folks,

      |     +--rw bgp-parameters

      |     |  +--rw common

 

Thanks for your help.

Regards,

Patrice Brissette

---

From: "Dhanendra Jain (dhjain)" <[email-masked]>
Date: Tue, 14 Feb 2017 20:45:17 +0000

Hi Xefeng,

From: Xufeng Liu <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 14, 2017 at 11:44 AM
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>, "Acee Lindem (acee)" <[email-masked]<mailto:[email-masked]>>, "Patrice Brissette (pbrisset)" <[email-masked]<mailto:[email-masked]>>, 'Jeff Tantsura' <[email-masked]<mailto:[email-masked]>>, 'Giles Heron' <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "'Shah, Himanshu'" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [bess] BGP common parameter Yang module

Hi Dhanendra,

More below.
Thanks,

- Xufeng

From: Dhanendra Jain (dhjain) [mailto:[email-masked]]
Sent: Tuesday, February 14, 2017 2:27 PM
To: Xufeng Liu <[email-masked]<mailto:[email-masked]>>; Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>>; Patrice Brissette (pbrisset) <[email-masked]<mailto:[email-masked]>>; 'Jeff Tantsura' <[email-masked]<mailto:[email-masked]>>; 'Giles Heron' <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; 'Shah, Himanshu' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] BGP common parameter Yang module

Hi Xufeng,

inline..

      |     +--rw bgp-parameters
      |     |  +--rw common

Hi Dhanendra and All,

Dhjain> I think one way to handle this is to have separate common groupings for RD and RT. So that we can retain AF level granularity for RT grouping for import/export rules.
[Xufeng] Yes. That will be the approach below, to have separate an RT grouping. The question is: do we need/want to retain the AF level granularity for RT rules?

Dhjain> Yes, because we have to configure Safi specific import/export rules separately with an L3 instance.  In the case of L2 the L2vpn and EVPN instances are separate from the top itself,  having separate RD/RT.

Thanks,
Dhanendra.

Thanks,
Acee

Hi Folks,

Regards,
Patrice Brissette

Cheers,
Jeff

Hi Giles,

Hi Acee,

Giles

Thanks,
Acee

Folks,

      |     +--rw bgp-parameters
      |     |  +--rw common

Thanks for your help.
Regards,
Patrice Brissette

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 14 Feb 2017 20:51:26 +0000

See inline.

From: "Dhanendra Jain (dhjain)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 14, 2017 at 3:45 PM
To: Xufeng Liu <[email-masked]<mailto:[email-masked]>>, Acee Lindem <[email-masked]<mailto:[email-masked]>>, "Patrice Brissette (pbrisset)" <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, 'Giles Heron' <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Himanshu Shah <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] BGP common parameter Yang module

Hi Xefeng,

Hi Dhanendra,

More below.
Thanks,

- Xufeng

Hi Xufeng,

inline..

      |     +--rw bgp-parameters
      |     |  +--rw common

Hi Dhanendra and All,

Agreed, but this shouldn’t be reflected in the common grouping. It should just be simple reusable list of <RT, RT-Type> and possibly an RD.

Thanks,
Acee

Thanks,
Dhanendra.

Thanks,
Acee

Hi Folks,

Regards,
Patrice Brissette

Cheers,
Jeff

Hi Giles,

Hi Acee,

Giles

Thanks,
Acee

Folks,

      |     +--rw bgp-parameters
      |     |  +--rw common

Thanks for your help.
Regards,
Patrice Brissette

---

From: Xufeng Liu <[email-masked]>
Date: Tue, 14 Feb 2017 20:59:40 +0000

Inline, Thanks.

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Tuesday, February 14, 2017 3:51 PM
To: Dhanendra Jain (dhjain) <[email-masked]>; Xufeng Liu <[email-masked]>; Patrice Brissette (pbrisset) <[email-masked]>; 'Jeff Tantsura' <[email-masked]>; 'Giles Heron' <[email-masked]>
Cc: [email-masked]; [email-masked]; 'Shah, Himanshu' <[email-masked]>
Subject: Re: [bess] BGP common parameter Yang module

See inline.

Hi Xefeng,

Hi Dhanendra,

More below.
Thanks,

- Xufeng

Hi Xufeng,

inline..

      |     +--rw bgp-parameters
      |     |  +--rw common

Hi Dhanendra and All,

Agreed, but this shouldn't be reflected in the common grouping. It should just be simple reusable list of <RT, RT-Type>
[Xufeng] Yes.
and possibly an RD.
[Xufeng] This is the questionable part. Putting an RD here does not fit the current l3vpn structure.

Thanks,
Acee

Thanks,
Dhanendra.

Given that there is no paucity of authors and contributors on these three BESS YANG models, I'd hope that one of them could provide a suggested common grouping. For now, I've added the route-target-type type on which there seems to be consensus.

Thanks,
Acee

Hi Folks,

Regards,
Patrice Brissette

I'd prefer common grouping indraft-ietf-rtgwg-routing-types and references from any other model using it

Cheers,
Jeff

Hi Giles,

Hi Acee,

Giles

Thanks,
Acee

Folks,

      |     +--rw bgp-parameters
      |     |  +--rw common

Thanks for your help.
Regards,
Patrice Brissette

---

From: "Dhanendra Jain (dhjain)" <[email-masked]>
Date: Tue, 14 Feb 2017 21:12:13 +0000

Hi Acee,

From: "Acee Lindem (acee)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 14, 2017 at 12:51 PM
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>, Xufeng Liu <[email-masked]<mailto:[email-masked]>>, "Patrice Brissette (pbrisset)" <[email-masked]<mailto:[email-masked]>>, 'Jeff Tantsura' <[email-masked]<mailto:[email-masked]>>, 'Giles Heron' <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "'Shah, Himanshu'" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] BGP common parameter Yang module

See inline.

Hi Xefeng,

Hi Dhanendra,

More below.
Thanks,

- Xufeng

Hi Xufeng,

inline..

      |     +--rw bgp-parameters
      |     |  +--rw common

Hi Dhanendra and All,

Dhjain> Yes, essentially that is second option below, the re-usable groupings of RT alone and RD alone. Another grouping containing both can also be provided and can be used within l2vpn/evpn.  But in case of L3, RD grouping can be used at network instance level, and RT grouping at SAFI level.

Thanks,
Dhanendra.

Thanks,
Acee

Thanks,
Dhanendra.

Thanks,
Acee

Hi Folks,

Regards,
Patrice Brissette

Cheers,
Jeff

Hi Giles,

Hi Acee,

Giles

Thanks,
Acee

Folks,

      |     +--rw bgp-parameters
      |     |  +--rw common

Thanks for your help.
Regards,
Patrice Brissette

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 14 Feb 2017 21:27:49 +0000

Hi Dhanendra,

From: "Dhanendra Jain (dhjain)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 14, 2017 at 4:12 PM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Xufeng Liu <[email-masked]<mailto:[email-masked]>>, "Patrice Brissette (pbrisset)" <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, 'Giles Heron' <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Himanshu Shah <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] BGP common parameter Yang module

Hi Acee,

See inline.

Hi Xefeng,

Hi Dhanendra,

More below.
Thanks,

- Xufeng

Hi Xufeng,

inline..

      |     +--rw bgp-parameters
      |     |  +--rw common

Hi Dhanendra and All,

So I don’t see any benefit of doing more than the RT List. Will there be more than one model where the RD/RT List grouping could be used?

Thanks,
Acee

Thanks,
Dhanendra.

Thanks,
Acee

Thanks,
Dhanendra.

Thanks,
Acee

Hi Folks,

Regards,
Patrice Brissette

Cheers,
Jeff

Hi Giles,

Hi Acee,

Giles

Thanks,
Acee

Folks,

      |     +--rw bgp-parameters
      |     |  +--rw common

Thanks for your help.
Regards,
Patrice Brissette

---

From: "Dhanendra Jain (dhjain)" <[email-masked]>
Date: Wed, 15 Feb 2017 18:42:43 +0000

Hi Acee,

Date: Tuesday, February 14, 2017 at 1:27 PM

Hi Dhanendra,

Hi Acee,

See inline.

Hi Xefeng,

Hi Dhanendra,

More below.
Thanks,

- Xufeng

Hi Xufeng,

inline..

      |     +--rw bgp-parameters
      |     |  +--rw common

Hi Dhanendra and All,

Dhjain> Its L2vpn/EVPN as Patrice mentioned below. But I agree that just RT-list and RD type (commonly defined) could be used in all models instead of worrying about further grouping, as single grouping won't satisfy all.

Thanks,
Dhanendra

Thanks,
Acee

Thanks,
Dhanendra.

Thanks,
Acee

Thanks,
Dhanendra.

Thanks,
Acee

Hi Folks,

Regards,
Patrice Brissette

Cheers,
Jeff

Hi Giles,

Hi Acee,

Giles

Thanks,
Acee

Folks,

      |     +--rw bgp-parameters
      |     |  +--rw common

Thanks for your help.
Regards,
Patrice Brissette