Subject: Re: [Bier] New Version Notification for draft-hao-bier-active-active-00.txt

From: Haoweiguo <[email-masked]>
Date: Mon, 11 Jan 2016 06:27:37 +0000

Hi,
A new draft about BIER split-horizon mechanism used for active-active access was proposed. Your comments and suggestions are appreciated.
Thanks,
weiguo

________________________________________
From: [email-masked] [[email-masked]]
Sent: Monday, January 11, 2016 11:53
To: Liyizhou; Zhuangshunwan; Liyizhou; Haoweiguo; Haoweiguo
Subject: New Version Notification for draft-hao-bier-active-active-00.txt

A new version of I-D, draft-hao-bier-active-active-00.txt
has been successfully submitted by Weiguo Hao and posted to the
IETF repository.

Name:           draft-hao-bier-active-active
Revision:       00
Title:          BIER Split-horizon mechanism for active-active access
Document date:  2016-01-11
Group:          Individual Submission
Pages:          8
URL:            https://www.ietf.org/internet-drafts/draft-hao-bier-active-active-00.txt
Status:         https://datatracker.ietf.org/doc/draft-hao-bier-active-active/
Htmlized:       https://tools.ietf.org/html/draft-hao-bier-active-active-00

Abstract:
   This document proposes a BIER split-horizon mechanism for active-
   active access. Both data plane and control plane extension are
   included.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 11 Jan 2016 15:54:27 +0000

Weiguo,

Existing EVPN procedures is enough to avoid traffic duplication and achieve split-horizon, whether Ingress Replication, P2MP, or BIER "tunnels" are used.

Not sure why we need new signaling?

Jeffrey

> -----Original Message-----
> From: BIER [mailto:[email-masked]] On Behalf Of Haoweiguo
> Sent: Monday, January 11, 2016 1:28 AM
> To: [email-masked]
> Cc: Zhuangshunwan <[email-masked]>; Liyizhou
> <[email-masked]>
> Subject: Re: [Bier] New Version Notification for draft-hao-bier-active-
> active-00.txt
> 
> Hi,
> A new draft about BIER split-horizon mechanism used for active-active
> access was proposed. Your comments and suggestions are appreciated.
> Thanks,
> weiguo
> 
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier

---

From: Caitlin Bestler <[email-masked]>
Date: Mon, 11 Jan 2016 13:47:12 -0800

802.1AX Ethernet link aggregation creates a *single* virtual 802.1 link.
Therefore LACP should never be referenced in an IP layer standard.

---

From: Haoweiguo <[email-masked]>
Date: Tue, 12 Jan 2016 01:10:59 +0000

Hi Jeffery,
Yes, currently EVPN provides comprehensive active-active access solution. The solution mainly includes two parts of DF election and split-horizon mechansim. For the split-horizon mechanism, currently it will vary along with different transport layer technology. If the transport layer is MPLS, it relies on ESI Label for filtering. If the transport layer is VXLAN, it relies on source VTEP IP address for filtering.
For layer 3 VPN active-active access, it doesn't have the active-active solution. If it wants to realize similar active-active access procedures, it should design similar mechanism repeatedly.
So we think split-horizon mechanism should be removed from service layer to transport layer, it should be service agnostic. The split-horizon mechanism should be inherent in BIER itself and should be shared for all multicast services over it.
Thanks,
weiguo
________________________________________
From: Jeffrey (Zhaohui) Zhang [[email-masked]]
Sent: Monday, January 11, 2016 23:54
To: Haoweiguo; [email-masked]
Cc: Zhuangshunwan; Liyizhou
Subject: RE: [Bier] New Version Notification for        draft-hao-bier-active-active-00.txt

Weiguo,

Jeffrey

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 12 Jan 2016 13:52:13 +0000

Weiguo,

> From: Haoweiguo [mailto:[email-masked]]
> Sent: Monday, January 11, 2016 8:11 PM
> To: Jeffrey (Zhaohui) Zhang <[email-masked]>; [email-masked]
> Yes, currently EVPN provides comprehensive active-active access solution.
> The solution mainly includes two parts of DF election and split-horizon
> mechansim. For the split-horizon mechanism, currently it will vary along
> with different transport layer technology. If the transport layer is MPLS,
> it relies on ESI Label for filtering. If the transport layer is VXLAN, it
> relies on source VTEP IP address for filtering.

For EVPN with BIER, it happens that both ESI label and local-bias could be used.

> For layer 3 VPN active-active access, it doesn't have the active-active
> solution. If it wants to realize similar active-active access procedures,
> it should design similar mechanism repeatedly.

Can you give an example? I had thought the RPF mechanism makes sure that traffic only goes where it should go.

> So we think split-horizon mechanism should be removed from service layer
> to transport layer, it should be service agnostic. The split-horizon
> mechanism should be inherent in BIER itself and should be shared for all
> multicast services over it.

I think BIER, not split-horizon, should be service agnostic.

Even though you say L3 has a problem, you're proposing to signal ESI as part of BIER signaling, and that is purely L2.

Jeffrey

> Existing EVPN procedures is enough to avoid traffic duplication and
> achieve split-horizon, whether Ingress Replication, P2MP, or BIER
> "tunnels" are used.
> 
> > Htmlized:       https://tools.ietf.org/html/draft-hao-bier-active-
> active-
> > 00
> >
> >
> > Abstract:

---

From: Caitlin Bestler <[email-masked]>
Date: Tue, 12 Jan 2016 12:32:51 -0800

If you are claiming that a purely L2 issue is something that BIER must 
deal with then your draft should be explicit on which standards allow 
this problem to exist.
Under what conditions does the BIER layer have to augment duplication 
elimination?