Subject: [Bier] comments on draft-wang-bier-ethernet-01

From: Tony Przygienda <[email-masked]>
Date: Tue, 5 Apr 2016 07:36:30 -0700

after reading

a) first nibble: refer to MPLS encaps as "the same value" to keep in sync
b) refer to all other possible fields to MPLS encaps to keep in sync when
describing instead of repeating
c) you need to describe which kind of ether MACs are allowed, especially on
broadcast media, i.e. is it always p2p or can you take advantage of the
broadcast ?
d) Figure 4: use the architecture/MPLS encoding for the length, don't
invent a new one
e) who will obtain a new ether type from IEEE? As far I understand, not a
trivial process albeit we have several liaisons with IEEE

-- 
*We’ve heard that a million monkeys at a million keyboards could produce
the complete works of Shakespeare; now, thanks to the Internet, we know
that is not true.*
—Robert Wilensky

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 5 Apr 2016 22:04:42 +0000

In fact, the following draft (https://tools.ietf.org/html/draft-xu-bier-encapsulation-03) has already proposed a transport-independent BIER encapsulation header which is applicable in any kind of transport networks. In other words, the BIER-in-MAC encapsulation has been covered in the above draft.

Best regards,

Xiaohu

________________________________

发件人: BIER [[email-masked]] 代表 Tony Przygienda [[email-masked]]
发送时间: 2016年4月5日 22:36
收件人: [email-masked]
主题: [Bier] comments on draft-wang-bier-ethernet-01

after reading

a) first nibble: refer to MPLS encaps as "the same value" to keep in sync
b) refer to all other possible fields to MPLS encaps to keep in sync when describing instead of repeating
c) you need to describe which kind of ether MACs are allowed, especially on broadcast media, i.e. is it always p2p or can you take advantage of the broadcast ?
d) Figure 4: use the architecture/MPLS encoding for the length, don't invent a new one
e) who will obtain a new ether type from IEEE? As far I understand, not a trivial process albeit we have several liaisons with IEEE

--
We’ve heard that a million monkeys at a million keyboards could produce the complete works of Shakespeare; now, thanks to the Internet, we know that is not true.
―Robert Wilensky