Subject: [Bier] YANGvalidator output of draft-chh-bier-bier-yang-03

From: Gregory Mirsky <[email-masked]>
Date: Wed, 6 Apr 2016 18:19:36 +0000

Dear Authors, et. al,
I've briefly checked the YANG model by YANGvalidator. The model is extracted properly but validation fails with the following:

ietf-bier.yang:15: error: module "ietf-mpls" not found in search path
ietf-bier.yang:19: error: module "ietf-isis" not found in search path
ietf-bier.yang:23: error: module "ietf-ospf" not found in search path
Hope this helps.

                Regards,
                                Greg

---

From: [email-masked]
Date: Thu, 7 Apr 2016 03:15:51 +0800

Hi,Gregory

Yes, we know this issue, and have discussed with YANG doctor. 

The reason is that the validator is looking for imported modules 
(ietf-mpls, ietf-is-is, and ietf-ospf). And since they are not formally 
published (yet) we don’t have them in the local repository on the 
validator site.

Regards.
Fangwei.

Gregory Mirsky <[email-masked]> 
发件人:  "BIER" <[email-masked]>
2016-04-07 02:19

收件人
"[email-masked]" <[email-masked]>, 
抄送
"BIER \([email-masked]\)" <[email-masked]>
主题
[Bier] YANGvalidator output of draft-chh-bier-bier-yang-03

Dear Authors, et. al,
I’ve briefly checked the YANG model by YANGvalidator. The model is 
extracted properly but validation fails with the following:

                Regards,
                                Greg
_______________________________________________
BIER mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bier