Subject: [Bier] YANG doctors @ IETF

From: Gregory Mirsky <[email-masked]>
Date: Wed, 6 Apr 2016 21:44:35 +0000

Dear All,
YANG doctors can be reached by email via [email-masked]<mailto:[email-masked]>.
Their home page https://www.ietf.org/iesg/directorate/yang-doctors.html  has the list of esteemed doctors and links to invaluable resources.

                Regards,
                                Greg

---

From: [email-masked]
Date: Fri, 8 Apr 2016 00:34:17 +0800

Hi, Gregory

Thanks for your reminding.

to YANG doc team:

We’ve  checked the YANG model by YANGvalidator.  The model fails with the 
following errors:

ietf-bier.yang:15: error: module "ietf-mpls" not found in search path 
ietf-bier.yang:19: error: module "ietf-isis" not found in search path 
ietf-bier.yang:23: error: module "ietf-ospf" not found in search path 

We do not know how to correct it,  would you please help us to fix them? 
Thanks!

Regards.
Fangwei.

Gregory Mirsky <[email-masked]> 
发件人:  "BIER" <[email-masked]>
2016-04-07 05:44

收件人
"BIER ([email-masked])" <[email-masked]>, 
抄送

主题
[Bier] YANG doctors @ IETF

Dear All,

YANG doctors can be reached by email via  [email-masked].

Their home page  https://www.ietf.org/iesg/directorate/yang-doctors.html 
 has the list of esteemed doctors and links to invaluable resources.

                Regards,

                                Greg
_______________________________________________
BIER mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bier

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 7 Apr 2016 16:46:56 +0000

I believe right now you need to upload the dependent YANG modules also by using “Upload multiple YANG files or a zip archive"

Regards,
Reshad.

From: BIER <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, April 7, 2016 at 12:34 PM
To: Gregory Mirsky <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "BIER ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, BIER <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] YANG doctors @ IETF

Hi, Gregory

to YANG doc team:

We’ve  checked the YANG model by YANGvalidator.  The model fails with the following errors:

Regards.
Fangwei.

Gregory Mirsky <[email-masked]<mailto:[email-masked]>>
发件人:  "BIER" <[email-masked]<mailto:[email-masked]>>

2016-04-07 05:44

收件人
        "BIER ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>,
抄送

主题

Dear All,

Their home page  https://www.ietf.org/iesg/directorate/yang-doctors.html<https://www.ietf.org/iesg/directorate/yang-doctors.html>  has the list of esteemed doctors and links to invaluable resources.

                Regards,

                                Greg
_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

---

From: "Carl Moberg (camoberg)" <[email-masked]>
Date: Thu, 7 Apr 2016 17:22:59 +0000

That’s right. The YANG validator site does not (yet) download and make available non-RFC YANG modules (like "ietf-mpls” below), so you need to use the multiple upload or zip-options and include the missing YANG modules.

 We are working on making all published (draft and later) YANG modules available to the validator, but that’s not done yet.

--
Carl Moberg
Technology Director, CVG
[email-masked]

> On Apr 7, 2016, at 6:46 PM, Reshad Rahman (rrahman) <[email-masked]> wrote:
> 
> From: BIER <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
> To: Gregory Mirsky <[email-masked]>, "[email-masked]" <[email-masked]>
> Cc: "BIER ([email-masked])" <[email-masked]>, BIER <[email-masked]>
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors