Subject: Re: [Bier] comment on draft-anish-bier-overlay-pim-00

From: Anish Peter <[email-masked]>
Date: Fri, 17 Jun 2016 15:45:33 +0530

Hi Eric, Toni,
  I went through the isis bier draft to realize that it may not be 
possible to derive the BIER ID and sub-domain from the bier prefix.
  But the architecture draft for bier seem to give a different picture 
in section 5 
(https://tools.ietf.org/html/draft-ietf-bier-architecture-03#section-5).

"

These advertisements enable each BFR to associate a given <sub-
    domain-id, BFR-id> with a given BFR-prefix.
"

  Please let us know what should be the right approach. Should the draft 
state both prefix and <ID, subdomain>.

Thanks,
Anish

On 10/22/15 1:04 PM, Antoni Przygienda wrote:
>
> AP> The field in the hello tlv is BIER-prefix and not BIER-ID. A 
> router participating in BIER forwarding but is not egress may not have 
> a BIER-ID, but will have BIER-prefix. Hence this flag helps.
>
> */[Tony saiz:] I don’t see how those two things relate to each other. 
> You always have a prefix, yes, under that you have BFR-id per 
> sub-domain and that  is basically your ‘e’ bit you can derive from 
> underlay. The bit seems redundant and may contradict the underlay 
> easily /*
>

---

From: Antoni Przygienda <[email-masked]>
Date: Fri, 17 Jun 2016 22:05:43 +0000

It does not say “derive” as you say, only “associate”.

Uml sketch

--- tony

<[email-masked]<mailto:[email-masked]>> spake:

Hi Eric, Toni,
 I went through the isis bier draft to realize that it may not be possible to derive the BIER ID and sub-domain from the bier prefix.
 But the architecture draft for bier seem to give a different picture in section 5 (https://tools.ietf.org/html/draft-ietf-bier-architecture-03#section-5).

"

"
 Please let us know what should be the right approach. Should the draft state both prefix and <ID, subdomain>.

Thanks,
Anish

On 10/22/15 1:04 PM, Antoni Przygienda wrote:
AP> The field in the hello tlv is BIER-prefix and not BIER-ID. A router participating in BIER forwarding but is not egress may not have a BIER-ID, but will have BIER-prefix. Hence this flag helps.
[Tony saiz:] I don’t see how those two things relate to each other. You always have a prefix, yes, under that you have BFR-id per sub-domain and that  is basically your ‘e’ bit you can derive from underlay. The bit seems redundant and may contradict the underlay easily