Subject: [Bier] Call for adoption: draft-xiong-bier-resilience-01

From: Greg Shepherd <[email-masked]>
Date: Fri, 25 Jan 2019 10:11:46 -0800

Please read and reply to this thread with your vote for/against adoption of:

https://datatracker.ietf.org/doc/draft-xiong-bier-resilience/

..as a BIER WG document.

This starts a two week counter.

Thanks,
Chairs
(Shep)

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 25 Jan 2019 18:36:44 +0000

Hmm … I had some email exchanges on this topic with a few folks before but looks like I forgot to compile and send out my comments soon after the Bangkok meeting.

Anyway, I think we need more discussion on the content before adoption.

Quite a long time ago we discussed with some customers and the following are a summary:

  *   BIER makes use of unicast FRR so traffic interruption is minimum
     *   Same as unicast
     *   Therefore MoFRR or live-live is not really needed
  *   Live-live might be done for mission critical applications
     *   Just send two streams in different subdomains (with disjoint underlays)
     *   Application must be responsible for merging the two streams and discard duplicates
        *   It’s not feasible or it does not provide live-live protection value for a BFER to pick which stream to deliver
           *   Switch over can’t be link status based
           *   Traffic based switch over only possible for CBR, and even so due to FRR traffic loss may not be enough to trigger detection

For the three use cases in draft-xiong-bier-resilience:

3.1.  End-to-End 1+1 Protection

3.2.  End-to-End 1:1 Protection

3.3.  BIER Link Protection

1+1 Protection is what we referred to as live-live, but it only make sense if both copies are sent to the CE (using MVPN example) for it to do the merge, and that is really not BIER specific (it is rather an overlay function).

BIER Link Protection is inherent of unicast protection and nothing special needs to be done.

With the inherent unicast FRR it’s not clear to me what value the 1:1 protection has.

Jeffrey

From: BIER [mailto:[email-masked]] On Behalf Of Greg Shepherd
Sent: Friday, January 25, 2019 1:12 PM
To: BIER WG <[email-masked]>
Subject: [Bier] Call for adoption: draft-xiong-bier-resilience-01

https://datatracker.ietf.org/doc/draft-xiong-bier-resilience/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dxiong-2Dbier-2Dresilience_&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=f7wsLGcfzAWDNS6XNTBZwj_OLAOsZZqdrR2IDAzeZqE&m=STb7mqddzf1ELpQUCskrlZeKWCg8DUFLm6tGxLR5-N4&s=zxYw2qZxEAraeYYpbwQ4j3pvaDxP-VTa-Zj70NrZh4U&e=>

..as a BIER WG document.

Thanks,
Chairs
(Shep)