Subject: [Bier] editorial comments on draft-ietf-bier-use-cases-08

From: Anoop Ghanwani <[email-masked]>
Date: Tue, 29 Jan 2019 14:32:52 -0800

I read the document and have the following editorial comments on the doc.

Thanks,
Anoop

===
General
There is a mix of acronym plurals, e.g. PEs and PE's, VPNs and VPN's,
etc. Would be good if it can be made consistent.  I would prefer the
former style.

Section titles -- some are capitalized, some not.  Make consistent.

abstract
use-cases -> use cases

1
is an architecture -> is a protocol
Multicast -> multicast
use-cases -> use cases

3.1
Multicast across a providers -> multicast across a provider's
build -> built
"Selective" PMSI -> "Selective" PMSI (S-PMSI)
in the providers network -> in the provider's network
Mi-PMSI's -> MI-PMSI's
Egress PE router -> egress PE router
a least a PMSI -> at least a PMSI
Ingress PE -> ingress PE
BIER domain's -> BIER domains

3.2
P-Multicast Service Interface (PMSI) [RFC6513] attribute -> PMSI
attribute [RFC6513]
EVPN and given EVPN -> EVPN, and given that EVPN
the PEs that participate in the EVI the BUM -> those PEs that
participate in the EVI that the BUM
In a sense BIER -> In a sense, BIER
allow to deliver -> allow delivery of
involved has not been specified as of date -> involved, but has not
been specified as yet

3.3
end-to-end Managed IP network -> an end-to-end managed IP network
managed layer 3 IP network -> managed layer 3 IP networks
multicast group/channels -> multicast groups/channels
BIER could allows -> BIER could allow
every receivers behind every egress PE routers -> all receivers behind
all egress PE routers
With BIER in IPTV environment -> With BIER in an IPTV environment
of tree building -> for building a tree
addition of new channel -> addition of new channels
from ingress router -> from the ingress router _
mapped to Bit string -> mapped to a bit string
in each egress routers -> in each egress router
channel/stream -> group/channel . (stream not used till now)
from ingress router itself by configuring the new group to Bit Mask
mapping -> from the ingress router itself by configuring the new group
to bit mask mapping
these edge routers in CDN -> the edge routers in the CDN
the Ingress BIER routers -> the ingress BIER routers
Layer 4 applications -> layer 4 applications
the Ingress BIER router -> the ingress BIER router
keeps the BIER more descrete on a domain by domain basis -> keeps BIER
domains discrete

3.4
multiple-services -> multiple services
single Metro Core network -> single metro core
Residential IPTV -> residential IPTV
use multicast -> use the multicast
ten's of millions -> ten's of millions
all consequences such -> all of the consequences that such
of tree building -> for building a tree
As described earlier on -> As described earlier

3.5

being consider include -> being considered include
network-elements with simplified control -> network elements with a
simplified control
control-plane architecture -> control plane architecture
With Segment routing -> With segment routing
simplifies control-plane -> simplifies the control plane
which makes transition to control-plane simplified network simpler to
operationalize -> which simplifies the operation of transitioning the
control plane
for operators, who would desire centralized -> for operators who
desire a centralized
could migrate to controller-based programming -> could be used with
controller-based programming

3.6
layer2 flooding -> layer 2 flooding
layer3 underlay -> layer 3 underlay

it requires to have a mapping between the VXLAN Virtual Network
Instance (VNI) and the IP multicast group in a ratio of 1:1 or n:1 ->
it requires a 1:1 or n:1 mapping between the VXLAN Virtual Network
Instance (VNI) and the corresponding IP multicast group
it requires to enable the -> it requires enabling
as a unaffordable -> as an undesirable
network operation and maintenance perspectives -> perspective of
network operation and maintenance
VXLAN implementations are claimed -> VXLAN implementations claim
on a high amount -> on a large number
multicast states -> multicast state

3.7
rely on IP Multicast -> rely on IP multicast
solutions e.g.  PIM, mLDP etc., -> solutions, e.g. PIM, mLDP, etc.,
driven i.e. -> driven, i.e.

3.8
with enormous demand -> placing enormous demands
of Low latency -> of low latency
between Ingress connecting -> between ingress connecting
resulting with more multicast state -> resulting in more multicast state
or SDN controller -> or an SDN controller

3.9
The Client multicast a -> The Client multicasts a
unicast a Chunk Put Response -> unicasts a Chunk Put Response
>The Client multicast a Chunk Put -> The Client multicasts a Chunk Put
short Bitstring -> short bit string
To address the entire Negotiating Group you set
   the Bitstring to all ones.  To later address a subset of the group a
   subset Bitstring is used.
to
To address the entire Negotiating Group the bit string is set
   to all ones.  To later address a subset of the group a
   subset of the bit string is used.

3.10
from the the dynamic -> from the dynamic

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 30 Jan 2019 00:10:53 +0000

Hi Anoop,

Thanks a lot for your editorial review and feedback. Will address them in the next version.

--
Cheers,
Rajiv Asati

From: BIER <[email-masked]> on behalf of Anoop Ghanwani <[email-masked]>
Date: Tuesday, January 29, 2019 at 5:33 PM
To: "[email-masked]" <[email-masked]>
Subject: [Bier] editorial comments on draft-ietf-bier-use-cases-08

Thanks,
Anoop

===
General

abstract
use-cases -> use cases

1

3.1

3.2

3.3

3.4

3.5

3.6

3.7

3.8

3.9

to

3.10

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Wed, 30 Jan 2019 12:01:49 +0000

Hi Anoop,

Thank you for the comments. We will look into this and will get back to you.

Thanks
Nagendra

Sent from my iPhone

> On Jan 29, 2019, at 5:33 PM, Anoop Ghanwani <[email-masked]> wrote:
> 
> [email-masked]