Subject: [Bier] Call For Adoption: draft-venaas-bier-mtud

From: Greg Shepherd <[email-masked]>
Date: Fri, 25 Jan 2019 10:07:38 -0800

Please read and reply to this thread with your vote for/against adoption of:

https://datatracker.ietf.org/doc/draft-venaas-bier-mtud/

..as a BIER WG document.

This starts a two week counter.

Thanks,
Chairs
(Shep)

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Fri, 25 Jan 2019 18:09:26 +0000

Support the adoption of this document.

Thanks
Mankamana

From: BIER <[email-masked]> on behalf of Greg Shepherd <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Friday, January 25, 2019 at 10:08 AM
To: BIER WG <[email-masked]>
Subject: [Bier] Call For Adoption: draft-venaas-bier-mtud

..as a BIER WG document.

Thanks,
Chairs
(Shep)

---

From: Greg Mirsky <[email-masked]>
Date: Sun, 27 Jan 2019 21:14:52 +0800

Hi,
I've read the draft and support its adoption.

Regards,
GregM

On Sat, Jan 26, 2019 at 2:08 AM Greg Shepherd <[email-masked]> wrote:

> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
>

---

From: Xiejingrong <[email-masked]>
Date: Mon, 28 Jan 2019 01:58:44 +0000

Support the adoption.

Jingrong

From: BIER [mailto:[email-masked]] On Behalf Of Greg Shepherd
Sent: Saturday, January 26, 2019 2:08 AM
To: BIER WG <[email-masked]>
Subject: [Bier] Call For Adoption: draft-venaas-bier-mtud

..as a BIER WG document.

Thanks,
Chairs
(Shep)

---

From: Liuyisong <[email-masked]>
Date: Mon, 28 Jan 2019 02:02:26 +0000

I support the adoption

Thanks
Yisong

..as a BIER WG document.

Thanks,
Chairs
(Shep)

---

From: Senthil Dhanaraj <[email-masked]>
Date: Mon, 28 Jan 2019 16:05:09 +0530

Few concerns on, whether the proposed solution by the draft can address
different scenario's and if this is the best way to go.
Request authors to have a look.

1.  The draft already explains that the selected MTU for a path might not
be the best MTU, rather a conservative one.
Adding to that,

As per the draft, the advertised MTU indicates the size of the largest BIER
packet including the BIER header.
But the size of the BIER header itself varies based on the selected BSL.

If there exists a node which only supports lower BSL, say BSL=64 and
advertises MTU considering BSL=64, then we force all the other nodes in the
same SD which may support/choose to use bigger BSL, say BSL=256 to operate
with even lesser MTU.

Makes me wonder, if we should discover MTU per SD/BSL (or) advertise link
MTU irrespective of L3 overhead SR/BIER.

2. How do we address below scenario,

BFIR  -- BFR1 -- Non-BIER-Node -- BFR2 -- BFER
                 <=== MPLS//SR tunnel ===>

BFR1 may use a MPLS/SR tunnel to bypass the Non-BIER-Node.
Note that,
 - the IGP (BIER) adjacency is between (BFR1, Non-Bier-Node) and
(Non-BIER-Node, BFR2).
 - there is no IGP adjacency over the MPLS/SR tunnel used to bypass
non-bier-capable-node.

3. It is not clear , how the BIER MTU is discovered across IGP area's ?

Thanks,
Senthil