Subject: [Bier] RFC8401 - Question on BIER TLV leaking from one level to the other

From: Senthil Dhanaraj <[email-masked]>
Date: Fri, 12 Apr 2019 08:02:58 +0200

Hi Authors,

When ABR leaks the Prefix (& BIER TLVs) from one level to another, the LSP
contains both the ABR's local prefix and the other prefix'es which are
re-advertised from one level to the other.
Nodes receiving such an LSP should be able to identify the Prefix (& BIER
TLV) that is originally local to the ABR from the other inter
(re-advertised) prefix'es.

Unlike SR-ISIS extensions TLV, BIER-ISIS extension TLVs do not have N/R
flags.

Hence the only way to identify the prefix type (local or re-advertised) is
by having the ABR advertise the "IPv4/IPv6 Extended Reachability Attribute
Flags sub-TLV - RFC7794" whenever it leaks the BIER TLVs from one level to
another. Is my understanding correct?

Ref from - RFC 7794 - 2.1 <https://tools.ietf.org/html/rfc7794#section-2.1>.
IPv4/IPv6 Extended Reachability Attribute Flags

       0 1 2 3 4 5 6 7...
      +-+-+-+-+-+-+-+-+...
      |X|R|N|          ...
      +-+-+-+-+-+-+-+-+...

   R-Flag:  Re-advertisement Flag (Bit 1)
      Set when the prefix has been leaked from one level to another
      (upwards or downwards).

Thanks,
Senthil

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 12 Apr 2019 20:23:35 +0000

Senthil –

There is no such thing as a “BIER-ISIS extension TLV”.
There is only the “BIER Info” sub-TLV(sic) which is carried in a Prefix Reachability TLV (one of TLVs 135, 235, 236, and 237).
Therefore the Prefix-Attribute sub-TLV can and should be present in such a TLV as well.

See https://tools.ietf.org/html/rfc8401#section-4.2

The only minor issue here is that the RFC says:

o  When the Prefix Attributes Flags sub-TLV [RFC7794] is present, the
      N flag MUST be set and the R flag MUST NOT be set.

In cases where the prefix is leaked the R flag will be set. The text is a holdover from early versions where we had prohibited leaking.
In cases where the prefix is leaked the R flag will be set.

I suppose this deserves an Errata.
I thought this issue had been discussed and addressed – but I couldn’t find any relevant email and clearly the published text has a flaw.
Sigh…

    Les

From: Senthil Dhanaraj <[email-masked]>
Sent: Thursday, April 11, 2019 11:03 PM
To: Les Ginsberg (ginsberg) <[email-masked]>; Antoni Przygienda <[email-masked]>; [email-masked]; Jeffrey (Zhaohui) Zhang <[email-masked]>
Cc: BIER WG <[email-masked]>
Subject: RFC8401 - Question on BIER TLV leaking from one level to the other

Hi Authors,

When ABR leaks the Prefix (& BIER TLVs) from one level to another, the LSP contains both the ABR's local prefix and the other prefix'es which are re-advertised from one level to the other.
Nodes receiving such an LSP should be able to identify the Prefix (& BIER TLV) that is originally local to the ABR from the other inter (re-advertised) prefix'es.

Unlike SR-ISIS extensions TLV, BIER-ISIS extension TLVs do not have N/R flags.

Hence the only way to identify the prefix type (local or re-advertised) is by having the ABR advertise the "IPv4/IPv6 Extended Reachability Attribute Flags sub-TLV - RFC7794" whenever it leaks the BIER TLVs from one level to another. Is my understanding correct?

Ref from - RFC 7794 - 2.1<https://tools.ietf.org/html/rfc7794#section-2.1>. IPv4/IPv6 Extended Reachability Attribute Flags

       0 1 2 3 4 5 6 7...

      +-+-+-+-+-+-+-+-+...

      |X|R|N|          ...

      +-+-+-+-+-+-+-+-+...

      (upwards or downwards).

Thanks,
Senthil

---

From: Senthil Dhanaraj <[email-masked]>
Date: Sat, 13 Apr 2019 07:48:11 +0530

Thanks Les!
Yes, we'd better raise an errata to fix the text about R flag setting.

Thanks,
Senthil

On Sat, Apr 13, 2019, 1:53 AM Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> There is only the “BIER Info” sub-TLV(sic) which is carried in a Prefix
> Reachability TLV (one of TLVs 135, 235, 236, and 237).
>
>       N flag MUST be set and the *R flag MUST NOT be set*.
>
>
>
> In cases where the prefix is leaked the R flag will be set. The text is a
> holdover from early versions where we had prohibited leaking.
>
> I thought this issue had been discussed and addressed – but I couldn’t
> find any relevant email and clearly the published text has a flaw.
>
> Sigh…
>
>
>
>     Les
>
>
>
>
>
> *From:* Senthil Dhanaraj <[email-masked]>
> *Sent:* Thursday, April 11, 2019 11:03 PM
> *To:* Les Ginsberg (ginsberg) <[email-masked]>; Antoni Przygienda <
> [email-masked]>; [email-masked]; Jeffrey (Zhaohui) Zhang <
> [email-masked]>
> *Cc:* BIER WG <[email-masked]>
> *Subject:* RFC8401 - Question on BIER TLV leaking from one level to the
> other
>
>
>
> Hi Authors,
>
>
>
> Ref from - RFC 7794 - 2.1
> <https://tools.ietf.org/html/rfc7794#section-2.1>. IPv4/IPv6 Extended
> Reachability Attribute Flags
>
>
>
>        0 1 2 3 4 5 6 7...
>
>       +-+-+-+-+-+-+-+-+...
>
>       |X|R|N|          ...
>
>       +-+-+-+-+-+-+-+-+...
>
>
>