Subject: [Bier] ipv6 requirements

From: Mike McBride <[email-masked]>
Date: Mon, 1 Apr 2019 15:15:15 -0700

Hi all,

Thank you for your feedback last week. Per your comments, we've
replaced the problem-statement draft name with a requirements draft.
Besides the name, the only thing we've changed is adding Rajiv as a
co-author. We will now begin to re-work the draft with an emphasis on
requirements.

Tony, Greg, please use this new draft when you send the adoption call.

thanks,
mike

https://datatracker.ietf.org/doc/draft-mcbride-bier-ipv6-requirements/

---

From: Xiejingrong <[email-masked]>
Date: Tue, 2 Apr 2019 12:28:05 +0000

Hi All:

I do think the Requirements (R1 to R7) Eric had listed years before are really instructive, and may be a good start for the discussion:

R1: it shouldn't require hop-by-hop modification of the IP destination address field,  
   [XJR]: normal one-hop replication uses Multicast-Address may be a better way.
R2: and it shouldn't require the BFRs to inspect layer 4,  
   [XJR]: a router(BFR) should do L3 routing-and-forwarding, until a L3 packet is targeting to itself, then it does some 'Tunnel End' actions.
R3: and it shouldn't require changes to layer 4,  
   [XJR]: any change to layer4 means a lot, especially the integrity of the L4 payload. 
R4: and it shouldn't allow a multicast address to be put in the IP source address field,  
   [XJR]: The Source Address should be unicast address, link-local/ULA/Global-unicast.
R5: and it shouldn't assume that bits never get set incorrectly,  
   [XJR]: The bier packet may loop due to bit handling incorrectly, so the TTL should take effect.
R6: and it shouldn't require changes in source address filtering procedures.  
   [XJR]: Keeping IPv6 SA unchanged may be helpful for filtering procedure too.
R7: In addition, it should be possible to use it to support the entire BIER architecture"  
   [XJR]: BIER architecture like Sub-domain/multi-SI/multi-BSL/ECMP should all be supported.

The following are the Concerns (C1 to C3) in ietf104 discussion, and my understanding about each point: 

C1: Should BIER header in IPv6 payload (L4), or in IPv6 extension header (L3) ?
  [XJR] I think BIER header in IPv6 payload is definitely L4 behavior, which differs greatly from L3 behavior.
  The reading of BIER header is reading of L4, and the change to BitString is change to context of L4.
  One example for L4, normal L4 header like TCP/UDP/ICMP all have an upper-layer checksum to include all the payload and the pseudo-IP-header.
  Another example, when IPSEC is used, the payload is included in calculating the Integrity Check Value(ICV), and the ICV has to be re-calculated each time the L4 BitString is changed.
  For L3 solution, who encodes BIER header in an IPv6 extension header (L3), the change of BitString doesn't affect the integrity of L4 payload. 

C2: Should the Destination Address use Link-local address or routable address in case of unicast address ?
  [XJR] use link-local address will lose the capability of multi-hop replication.

C3: Does it violate RFC8200 of IPv6-RFCs to change Destination Address & BitString while keeping the Source Address unchanged ?
  [XJR] It's clear that RFC8200 allows change of Options in IPv6 extension header. 
  The IPv6 source-routing is an example who change DA while keeping SA untouched, just as the BIERv6-unicast.
  It is also a basic principle to keep the IPv6 SA unchanged, so that the Originator of a packet can be known, and the filtering procedures is also clear.
  Besides, having the originator of a packet, one can send ICMP packets to this originator in case like TTL=0.

Appreciate for your discussions !

Thanks,
Jingrong

-----Original Message-----
From: BIER [mailto:[email-masked]] On Behalf Of Mike McBride
Sent: Tuesday, April 02, 2019 6:15 AM
To: [email-masked]
Subject: [Bier] ipv6 requirements

Hi all,

Thank you for your feedback last week. Per your comments, we've replaced the problem-statement draft name with a requirements draft.
Besides the name, the only thing we've changed is adding Rajiv as a co-author. We will now begin to re-work the draft with an emphasis on requirements.

thanks,
mike

_______________________________________________
BIER mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bier