Subject: [Bridge-mib] Support of LAN FCS in Ethernet packet over ATM AAL5.

From: Nurit Sprecher <[email-masked]>
Date: Thu, 27 Jun 2002 10:18:33 +0200

In RFC 2684 on Multiprotocol Encapsulation over ATM Adaptation Layer 5, the
Payload Format for Bridged Ethernet/802.3 PDUs is defined as follows:

                +-------------------------------+
                |    MAC destination address    |
                +-------------------------------+
                |                               |
                |   (remainder of MAC frame)    |
                |                               |
                +-------------------------------+
                |  LAN FCS (if PID is 0x00-01)  |
                +-------------------------------+
 
The LAN FCS option is VC dependent. 
In case that the LAN FCS is supported, duplicate checksum calculations are
performed: one for the AAL5 frame and one for the Ethernet frame.

In what cases is it required/suggested/worth to support the LAN FCS when
transmitting a packet within an AAL5 packet over an ATM network? 

Can a bridge that resides at the end of the ATM, de-capsulate the ATM packet
and transmit the Ethernet packet over a LAN, calculate the LAN FCS and set
it in the Ethernet packet (if required)?

Thanks in advance, 
Nurit Sprecher

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: Nurit Sprecher <[email-masked]>
Date: Thu, 27 Jun 2002 10:29:42 +0200

One more question please. 
In case that the LAN FCS is not supported (e.g. in LLC encapsulation format
the PID is 0x00-07), does the LAN FCS appear in the packet with arbitrary
value? I guess that the LAN FCS does not appear in the packet at all in such
a case. Can you please confirm it?
Thanks again, Nurit.

		 -----Original Message-----
		From: 	Nurit Sprecher  
		Sent:	Thursday, June 27, 2002 10:19 AM
		To:	'Manuel Stol'; PPPoE Mailing List (E-mail)
		Cc:	[email-masked]'; [email-masked]'
		Subject:	Support of  LAN FCS in Ethernet packet over
ATM AAL5.

		In RFC 2684 on Multiprotocol Encapsulation over ATM
Adaptation Layer 5, the Payload Format for Bridged Ethernet/802.3 PDUs is
defined as follows:

		The LAN FCS option is VC dependent. 
		In case that the LAN FCS is supported, duplicate checksum
calculations are performed: one for the AAL5 frame and one for the Ethernet
frame.

		In what cases is it required/suggested/worth to support the
LAN FCS when transmitting a packet within an AAL5 packet over an ATM
network? 

		Can a bridge that resides at the end of the ATM,
de-capsulate the ATM packet and transmit the Ethernet packet over a LAN,
calculate the LAN FCS and set it in the Ethernet packet (if required)?

		Thanks in advance, 
		Nurit Sprecher