Subject: [Bridge-mib] Re: ieee8023-lag-mib : dot3adAggActorSystemPriority and dot3adAggPortActorSystemPriority definition

From: "Les Bell" <[email-masked]>
Date: Thu, 27 Feb 2003 16:16:45 +0000

This is a known bug in the MIB and a fix should appear in the next revision of
the 802.3 spec.
There are a number of similar objects with the same bug.  The range should be
(0..65535) on all of them.  The proposed fix is to deprecate these objects and
replace them with corrected equivalents.  There are some other fixes pending
also.

Les...

"Rohit Rohit" <[email-masked]> on 26/02/2003 22:55:29

Sent by:  "Rohit Rohit" <[email-masked]>

To:   [email-masked]
cc:    (Les Bell/GB/3Com)
Subject:  ieee8023-lag-mib : dot3adAggActorSystemPriority and
      dot3adAggPortActorSystemPriority definition

Hi,

  I am not sure if this is the right group for this question;
  but mail to [email-masked]' does not seem
  to work.

  I see the following inconsistency between the dot3adAggActorSystemPriority
  and dot3adAggPortActorSystemPriority.

  dot3adAggPortActorSystemPriority is defined to be 2 octets; but
  its range is only from 0 to 255. ( IMHO, it should be 0 .. 65535 ).

 > dot3adAggPortActorSystemPriority OBJECT-TYPE
 >   SYNTAX       INTEGER (0..255)
 >   MAX-ACCESS   read-write
 >   STATUS       current
 >   DESCRIPTION
 >       "A 2-octet read-write value used to define the priority
 >       value associated with the Actor's System ID."
 >   REFERENCE
 >       "IEEE 802.3 Subclause 30.7.2.1.2"
 >   ::= { dot3adAggPortEntry 2 }

  while dot3adAggActorSystemPriority is also defined to be
  2 octets; but its range is from 0..65535.

  Any reason for this inconsistency ?

> dot3adAggActorSystemPriority OBJECT-TYPE
>    SYNTAX       INTEGER (0..65535)
>    MAX-ACCESS   read-write
>    STATUS       current
>    DESCRIPTION
>        "A 2-octet read-write value indicating the priority
>        value associated with the Actor's System ID."
>    REFERENCE
>        "IEEE 802.3 Subclause 30.7.1.1.5"
>    ::= { dot3adAggEntry 3 }

Thanks
Rohit

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 28 Feb 2003 03:51:32 +0200

Les,

Did you (or somebody else) propose these fixes through the IEEE 802.3 maintenance mechanism? 

Dan

> -----Original Message-----
> From: Les Bell [mailto:[email-masked]]
> Sent: Thursday, February 27, 2003 6:17 PM
> To: Rohit Rohit
> Cc: [email-masked]; [email-masked]; David Law
> Subject: Re: ieee8023-lag-mib : dot3adAggActorSystemPriority 
> and dot3adAggPortActorSystemPriority definition
> 
> 
> 
> 
>

---

From: "Les Bell" <[email-masked]>
Date: Fri, 28 Feb 2003 09:34:37 +0000

Yes, these fixes are going through the IEEE 802.3 maintenance mechanism.  I do
not know the maintenance reference number, but I provided them with the fixes.

Les...

"Romascanu, Dan (Dan)" <[email-masked]> on 28/02/2003 01:51:32

Sent by:  "Romascanu, Dan (Dan)" <[email-masked]>

To:   Les Bell/GB/3Com, "Rohit Rohit" <[email-masked]>
cc:   [email-masked], [email-masked], David Law/GB/3Com
Subject:  RE: ieee8023-lag-mib : dot3adAggActorSystemPriority and
      dot3adAggPortActorSystemPriority definition

Les,

Did you (or somebody else) propose these fixes through the IEEE 802.3
maintenance mechanism?

Dan