Subject: RE: [Bridge-mib] FW: Please review and comment: draft-ietf-ops-vlanid-tc-mib-00.tx t

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 1 Jan 2004 10:53:49 +0200

VlanIdAssociation is definitely a bad name - there are other 'VLAN associations' it may be confused with. 

Regards,

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of Wijnen, Bert (Bert)
> Sent: 31 December, 2003 6:52 PM
> To: Bridge-Mib (E-mail)
> Subject: [Bridge-mib] FW: Please review and comment: 
> draft-ietf-ops-vlanid-tc-mib-00.tx t
> 
> 
> Any comments?
> 
> Thanks,
> Bert 
> 
> -----Original Message-----
> From: Mark Ellison [mailto:[email-masked]]
> Sent: woensdag 31 december 2003 20:04
> To: Wijnen, Bert (Bert)
> Cc: [email-masked]
> Subject: Re: Please review and comment:
> draft-ietf-ops-vlanid-tc-mib-00.tx t
> 
> 
> Hi Bert,
> 
> Thanks for your reply. 
> 
> I think I'd call a TC with a value range of Integer32 { 0 | 1..4094 | 
> 4095 }  a VlanIdReference or VlanIdAssociation.
> 
> This TC would be useful when defining an object that refers 
> to a vlan.  
> For example, a table where each entry can be associated with 
> none, one, 
> or any vlan.  One alternative, with the existing TCs, would be to use 
> VlanIdOrAny, but have the agent return noSuchInstance when 
> there is no 
> association with a vlan. Another alternative, with the existing TCs, 
> would be to use VlanIdOrNone, and not have use of the special 
> any/4095 
> value.
> 
> Regards,
> 
> Mark
> 
> Wijnen, Bert (Bert) wrote:
> 
> >Sorry for late reaction... but I am now again looking at 
> >this document and the discussion that we had back in October.
> >
> >inline
> >  
> >
> >>-----Original Message-----
> >>From: Mark Ellison [mailto:[email-masked]]
> >>Sent: donderdag 2 oktober 2003 20:12
> >>To: Wijnen, Bert (Bert)
> >>Cc: Mark Ellison; [email-masked]
> >>Subject: Re: Please review and comment:
> >>draft-ietf-ops-vlanid-tc-mib-00.txt
> >>
> >>
> >>Hi Bert,
> >>
> >>I'm wondering if there could be any mib or pib definition 
> requiring a 
> >>range of ( 0 | 1..4094 | 4095 )  for possible values?
> >>
> >>    
> >>
> >Mark, I have not seen anyone react to this as a option that they
> >wanted, so for now I am not going to include it.
> >It can of course always be added later if a need arises.
> >
> >By the way, what woyuld you call/name that TC?
> >
> >Bert
> >  
> >
> >>Regards,
> >>
> >>Mark
> >>
> >>
> >>
> >>    
> >>
> >
> >  
> >
> 
> 
> _______________________________________________
> Bridge-mib mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bridge-mib
> 

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: "Tom Petch" <[email-masked]>
Date: Fri, 2 Jan 2004 11:32:10 -0000

No thoughts on whether the TC should exist or no.

But if it does, then keep the name simple, don't overload the name, the
identifier, with a description of the semantics

ie VlanIdentifier VlanIds VlanId2 .. good
VlanIdOrNone VlanIdOrNoneOrAny VlanIdAssociation   .. bad

Tom Petch

-----Original Message-----
From: Wijnen, Bert (Bert) <[email-masked]>
To: Romascanu, Dan (Dan) <[email-masked]>; Bridge-Mib (E-mail)
<[email-masked]>
Date: 01 January 2004 11:22
Subject: RE: [Bridge-mib] FW: Please review and comment:
draft-ietf-ops-vlanid-tc-mib-00.tx t

>OK, but do you think that the TC specified (none, a specific one, or any)
>is a usefull one to have? ANd if yes, would then VlanIdReference be
>a proper name? Or do you have better names suggestions in that case.
>Would VlanIdOrNoneOrAny be better?
>
>Thanks,
>Bert
>
>> From: Romascanu, Dan (Dan) [mailto:[email-masked]]
>> Sent: donderdag 1 januari 2004 9:54
>> To: Wijnen, Bert (Bert); Bridge-Mib (E-mail)
>> Subject: RE: [Bridge-mib] FW: Please review and comment:
>> VlanIdAssociation is definitely a bad name - there are other
>> 'VLAN associations' it may be confused with.
>>
>> Regards,
>>
>> Dan
>>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 4 Jan 2004 10:47:11 +0200

Yes, the TC is useful. Concerning names, I do not know what VlanIdReference is supposed to mean, but at least it is not confusing like VlanIdAssociation. VlanIdOrNoneOrAny would be better. 

Regards,

Dan

> From: Wijnen, Bert (Bert) [mailto:[email-masked]]
> Sent: 01 January, 2004 1:17 PM
> To: Romascanu, Dan (Dan); Bridge-Mib (E-mail)

---

From: "Tom Petch" <[email-masked]>
Date: Mon, 5 Jan 2004 20:25:29 -0000

I did say overload:-)  DateAndTime I think a good choice of name, quite
short (11 characters) no abbreviations, well known words that are unlikely
to be misspelt or misremembered.  It does not, for example, try to convey
its particular characteristics, such as the accuracy in seconds or the
presentation of the year (which is what distinguishes it from similar TCs).

VlanIdOrNoneOrAny? rather long to always get right; on my Windows client,
the l of Vlan is the same as the I of Id; repetition of Or another
opportunity to get confused; other similar TCs (in Disman) have OrZero as
opposed to OrNone (which is better English IMO)

I respond because I do think this non-technical issue matters, that it is a
sometimes serious mistake when people invent names, making the name
difficult to read and write, say and hear, leading to errors and
misunderstandings, perhaps thinking they will be unable to remember what it
means, which with time is actually the easy part.

Tom Petch
-----Original Message-----
From: Wijnen, Bert (Bert) <[email-masked]>
To: Tom Petch <[email-masked]>; Bridge-Mib (E-mail)
<[email-masked]>
Date: 04 January 2004 10:46
Subject: RE: [Bridge-mib] FW: Please review and comment:
draft-ietf-ops-vlanid-tc-mib-00.tx t

>Inline
>> From: Tom Petch [mailto:[email-masked]]
>> Sent: vrijdag 2 januari 2004 12:32
>> Subject: Re: [Bridge-mib] FW: Please review and comment:
>> But if it does, then keep the name simple, don't overload the
>> name, the identifier, with a description of the semantics
>>
>MMm... if we look at for example DateAndTime TC, does that not give
>similar semantics in the name? I am sure there are many others
>that do so too.
>